This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.40 hours from now. Thank you for your understanding.

This topic contains 8 risposte, has 2 voci.

Last updated by Laura 5 mesi, 2 settimane fa.

Assigned support staff: Laura.

Autore Post
May 5, 2019 at 2:42 pm

raffaellab-2

Salve, purtroppo sono costretta a riaprire un ticket per continui errori della memoria.

Sono abbastanza sicura (direi per un 90%) che il problema sia dovuto al plug-in di wpml.
Conferma di quanto affermo è dato dal fatto che disattivando il plug-in, non ce l'ho.

Nello specifico, quando tento di creare post contenenti una buona dose di dati (immagini, testi, link ecc...) sistematicamente il server si blocca per un eccesso di richiesta di risorse.

Penso (non ho competenze tecniche specifiche in merito al limite di memoria ecc...) di avere rispettato tutti i requisiti minimi richiesti dal plug-in, eppure mi resta impossibile effettuare modifiche al sito.

Allego anche qualche screenshot del cPanel per dare dettagli delle risorse che vengono richieste.
Attendo istruzioni per la risoluzione.

Grazie a presto.

May 6, 2019 at 7:31 am #3745441

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Se c'è un errore 500, ho bisogno di sapere con esattezza di cosa si tratta, quindi ti chiederei di abilitare il debug log di WordPress.
Per farlo inserisci queste righe all'inizio del file wp-config.php dopo il tag di apertura:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

dopodiché riproduci l'errore e dovresti trovare un file debug.log nella cartella wp-content.

Copia le ultime righe qui. Se necessario, rimuovi le informazioni sensibili.

Dalle immagini che hai postato del cPanel, tuttavia, sembrerebbe esserci un problema di memoria, che è stata del tutto utilizzata. Se è questo il caso, l'unica soluzione è utilizzare un piano hosting con più memoria, perché evidentemente non è sufficiente per le necessità del sito.

May 7, 2019 at 8:48 am #3755497

raffaellab-2

Buongiorno Laura,
grazie del riscontro.
Incollo i dati del debug.log

[07-May-2019 08:19:39 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_recent_posts_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-recent-posts.php on line 4
[07-May-2019 08:19:39 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_contact_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-contact.php on line 4
[07-May-2019 08:19:39 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_booking_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-booking.php on line 4
[07-May-2019 08:19:52 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_recent_posts_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-recent-posts.php on line 4
[07-May-2019 08:19:52 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_contact_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-contact.php on line 4
[07-May-2019 08:19:52 UTC] PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; chauffeur_booking_widget has a deprecated constructor in /home/aqonywre/public_html/wp-content/themes/chauffeur/framework/inc/widgets/widget-booking.php on line 4

Ce ne sono molte altre di linee di questo tenore (tutte grosso modo simili), io ho copiato le ultime come indicato.

Non conosco molto bene il linguaggio php ma sembra di capire che sia qualcosa del tema chauffeur che non va. Ma non riesco a comprenderne il motivo. Disattivando il plug-in di wpml non ho questo problema.

Sono piuttosto propensa a credere che ci siano delle interferenze/incompatibilità dei due.

Il piano hosting non penso sia insufficiente, ho fatto un up-grade giusto la settimana scorsa per avere più risorse perché già una settimana fa, installando appunto wpml avevo notato il problema del limite della memoria.

Il supporto tecnico dell'hosting hanno consigliato di verificare con voi perchè appunto la mole di richieste nei report erano veramente "strane" pur avendo effettuato l'upgrade.

Insomma non riesco a credere che un sito che ha un tema e qualche plug-in (non ha chissà quali dati e mole di contenuti ancora perché è in fase di inserimento) abbia bisogno di chissà quale piano hosting.

Allego anche gli screenshot del dettaglio del mio piano.
Grazie a presto.

May 7, 2019 at 10:44 am #3756571

raffaellab-2

Nel frattempo Laura,
sto effettuando anche altre verifiche col fornitore dell'hosting.
Potrebbe essere dato da una qualche incompatibilità della versione php, ma è in fase di analisi.

Appena ho dei riscontri, aggiorno.

May 7, 2019 at 11:15 am #3756921

raffaellab-2

Salve Laura,
probabilmente abbiamo risolto ma prima di ritenere chiuso il ticket attendo che mi dia conferma il mio fornitore hosting.

Per il momento è stato sufficiente passare dalla versione 7.1 alla 7.2 del php.
Ma non mi hanno dato spiegazioni sul perchè disabilitando wpml il problema non si poneva.

Per cui potrebbe essere che non c'entrava sin dal principio il vostro plug-in ma vorrei avere conferma da parte loro, così da avere un quadro chiaro.

May 7, 2019 at 3:07 pm #3759593

raffaellab-2

La vostra latitanza crea praticamente un monologo 😀

Ad ogni modo allego la rispsota del mio fornitore hosting:

"Salve,

purtroppo non conosciamo il plugin indicato, dovrebbe verificare se esiste una comparativa dei requisiti hosting richiesti.

Nessun problema per la richieste che avanza: come indicato, sull'hosting la versione di php era impostata su ereditata e con i parametri di default base, molto probabilmente il cambio di versione ha implicato che alcuni valori venissero riconosciuti e letti dal plugin in maniera consona.

Dallo screenshot di risposta del supporto tecnico, abbiamo potuto supporre che il problema riscontrato fosse collegato ad un utilizzo di risorse PHP maggiori rispetto a quelle impostate, da qui la modifica effettuata.
La risoluzione potrebbe essere anche dovuta ad altre impostazioni, che nello switch di versione hanno inciso su alcune risorse di cui il plugin aveva bisogno.
In cPanel >> Editor INI Multi PHP >> selezionare il dominio dal menu a tendina, può verificare tutti i parametri modificati.

Confronti tali valori con i requisiti del plugin per capire meglio, anche con il supporto dell' assistenza, in modo che in futuro non possa riscontrare ulteriori anomalie.

Rimaniamo a disposizione

Cordiali Saluti,"

Insomma, non conferma ne smentisce l'ipotesi che sia stato o meno wpml a richiedere le risorse, ad ogni modo per il momento questo switch di versione e di dati sembrano essere risolutivi.
Il sito è stabile e riesco ad effettuare le modifiche alle pagine/post ecc...

Se per scrupolo potete confermare che questa procedura sia la migliore attuabile per la risoluzione, sarei più sicura.
Grazie a presto.

May 8, 2019 at 9:08 am #3764835

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

scusa la mancanza di risposte ma non lavoro il martedì.

Il requisito minimo di PHP per WPML è al momento la 5.6 (aumenterà a breve in quanto anche WordPress aumenterà i suoi requisiti minimi) ma può succedere che a causa di una particolare configurazione del sito, dato dall'insieme di plugin + tema, sia necessaria una versione superiore.

Per capire esattamente come mai sia successo avrei bisogno di inviare una copia del sito agli sviluppatori, ma dato che il problema al momento è risolto non so se e quando potrebbero avviare l'indagine. Discorso diverso ovviamente se il problema si ripresentasse.

May 8, 2019 at 9:51 am #3765271

raffaellab-2

Ciao Laura,
si confermo, per ora il sito è ok, ho effettuato diverse modifiche nella giornata di ieri e non ho mai riscontrato problemi.
Considerando appunto che dal mio punto di vista la problematica è rientrata, potremmo sorvolare, a meno che non sia di utilità comune e per il vostro team effettuare tale verifica.
Resto a disposizione dunque 🙂
A presto.

May 8, 2019 at 2:26 pm #3767727

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Grazie, contattaci di nuovo in caso di ulteriori problemi.