This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 risposte, has 2 voci.

Last updated by Vincenzo 2 anni, 2 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
September 13, 2017 at 12:58 pm #1370298

world-capitalW

quando cerco di aprire un articolo o una pagina nella lingua secondaria mi esce errore

"www.xxx.xx ti ha reindirizzato troppe volte" - "err_to_many_redirects"

allego screen shot

come posso risolverlo?

grazie

September 13, 2017 at 6:18 pm #1370834

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket.

Provando a salvare i Permalink nel sito si ottiene il messaggio mostrato nello screenshot che ho allegato.

1. Puoi confermare che l'operazione descritta è stata effettuata?

2. Potresti aggiornare WordPress e tutti i plugin alle ultime versioni?

Grazie

September 14, 2017 at 9:39 am #1371598

world-capitalW

si sotto ho quelle voci che mi hai allegato
bisogna fare prima qualche altra modifica o procedo con aggiornamento di wP?

September 14, 2017 at 3:48 pm #1372150

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

per risolvere il problema dovrebbe essere sufficiente effettuare le operazioni descritte nello screenshot che ho allegato (Impostazioni -> Permalink).

Una volta effettuate quelle operazioni si può effettuare l'aggiornamento di WordPress e dei plugin.

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

September 18, 2017 at 9:38 am #1374892

world-capitalW

ho aggiornato WP e tutti i plugin, salvato permalink , ma da lo stesso errore..

mi puoi aiutare?
grazie

September 18, 2017 at 9:42 am #1374906

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Buongiorno,

1. Puoi postare qui il contenuto del file .htaccess che si trova nella cartella principale dell'installazione di WordPress?

2. Se fosse possibile adesso vorrei anche chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

- Un BACKUP dei file e del database è fortemente consigliato -

Privacy e Sicurezza:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Grazie

September 18, 2017 at 12:16 pm #1375158

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

dando un'occhiata al sito si può vedere che il problema non riguarda WPML ma la configurazione del sito.
- Infatti disattivando WPML il problema persiste.

Prima di consigliare una possibile soluzione ho bisogno di maggiori informazioni:

1. Qual'è il dominio effettivo del sito WordPress?
- Andando in Setting -> General si vede che il WordPress Address (URL) ed il Site Address (URL) usano domini diversi.
- Questo provoca inoltre qualche problema con i font nella homepage.

2. Verso quale cartella sono puntati i domini?
- Se i domini fossero puntati direttamente sulla cartella wordpress non ci sarebbe più bisogno di includere la cartella wordpress nel WordPress Address (URL).
- Inoltre questo risolverebbe probabilmente il problema del file .htaccess non scrivibile.

3. Se si selezionano i Permalink Plain in Settings -> Permalinks il problema si risolve.

Allego un po' di documentazione di WordPress

Documentazione relativa:
- https://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
- https://codex.wordpress.org/it:Modificare_l%27URL_del_sito
- https://codex.wordpress.org/Using_Permalinks

September 18, 2017 at 1:12 pm #1375247

world-capitalW

il sito reale è hidden link
è salvato nella cartella worldcapitalblog.it/wordpress

era stato attivato un sistema di redirect sul server che ospita il dominio worldcapital.it che quando riceve le chiamate per worldcapital.it/blog/xxx le manda a worldcapitalblog.it/xx

tutto funzionava regolarmente anche quando abbiamo iniziato a sentirci per il problema dell'altro ticket.. https://wpml.org/it/forums/topic/wpml-non-dispone-di-alcuni-record-delle-tabelle-delle-lingue-e-non-puo-funzionar-6/ (anche se WPML non funzionava perchè in errore)

dopo che abbiamo fatto un po' di modifiche con te per risolvere il problema di WPML, che si è risolto, si è presentato questo problema....

non abbiamo fatto nessuna modifica al sistema di redirect

come si può risolvere?
grazie

September 18, 2017 at 3:27 pm #1375452

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Grazie per i dettagli.

Dalla descrizione credo sia meglio impostare il WordPress Address (URL) ed il Site Address (URL) usando lo stesso dominio "worldcapitalblog.it".

Una volta risolto il problema per il dominio principale, potrebbe essere utile configurare entrambi i domini sullo stesso server.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

September 18, 2017 at 3:45 pm #1375472

world-capitalW

grazie per la risposta ma scusami prima funzionava i vari link e dovrei tornare in quelle condizioni che abbiamo strutturato.

purtroppo non posso promuovere worldcapitalblog per diversi motivi aziendali e deve essere una sottocartella del dominio principale per posizionamento nel web, inoltre non possiamo metterlo sullo stesso server perchè il sito principale è in windows e il blog in wordpress è in linux...

September 18, 2017 at 4:50 pm #1375552

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

in questo caso si può utilizzare l'altro dominio. Credo che il problema sia causato dall'uso contemporaneo di entrambi i domini in Settings -> General.

Per semplificare la risoluzione del problema ti consiglio di disattivare WPML e tutti i plugin che vanno ad effettuare redirect o modificano i Permalink.

Riguardo al ticket precedente non ricordo sia stata effettuata qualche operazione che interferisca con i Permalink.
- Puoi darmi qualche dettaglio in più?

Grazie

September 19, 2017 at 9:00 am #1376140

world-capitalW

ciao ho disattivato il plugin WPML e un plugin "Advanced Permalinks" (che non so cosa serve)
ma il problema resta...

la cosa strana che fino a ieri il problema che usciva era 404 adesso è 505
ricercando in internet ho eseguito anche l'aggiornamento dei permessi sui file sul server di aruba (come ho visto su questo articolo hidden link)

ma anche cosi non si è risolto il problema..

allora ho provato come mi hai detto a mettere lo stesso dominio nelle impostazioni generali, ma da errore comunque (adesso l'ho lasciato impostato così che tu possa vedere)

cosa altro si può fare?

September 19, 2017 at 1:52 pm #1376596

world-capitalW

??
urgente

abbiamo tutto bloccato!

September 19, 2017 at 2:10 pm #1376624

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve,

io potrei anche dare un'occhiata non appena possibile ma la configurazione di WordPress non è standard e il problema si presenta anche con WPML disattivato.
Ritengo che l'intervento del servizio di hosting che ha la possibilità di intervenire anche nella configurazione del server e dei redirect sia più indicata in questo caso.
Inoltre loro hanno a disposizione il log del server web che fornisce maggiori informazioni sulla causa del problema.

Fammi sapere l'opinione del supporto del servizio di hosting al riguardo ed eventualmente il log degli errori del server web.

Grazie

September 19, 2017 at 2:41 pm #1376672

world-capitalW

il problema errore 505 l'ho risolto con il provider hosting (c'era il file .htaccess)

adesso se non attivo il plugin wpml si aprono gli articoli interni
se invece attivo il plugin non si aprono..

adesso puoi verificare tu?
grazie