This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problema: Dopo l'installazione di WPML è comparso l'errore "There is a problem with the String Translation table in your site" Soluzione: In alcuni casi si tratta di un falso positivo. Specialmente nel caso di siti con Dynamic cache e Memcache Prova a risolvere seguendo questa procedura ❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌ 1. Cancella tutta la cache tramite i controlli del plugin di cache (Purge) 2. Segui i passaggi descritti in questo articolo per creare le tabelle mancanti: - https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/ 3. Rimuovi la key "wpml_string_table_ok_for_mo_import" dalla tabella wp_options del database.

Se il problema persiste, aggiungi un messaggio in Inglese alla fine del ticket allegato qui sotto chiedendo di attivare una risposta privata per inviare il database. - https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/

Etichettato: 

This topic contains 5 risposte, has 2 voci.

Last updated by davidea-6 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
October 1, 2018 at 10:28 pm #2779610

davidea-6

Tell us what you are trying to do?
Dopo installazione è comparso l'errore. Nel db sono presenti le tabelle icl_strings. Nessuna stringa traducibile in String Translation.

Is there any documentation that you are following?
https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/

Is there a similar example that we can see?

What is the link to your site?
hidden link

October 2, 2018 at 7:36 am #2780550

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

In alcuni casi si tratta di un falso positivo.

Puoi verificare se seguendo questa procedura il problema si risolve?
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

1. Segui i passaggi descritti in questo articolo per creare le eventuali tabelle mancanti:
- https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

2. Rimuovi la key "wpml_string_table_ok_for_mo_import" dalla tabella wp_options del database.

Se il problema persiste, aggiungi un messaggio in Inglese sull'ultima pagina del ticket allegato qui sotto chiedendo A George di attivare una risposta privata per inviare una copia del database.
- https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie

October 2, 2018 at 8:16 am #2780660

davidea-6

Ho già eseguito tutti i passaggi descritti prima di aprire il ticket compresa la richiesta a George ma per ora non ho ricevuto nessun contatto. Come avviene la procedura invia una mail all'indirizzo di contatto del profilo?
Grazie

October 2, 2018 at 8:21 am #2780664

davidea-6

Ho visto ora che ha postato una risposta nel forum dicendo che sta approntando una risposta privata ma ancora non vedo nulla sul mio profilo, devo tenere d'occhio la mail o potrò visualizzarla dal sito WPML?
Grazie e scusa il disturbo ma non leggo io direttamente la mail registrata su WPML e quindi mi devo organizzare di conseguenza.
A presto

October 2, 2018 at 11:35 am #2781270

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

ho letto la risposta di George nel ticket. La risposta privata dovrebbe essere già attiva nel forum.

Quando andrai a rispondere, troverai dei campi aggiuntivi in cui inserire il link al database.

Se non vedi i campi privati non aggiungere il database per evitare che appaia nel forum pubblico.

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie

October 2, 2018 at 9:04 pm #2782809

davidea-6

My issue is resolved now. Thank you!