This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 25 risposte, has 2 voci.

Last updated by pasqualeD 1 giorno, 9 ore fa.

Assigned support staff: Alejandro.

Autore Post
November 2, 2019 at 7:23 pm

pasqualeD

Buongiorno, ho diversi problemi :

Per farvi fare dei test senza guastare il sito on line ho creato un'area di staging :
hidden link

le credenziali di accesso sono le stesse del sito on line

In WPML/Traduzioni stringhe visualizzo questo :
Warning: fopen(/home/tabacch1/public_html/wp-content/plugins/wp-optimize/wp-optimize.php): failed to open stream: No such file or directory in /home/tabacch1/public_html/wp-includes/functions.php on line 5573

Warning: fread() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5576

Warning: fclose() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5579

Warning: fopen(/home/tabacch1/public_html/wp-content/plugins/rvg-optimize-database/rvg-optimize-database.php): failed to open stream: No such file or directory in /home/tabacch1/public_html/wp-includes/functions.php on line 5573

Warning: fread() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5576

Warning: fclose() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5579

Warning: fopen(/home/tabacch1/public_html/wp-content/plugins/woocommerce-jetpack/woocommerce-jetpack.php): failed to open stream: No such file or directory in /home/tabacch1/public_html/wp-includes/functions.php on line 5573

Warning: fread() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5576

Warning: fclose() expects parameter 1 to be resource, bool given in /home/tabacch1/public_html/wp-includes/functions.php on line 5579

November 5, 2019 at 12:03 pm #4888579

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!

Da questo errore sembra che il problema sia Jetpack. potresti disattivarlo per vedere se il problema si risolve?

November 5, 2019 at 1:23 pm #4889439

pasqualeD

Ciao Alejandro.
Anche io avevo avuto l'impressione che si trattasse di jetpack e infatti ho creato un area di staging per fare le prove. Ho disattivato tutti i plugin, jetpack compreso e il problema persiste.

November 5, 2019 at 5:09 pm #4891943

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi confermi che su quel sito di staging non ci sono cache a livello di server? per essere sicuro puoi sempre chiedere al tuo hosting.

Fammi sapere per capire come procedere.

Saluti.

November 6, 2019 at 1:34 pm #4898959

pasqualeD

Ciao Alejandro. il provider è siteground e come sai ha un sistema proprietario per la gestione della cache. Inoltre è attiva anche la gestione della cache mediante cloudflare, oltre al plugin installato sgoptimizer

November 6, 2019 at 2:33 pm #4899223

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, quindi in questo caso abbiamo il cache dinamico di siteground + Cache del server + Cache di cloudflare.

Potresti pulirli tutti e disabilitarli finché non finiamo di lavorarci? per disabilitare quello di cloudflare basta mettere grigia la nuvoletta per questo dominio, così funzionerà ancora ma non userà le cose di cloudflare.

November 6, 2019 at 2:43 pm #4899287

pasqualeD

Per site ground ci sono 3 livelli di cache però.......ti ho dato un informazione errata, ovvero......quanto prima esposto è attivo sul sito on line, mentre sullo staging.........non ci dovrebbe essere la cache.....e non è attivo CDN (Cloudflare) e di conseguenza nemmeno la cache di cloudflare. C'era attivo il plugin di sg optimizer che ho disattivato.

P.s.

Nel primo post, potresti nascondere o cancellare tutti quei link?

November 6, 2019 at 3:16 pm #4899843

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, sto controllando per vedere cosa succede e tranquillo per i link, tutti i link che pubblicherai qui sono nascosti e soltanto noi supporter e te (autore del ticket) potremo vederli.

November 6, 2019 at 3:41 pm #4899945

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Allora come prima cosa, cambia questa riga di codice nel tuo file wp-config.php:

define('FS_CHMOD_FILE',0755);

per

define('FS_CHMOD_FILE',0644);

(l'ho già fatto io per te)

per il resto, non vedo più nessun errore né sul sito né sullo staging e anche se ho attivato il debug log, non vedo neanche che si creino i log.

Per controllare questo errore e per cercare di riprodurlo sono andato su WPML > Traduzione di stringhe visto che da quello che ho capito era lì che vedevi l'errore, giusto?

Fammi sapere come va.

November 6, 2019 at 5:08 pm #4900561

pasqualeD

Ciao Alejandro, infatti ora visualizzo correttamente. Infinitamente Grazie!
Sul file wp-config, hai impostato il permesso 0644, mentre il plugin di Sicurezza mi consiglia di impostare 0640, come immagine allegata. Qual'è la soluzione migliore?
Ti assicuro inoltre che non ho mai modificato quei permessi, è da un po' di tempo che ho vari problemi con WPML, uno si è risolto con la nuova versione ma gli altri problemi sono ancora presenti.

Ad esempio ho un grosso problema ma non so dirti se sia dovuto a WPML, magari se fai qualche verifica......mi saresti di grosso aiuto :

In pratica mi ritrovo la tabella del database : POST_META improvvisamente aumentata di dimensione circa 270 MB (Peso Attuale). Quando ad ottimizzare ma sopratutto riparare la tabella.....(Direttamente da PHP ADMIN) .il processo non viene concluso, si interrompe con un errore 500. Inoltre........se vado a visualizzare il sito, non visualizzo più le immagini...non c'è più il menù....e tanti contenuti. Quindi sono stato costretto ad effettuare un ripristino (Prima di ottimizzare avevo fatto un backup completo e manuale direttamente da CPanel di Site Ground...lo faccio sempre per sicurezza) ed ha impiegato diversi minuti quando in genere è un'operazione che faccio in meno di un minuto.
riesci a capire cosa sta succedendo senza toccare il sito ma provando sullo staging? (C'è un database apposta per lo staging)

Ho anche un topic aperto....mi sta seguendo Laura.....ma non riesco ad esportare il sito........anche li...riesci a capire cosa sta succedendo senza toccare il sito ma provando sullo staging?

November 7, 2019 at 11:06 am #4905133

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Puoi anche aggiungere il permesso 0640, basta che non sia il 0755 o 0750 che sono per le cartelle invece.

Conosco il problema che menzioni del database e infatti c'è qualche problema con il DB, neanche io so se possa essere legato a WPML, ma quando Laura ha provato a caricare il database manualmente, ha avuto un sacco di problemi.

Stiamo lavorandoci ma ti risponderà lei, non ti preoccupare.

November 7, 2019 at 7:49 pm #4909847

pasqualeD

Grazie Alejandro.
Il problema del errore 500 su database è una cosa , mentre il problema delle traduzioni dei prodotti che sta affrontando Laura è un altro. Laura non sa di questo problema dell'errore 500. Te l'ho segnalato perchè avendo avuto diversi problemi con WPML, tra cui il fatto che non si riusciva ad aggiornare......posso pensare l'improvviso aumento di peso del database e che non si riesca ad ottimizzare e riparare...possa essere ricondotto a tutti i problemi avuti ultimamente con wpml ma.....preferisco che indagate voi.

November 8, 2019 at 11:52 am #4912993

pasqualeD

N.B. ho creato nuovamente lo staging ed non è più staging1 ma staging2

November 8, 2019 at 12:04 pm #4913049

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!

Allora, ho visto qual'è il problema ed è cloudflare. hai il "rocket loader" attivo che ti sta creando problemi di timeout costanti (infatti sono riuscito ad entrare soltanto una volta poco fa, per il resto ho avutoproblemi anche per accedere al sito!) oltre a errori che forse non sono visibili (li vedi dall'inspector).

Ti chiedo di disabilitare il rocket loader da cloudflare, poi di pulire il cache e per ultimo pulisci anche tutti i cache del sito originale. aspetta 5 minuti e poi vedrai che tutto sarà apposto di nuovo.

Ti consiglio di non usare nessun tipo di caching per parte di cloudflare visto che con siteground dovresti avere le stesse cose che funzionano anche bene.

Poi, per quanto riguardano l'errore 500 (e non 504 = timeout), quello non dovrebbe c'entrare con WordPress per niente, invece dovrebbe essere un problema di server direttamente quindi i ragazzi di siteground sicuramente ti aiuteranno a scoprire il problema(il loro supporto è veramente buono).

Purtroppo non ho potuto fare quasi niente, perché appena sono entrato al database tramite adminer (con il file adminer.php), l'errore del rocket loader mi ha fregato e appena sono entrato, ho potuto soltanto fare un dump del database e subito dopo è entrato in errore 504 per timeout quindi non sono neanche riuscito a vedere la tabella postmeta del sito originale.

Se ti serve ho caricato il dump del database che sono riuscito a scaricare prima dell'errore nel sito e l'ho caricato nel root (tabacchi1_ss.sql.gz)

November 8, 2019 at 12:06 pm #4913051

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ah si, ho trovato una buona guida per l'ottimizzazione e pulizia del database: https://premium.wpmudev.org/blog/optimizing-your-wordpress-database-a-complete-guide/

Puoi provare a seguirla.

Saluti.