This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.11 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I want to translate Rooms custom post type (descriptions and titles).

Solution: It seems you are managing Rooms in your site as Custom Post Type, you need to enable "translate" option for custom post type Rooms.

Go to WPML >> Settings >> Multilingual content setup tab. Scroll down to custom post type box, enable translate option for Rooms and click save button.

Then go to Rooms menu >> there will be a + icon, you need to click on the + icon to translate it to secondary language.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

This topic contains 4 risposte, has 2 voci.

Last updated by Noman 3 mesi, 3 settimane fa.

Assigned support staff: Noman.

Autore Post
June 19, 2019 at 5:36 am #4048033

francescoP-43

I realized that there is another thing I can't translate. Everything concerning the rooms (descriptions and titles) is not detected. Can I ask you to help me again for this last (I hope) question?

June 19, 2019 at 5:46 am #4048069

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. It seems you are managing Rooms in your site as Custom Post Type, you need to enable "translate" option for custom post type Rooms.

Go to WPML >> Settings >> Multilingual content setup tab. Scroll down to custom post type box, enable translate option for Rooms and click save button.

Then go to Rooms menu >> there will be a + icon, you need to click on the + icon to translate it to secondary language.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

Please let me know if this resolves your issue or you need further assistance.

Thank you

June 19, 2019 at 8:26 am #4049533

francescoP-43

My issue is resolved now. Thank you!

June 19, 2019 at 8:40 am #4049587
francescoP-43

Hi, now I have seen that the translations actually work, but in the English version page the room image is not displayed, only the translated text is seen but without the image. Maybe I need to enable something else?

I nuovi thread creati da Noman e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/room-image-is-not-displayed/

June 19, 2019 at 9:23 am #4050031

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For this new issue, I have created a new ticket since this is a separate issue. Here is the link to the new ticket:
https://wpml.org/it/forums/topic/room-image-is-not-displayed/

You may mark this ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.