This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 10 risposte, has 2 voci.

Last updated by stefanoM-25 1 settimana, 5 giorni fa.

Assigned support staff: Alejandro.

Autore Post
September 30, 2019 at 10:29 am #4663691

stefanoM-25

Sto tentando di: traduttre un post

Link a una pagina dove è possibile vedere il problema:

Mi aspettavo di vedere: la schermata per la traduzione

Invece ho ottenuto: un errore fatale

September 30, 2019 at 3:19 pm #4665925

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Sembra che per qualche ragione non ci sia la cosa più importante in un post: la lingua originale.

❌ Prima di procedere, ti consiglio di fare un backup completo del tuo sito ❌

Vai sul menu WPML > Assistenza > Risoluzione dei problemi
Premi i seguenti pulsanti, e controlla ad ogni premuta di pulsate se il problema si è risolto:
• "Cancella la cache di WPML"
• "Rimuovi dalle tabelle delle traduzioni le voci non correttamente collegate"
• "Correggi il confronto di element_type"
• "Inserisci informazioni sulla lingua"
• "Correggi l'assegnazione del tipo di articolo per le traduzioni"

Fammi sapere come va e se il problema si risolve, ti ringrazierei tantissimo se potessi dirmi quale opzione ha risolto il problema. Altrimenti possiamo provare altre soluzioni.

October 1, 2019 at 7:57 am #4669299

stefanoM-25

Il problema persiste anche dopo aver eseguito le tue istruzioni

October 1, 2019 at 11:15 am #4671549

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi sa che prima di continuare, avrò bisogno di accesso al tuo sito (e anche delle credenziali FTP visto che se il sito crasha devo poter risistemarlo velocemente).

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

Poi, mi confermi che questo ti succede soltanto quando attivi String Translation en Translation management? anche quando tutti gli altri plugin sono stati disattivati?

Se non puoi confermarmelo (forse perché non lo sai, ad esempio), ti chiedo di disattivare tutti i plugin velocemente, attivare WPML e gli add-on e poi provare a vedere se il problema capita ancora dopo aver seguito questa procedura. questo mi aiuterà ad isolare il problema più velocemente.

Saluti.

October 1, 2019 at 4:29 pm #4674009

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ho provato ad accedere con le credenziale fornitomi però purtroppo mi dice che non esiste l'utente. potresti controllarle, gentilmente?

October 2, 2019 at 8:49 am #4677943

stefanoM-25

Ciao, sei riuscito ad accedere con le nuove credenziali che ti ho rifornito ieri?

October 2, 2019 at 9:30 am #4678297

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Si. e sto controllando il sito per trovare cosa sta succedendo.

Ti aggiorno appena ho novità.

October 2, 2019 at 9:55 am #4678761

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, mi sa che l'utente che hai assegnato al database non ha tutti i privilegi perché se controlli il log di debug, compare che ci sono accessi negati e per alcune query, il che spiega perché non riesci a fare certe cose.

è strano che tu non abbia avuto problemi dello stile "Problem stablishing Database" (quando vai a diverse parti del sito) visto che di solito è il caso di queste situazioni.

Ti consiglio di fare 2 cose:

1) cambia la password dell'utente e aggiornala sul file wp-config.php
2) Aggiungi tutti i privilegi all'utente che hai assegnato al tuo database.

Fammi sapere se questo risolve il problema.

October 3, 2019 at 7:16 am #4685007

stefanoM-25

Ciao, ho aperto un Ticket presso il nostro provider e mi risponde così
"l'utente ha già disponibilità di gestione del relativo databasse. Quali altri permessi occorrono sul database?"
cosa gli rispondo?

October 3, 2019 at 9:23 am #4686265

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

L'errore che ti compare o che al meno compariva prima era che era stato negato al plugin di scrivere le query sul database. e di solito questo succede quando ci sono dei privilegi dell'utente del database che mancano.

Al momento vedo che WPML è attivo e anche i suoi add-on. ho provato a creare un post e a tradurlo usando il translation editor e sembra che tutto funzioni (vedi: "test" tra gli articoli).

Mi potresti dire se per caso c'è altro che devo fare per riprodurre il problema?

October 7, 2019 at 7:23 am #4704959

stefanoM-25

My issue is resolved now. Thank you!