This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 risposte, has 2 voci.

Last updated by Alejandro 4 mesi, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
May 31, 2019 at 7:01 am #3928169

pasqualeD

Buongiorno, all'interno del pacchetto del tema premium....c'era anche questo plugin : FREQUENTLY BOUGHT TOGETHER.

All'interno del editor dei prodotti in italiano......per un prodotto "X" seleziono quei prodotti che mi interessano "y", "z"...etc; Ma quando poi visualizzo il prodotto "X" in inglese........il prodotto "X" è tradotto in inglese (ovviamente) ma....i prodotti "y", "z"...etc; sono visualizzati in lingua italiana.

Sinceramente in questo momento...il plugin sembra essere non più compatibile con la mia versione di Woocommerce e WordPress, inoltre se ho capito bene........la compatibilità con con WPML è fornita solo con la versione premium del plugin. Vi scrivo per capire se è un problema sul mio sito, oppure effettivamente se è un problema del plugin. Inoltre avete da consigliarmi un plugin sicuramente compatibile con WPML?
Grazie!

May 31, 2019 at 7:47 am #3928287

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

1) la prima cosa che devi vedere è se per questo plugin esiste una documentazione che riguarda la traduzione, questo per capire i passaggi che si devono eseguire prima di vedere tutto tradotto. In questo caso la documentazione che ho trovato è:
hidden link

2) Tutti i plugin di caching vanno disattivati mentre si fanno le prove, così ti assicuri di vedere le cose giuste, gli elementi giusti e funzionando correttamente (molto importante. dopo che disattivi tutto, assicurati che il server abbia le sue opzioni di caching disattivate e pulite e poi aspetta 20-30 minuti prima di vedere i cambiamenti, perché a volte ci mette un po' a farti vedere le cose "reali" )

3) In WPML > Lingue troverai una opzione "Auto Adjust ID for better compatibility", abilitala visto che di solito questo aiuta con i plugin come quello tuo

4) Sempre in WPML > Lingue troverai anche una opzione "Store a language cookie to support language filtering for AJAX", abilitala se non è già abilitata.

Questo è quello che mi viene in mente per iniziare.

Fammi sapere come va.

May 31, 2019 at 8:21 am #3928443

pasqualeD

Ciao Alejandro, i punti 3 e 4...erano già abilitati.
Se può esserti di aiuto, ho notato due cose :
Nel prodotto tradotto in inglese, dove mi compaiono i titoli dei prodotti in italiano....se clicco su di uno di quei prodotti (Pur avendo il titolo initaliano).....quando clicco il prodotto lo visualizzo in inglese.

C'è una nuova cosa da dire che ho scoperto ora.......proprio guardando i link che mi hai inviato e ho capito che......non stavo utilizzando il plugin ma forse una funzionalità interna al tema.

May 31, 2019 at 3:30 pm #3931731

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Allora potrebbe essere un problema compatibilità, sono comuni questi errori in questi plugin (related post/product) o su quelli dei bundle.

Potresti riprodurre il problema qui? --> hidden link

Se il problema è davvero un problema di compatibilità, dovrò inviarlo al nostro team di sviluppatori.

Saluti,

May 31, 2019 at 9:28 pm #3933403

pasqualeD

Ho provato, ma la situazione è peggiore : in pratica sul prodotto in inglese.....non visualizzo nemmeno i prodotti che ho collegato nel prodotto in italiano.

Ho scelto il prodotto : Vneck Tshirt IT

Poi ho fatto un altro espertimento. Anzichè partire da un prodotto in Italiano...sono partito da un prodotto in inglese. Quando selezione il prodotto da collegare......posso visualizzare solo prodotti in Italiano...ovviamente poi nel corrispettivo prodotto italiano........non viene visualizzato il prodotto collegato.
Questa prova l'ho fatta sul prodotto : Tshirt EN

Anche se inserisco i prodotti due volte, una volta in quelli in italiano e poi in quelli inglesi...come puoi vedere visualizzo sempre e soltanto i prodotti IT (come prodotti collegati)

June 3, 2019 at 7:42 am #3939859

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Ho controllato i plugin che hai installato sul sito e ricordo che mi avevi detto che il plugin che stava creando problema non era più il YITH's WooCommerce Frequently Bought together, e che invece si tratta di una opzione del tema.

Mi sapresti dire dove si trova quest' opzione (se si puo' attivare, disattivare, modificare) perché devo assicurarmi di sapere come funziona e devo anche fare alcuni test prima di poterlo inviare ai nostri sviluppatori.

Grazie in anticipo.

June 3, 2019 at 7:49 am #3939915

pasqualeD

si ti confermo, non è il plugin YITH's WooCommerce Frequently Bought together, ma è un opzione del tema che avendo lo stesso nome mi ha creato confusione. Non credo che sia disattivabile. Comunque la configurazione la trovi all'interno del singolo prodotto. è molto semplice da utilizzare........basta cercare i prodotti.

June 3, 2019 at 3:52 pm #3944001

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie mille dell'informazione.

Sto facendo alcuni test per cercare di capire il perché dei problemi.

ti terrò aggiornato.

June 4, 2019 at 3:15 pm #3953195

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ho controllato per bene il problema e tutto succede per un custom field "mf_pbt_product_ids" che in effetti non funziona molto bene.

Ho inviato il caso al nostro sviluppatore e nel frattempo ti ho trovato un workaround:

1) Abilita l'editor di traduzione per i prodotti di WooCommerce o al meno per i prodotti interessati.

2) vai su un porodotto e scendi quasi fino alla fine della pagina finché non trovi la sezione "Impostazione contenuto Multilingua" e poi cerca "Campi personalizzati"

3) Cambia il capo personalizzato "mf_pbt_product_ids" da "Do not translate" a "translate" e poi aggiungi i prodotti che vuoi combinare (frequently bought together)

4) Salva la pagina e traducila usando l'editor di traduzione

5) Nel editor troverai dei numeri, questi numeri sono gli ID dei prodotti, quindi basterebbe cambiarli per quelli giusti (quelli in Inglese) e cos' al meno potrai farli vedere correttamente sul front-end

Fammi sapere come va.

June 4, 2019 at 4:06 pm #3953583

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I nostri sviluppatori hanno trovato una soluzione al problema:
Vai su:
wp-content/themes/martfury/inc/frontend/woocommerce.php e subito dopo la riga 2332 inserisci:

 $product_id = apply_filters('wpml_object_id', $product_id, 'product' );

- Poi vai su WPML > Settings > Custom field translation
- cerca "mf_pbt_product_ids" e cambia l'impostazione su "copia" e salva.

Ora dovresti avere tutti i frequently bought together mostrati correttamente.

Saluti.

June 4, 2019 at 4:15 pm #3953599

pasqualeD

Ciao Alejandro...gentilissimo come sempre. Se faccio questa operazione che mi chiedi.al prossimo aggiornamento del tema......sarò di nuovo nella stessa situazione. Posso contattare il supporto tecnico e riferire la soluzione che avete trovato?
Potete contattare lo sviluppatore del tema e chiedergli di fare questa modifica per il prossimo aggiornamneto del tema?

June 4, 2019 at 4:31 pm #3953665

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Esatto, probabilmente il nostro team lo riferirà appena anche tu mi confermerai che è tutto apposto, e se poi, certo, riferisciglielo pure.

Sarebbe bello se gli autori si iscrivessero al piano go global che offriamo, che è un modo per aiutare gli sviluppatori ad essere compatibili con noi (e poi è gratis quindi non fa mai male!)

Quindi puoi anche riferigli questo link: https://wpml.org/documentation/theme-compatibility/go-global-program/

basta che ci scrivono lì e cominceremo a collaborare con loro per rendere il tema il più compatibile possibile!

Comunque, appena mi confermi che funziona anche a te, glielo dirò ai nostri team così provano a mettersi in contatto con loro per rendere questo codice, uno permanente nel loro tema.

Saluti.

June 4, 2019 at 4:50 pm #3953797

pasqualeD

Per precauzione ho provato nella mia area di staging.
La riga 2332 era impegnata e quindi l'ho scritto un po' più in basso come l'immagine allegata.
Il parametro : "mf_pbt_product_ids" era già su copia.
Ma. il risultato non è cambiato : i prodotti acquistati insieme, nella versione inglese vengono ancora visualizzati in italiano, come puoi vedere dall'immagine allegata.

June 5, 2019 at 8:31 am #3958133

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il problema è proprio dove l'hai messo. la riga 2332, ha un codice "loop", un "foreach", devi inserire il codice dentro quel loop come ho fatto io sul sandbox (vedi screenshot allegato)

Puoi anche controllare il sandbox, ho installato un plugin chiamato "file manager", se vuoi, puoi prendere il file già modificato da lì.

Saluti

June 5, 2019 at 12:03 pm #3960179
pasqualeD

Ciao Alejandro. ho scaricato il tuo file e l'ho caricato nell'area di staging del mio FTP.
Ora funziona...ma è nato un altro problema : il layout dello shop non è più full Screen

I nuovi thread creati da Alejandro e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/split-frequently-bought-together-non-e-piu-fullwidth/