This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.15 hours from now. Thank you for your understanding.

This topic contains 8 risposte, has 2 voci.

Last updated by Laura 1 mese, 2 settimane fa.

Assigned support staff: Laura.

Autore Post
August 28, 2019 at 10:31 am #4473405

albertoR-2

Buongiorno,
Il sito in questione è hidden link con Woocommerce.
ho creato un file CSV con gli attributi di tutti i prodotti per poterli aggiornare agevolmente.

Il sito è in due lingue: ITA e EN
Gli attributi in questione, in quanto sono specifiche numeriche, sono stati impostati come NON traducibili, quindi mi aspetterei che, se imposto un attributo sul prodotto ITA, lo stesso attributo venisse copiato in tutte le traduzioni.

Quando carico il CSV con WP All Import (uso anche l'estensione WMPL per All Import) mi aggiorna solo il prodotto in Italiano. E il Prodotto in EN rimane senza attributo

Se invece inserisco l'attributo manualmente sul prodotto usando l'editor standard di Woocommerce (Edit Product), funziona tutto perfettamente.

Mi chiedo se devo fare per forza un doppio import, uno per l'italiano e uno per l'inglese... ma questo vanificherebbe l'utilità di avere un attributo NON traducibile, credo..

Forse c'è un settaggio che sto sbagliando ma non capisco cosa.

Mi potreste aiutare?

August 28, 2019 at 3:23 pm #4475483

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Se gli attributi sono settati come non traducibili, è normale che non vengano copiati - per copiarli devi impostarli, appunto, su "copy". Una volta impostati così non dovresti avere problemi nell'importarli in inglese.

Fammi sapere se così risolvi o se hai bisogno di ulteriore assistenza.

August 29, 2019 at 10:17 am #4479855

albertoR-2

Salve Laura,
infatti è quello che mi aspettavo anche io... ma se vado su setting non trovo l'attributo per impostarlo su 'copy'

Ti ho fatto degli screenshot per farti capire con un attributo che si chiama 'Product Analog Inputs (pa_analog-inputs)'

Immagine 1 (Taxonomy_translation_setting) - vedrai che l'attributo è impostato su 'Non traducibile'

Immagine 2 (Custom_term_meta_setting) e Immagine 3 (Custom_field_setting) - ho cercato l'attributo sia sui setting dei 'Custom Term' che su Taxonomy Translation' per impostarlo cu copy ma non lo trovo... forse devo cercare altrove?

Grazie per l'aiuto,
Alberto

August 30, 2019 at 9:18 am #4485667

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

gli attributi li trovi sotto i custom fields, non sono tassonomie. Hai provato a cliccare su "show system fields" e vedere se è lì?

August 30, 2019 at 5:17 pm #4488531

albertoR-2

Ciao Laura, si.. avevo provato e ho provato nuovamente.

Sto cercando l'attributo che si chiama 'analog-input' ma non c'è ...
Come vedi dallo screenshot non appare...

September 1, 2019 at 8:58 am #4492259

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ma da dove viene questo attributo? Magari WPML non lo rileva correttamente per qualche motivo.

September 2, 2019 at 4:13 pm #4499015

albertoR-2

In che senso 'da dove viene' ?
Si tratta di un attributo di Woocommerce creato nella pagina standard di Woocommerce WooCommerce -> Products -> Attributes

September 3, 2019 at 10:36 am #4503525

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ci sono plugin che creano i loro attributi customizzati. Se questo è creato tramite WooCommerce, dev'esserci per forza da qualche parte.

A questo punto ti chiederei le credenziali così posso controllare meglio. Abilito una risposta privata

September 4, 2019 at 12:53 pm #4511207

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

puoi farmi qualche esempio di prodotto che utilizza gli attributi problematici? Ne sto guardando un paio ma non ne trovo con prodotti non assegnati.

Credo comunque che finché gli attributi non sono traducibili non possano neppure essere copiati (intendo neanche se esegui la traduzione via WCML) e di conseguenza non possono venire esportati.

The topic ‘[Closed] Gli attributi di un prodotto con WP All Import non aggiorna la traduzione’ is closed to new replies.