This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.01 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 5 risposte, has 2 voci.

Last updated by Andreas W. 4 mesi fa.

Assigned support staff: Andreas W..

Autore Post
May 30, 2019 at 1:59 pm #3923545

Laura Artesio

Tell us what you are trying to do? When I enter in the english page I don't have the post in english but in italian

Is there any documentation that you are following? No

Is there a similar example that we can see? Yes this is the page hidden link

What is the link to your site? hidden link

May 30, 2019 at 4:48 pm #3925101

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Are those posts already translated into English? It seems to me that these are custom post types, correct?

Further the URL does nto seem correct. Is the page Eventi completelty translated into English?

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

Kind regards
Andreas

June 24, 2019 at 4:06 pm #4078483

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I realized that the issue does not occur if you call up the site URL directly, while using the language switcher the URL changes to the old slug (/eventi/ instead of /events/).

After going to Settings -> Permalinks and simply clicking the save button the language switcher acted normal again. If you run into a similar issue again simply resave the permalinks and the issue should be solved.

I would further advise you to translate you content by using one of our the WPML Translation Editors. You can enable them at WPML -> Settings -> How to translate posts and pages.

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Let me know if you need any further assistance.

Kind regards
Andreas

June 24, 2019 at 4:25 pm #4078605

Laura Artesio

I surfed the site and continues to make an error. Even if I click on the permalinks I see the correct page, but if I click on the menu no. How can I do?

June 24, 2019 at 4:26 pm #4078613

Laura Artesio

I enclose you an image with the permalink.

June 24, 2019 at 4:57 pm #4078855

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I honestly can not find the issue, as on my test the language switcher and backend links lead to the correct content but I realized an issue in regards to the site´s taxonomies.

Please go to WPML -> Taxonomy Translation and chosse "Category" from the dropdown. You will realize that the categories are having the default language Italian while they been created in English. Click on each category and edit the names in correct language.
Further, those categories are not translated. Please translate them into Italian.

https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

If this will not solve the issue please provide detailed steps in order to recreate the issue or send us a small video or screeshots.

Kind regards
Andreas