This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.87 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 12 risposte, has 2 voci.

Last updated by cristianoC-9 3 mesi, 1 settimana fa.

Assigned support staff: Bobby.

Autore Post
August 7, 2019 at 9:28 am #4353195

cristianoC-9

Sto tentando di:To lock translated page in order not to have changes when i modify original

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: Tranlsation frozen

Invece ho ottenuto:Translated page still changes

August 7, 2019 at 10:53 pm #4358523

Bobby
Supporter

Languages: Inglese (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

please go to your desired page=>and click on the translation ("pencil" icon) afterwards you should see a pop up that asks you to edit independently, click on that and let me know your results

August 8, 2019 at 5:55 pm #4365241

cristianoC-9

I Bobby thanks for replying.
Could you please tell me what happens when i modify an original page already translated?
Will be only modified posts be re-translated? Or the Entire page will be re-translated?

I AM WORKING WITH A PAGE WITH 20.000 WORDS!

This because after automatic transaltion i have spent lots of hours to review the job !

Is it possible to go back to manual translation?(Like this html would be updated but translation would remian the same?) Please Advice uon your experience.

Thanks
Cristiano

August 8, 2019 at 8:50 pm #4365983

Bobby
Supporter

Languages: Inglese (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

As long as the translation is translated independently the changes in the original page will only take effect in the original page.

After making the change you will most likely get a "circle" icon which means that there were changes done in the original language

if you are using the Advanced translation Editor , then you have to go to the translation and review again the translation to get it from the "circle" to "pencil" icon, a quick way to do this could be by holding down ctrl + enter / cmd + enter

(if this is what you are trying to avoid then try the following )

you can simply click on "Use WPML's Translation Editor" and deactivate it, this will allow you to remain in the page builder view.

If the pages are synchronized together (usually happens when a translation is a duplicate of the original) then the changes in the original will overwrite.

I would recommend to always have a backup in place when making changes as well as maybe create a test page add a translation and test the above steps to see how they take place.

let me know your results please

August 9, 2019 at 1:25 pm #4370737

cristianoC-9

Hi Bobby

in order to avoid any mistake be so kind to tell me if the procedure to remove synchronization between Visit Siracusa (Original ITA) and Visit Syracuse (translated ) is this:

Step 1 :there are 4 pencils to click
Shall I click on the pencil of what V Siracusa or V Syracuse ?
Shall click on the pencil under English or Italian flag?
PICTURE step 1 in Attachment

STEP II : Shal i than choose , " NO I will translate my self"??

Thanks in advance
Cristiano

August 9, 2019 at 1:36 pm #4370825

cristianoC-9

Perhaps need to switch off Automatic translator for English page only (Visit Syracuse), since now it is finished and i don't want the program to change anything.

In the future i will translate Visit Siracusa from Italian to French too

Cristiano

August 9, 2019 at 5:25 pm #4372211

cristianoC-9

Bobby where is the pop-up you sent me as picture??? IT DOES NOT APPEAR!!

August 9, 2019 at 7:21 pm #4372617

Bobby
Supporter

Languages: Inglese (English )

Timezone: America/Los_Angeles (GMT-08:00)

If it does not appear then your pages are not synchronized and making a change in the default language should not overwrite the backend

you can also verify this by going to your default language => edit the page-> use the language switcher at the top header and switch to your secondary language (ignore the warning for now)

on the top right if you do not see the message in my screenshot then the pages are not synced

NOTE : there is also the option to select "Minor edit - don't update translation" this might be perfect for what you want to achieve (only available when translation is not synced )

August 9, 2019 at 8:10 pm #4372807

cristianoC-9

Bobby

1)The posts are synchronized because i just modified the original and the changes do appears on the translated page.
2)Please i need someone to tell me how to disable syncronization , Visit Syracuse must become a page without any synch.
3)In attachment the screen shots of my editor + WPML Translate management page

i m waiting yur answer befire week end , i have urget needs to solve this

Thanks
Cristiano

August 9, 2019 at 8:11 pm #4372809

cristianoC-9

The screen shots

August 9, 2019 at 8:19 pm #4372933

Bobby
Supporter

Languages: Inglese (English )

Timezone: America/Los_Angeles (GMT-08:00)

If possible i would like to take a closer look at the backend

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 10, 2019 at 12:01 am #4373251

Bobby
Supporter

Languages: Inglese (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have test this on my local environment using a duplicator package created by your site and i am not able to reproduce a questionable behavior.

I go to the page , make a change and update.

The change is visible in the default language but not in the secondary language.

ex. Change a header to "Test" , the Test header shows in Italian but not in English.

please provide me with a screencast of the behavior you are referring to on your live site as i am not able to reproduce an issue using a duplicator package created from your site.

August 12, 2019 at 8:33 am #4379275

cristianoC-9

My issue is not resolved