This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.64 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: From the section Translation Management i can only see the element type PAGE.

Solution: We have released a new versions of WPML, Translation Management and String Translation early this week. Could you please perform the updates and let me know if the issue is solved?

Go to Plugins -> Add new -> Commercial and scan for updates if necessary. Then download the new version and mark the checkbox for ""activate after download"."

This topic contains 9 risposte, has 3 voci.

Last updated by Andreas W. 6 mesi, 1 settimana fa.

Assigned support staff: Andreas W..

Autore Post
March 26, 2019 at 5:59 pm

maurizio-riccardoP

From the section Translation Management i can only see the element type PAGE.

If I try to choose something else, for example Contact Form and then I click on filter, after 1-2 second the page reloads with the initial settings showing me only the list of pages

March 26, 2019 at 10:05 pm #3466705

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

While testing your site I experienced the same issue once. Anyhow, after applying the filter a second time the translations were available. Also further tests were successful.

It might be that the issue was only caused by temporary server issues. Please access Translation Management now and verify if you are able to set the filter.

Kind regards
Andreas

March 27, 2019 at 8:01 am #3468327

maurizio-riccardoP

Sorry but I have the same issue.

I am in italian, and I select "Modulo di contatto", in italian, all languages... but nothing, when i click on filter, the page returns do the initial dashboard...

Best Regards,
Maurizio

March 27, 2019 at 6:21 pm #3474749

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

About the issue with the filter on Media Translation it would be helpful if you could provide information from the debug.log file.
In order to obtain this information please follow those steps:

WordPress includes a debug mode which helps reveal PHP problems.

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );
In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );
The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */
Please note that you’ll see everything, not only related to WPML. This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place. Sometimes they appear right on top, but they can also appear in the middle of the page.

Kind regards
Andreas

March 28, 2019 at 7:57 am #3477761

maurizio-riccardoP

Hi Andreas,
i've configured the file wp-config.php and then i've tried to folter again...

No log file was created and nothing appears on screen...

Best,
Maurizio

March 28, 2019 at 10:47 am #3479703

ulrichB-4

I have the exact same issue. I try to filter by Contact Form but all that is returned are type page

March 28, 2019 at 5:49 pm #3484601

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your messages.

The issue has been escalated to our developer team who will work on a fix. The next update for our Translation Management Plugin should be able to solve the problem.

Kind regards
Andreas

April 6, 2019 at 12:13 am #3547377

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We have released a new versions of WPML, Translation Management and String Translation early this week. Could you please perform the updates and let me know if the issue is solved?

Go to Plugins -> Add new -> Commercial and scan for updates if necessary. Then download the new version and mark the checkbox for ""activate after download"."

Kind regards
Andreas

April 9, 2019 at 10:06 am #3565107
ulrichB-4

Hello Andreas.

Filtering works now, but the edit link is broken.
Please have a look at the attached image.

Regards, Ulrich

I nuovi thread creati da Andreas W. e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/splittranslation-management-edit-link-for-translation-jobs-is-broken/

April 9, 2019 at 4:26 pm #3569301

Andreas W.
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Tedesco (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Ulrich,

Thank you very much for your message.

In order to help our clients to find solutions for similar issue we try to keep the tickets focused on one topic.
Please make sure to mark this ticket as resolved. I have opened a new ticket for your new request and I will be replying there within some minutes.

Thank you!

Kind regards
Andreas