This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 risposte, has 2 voci.

Last updated by Vincenzo 7 mesi, 1 settimana fa.

Assigned support staff: Vincenzo.

Autore Post
March 18, 2019 at 11:06 am #3368471

carloD-9

Sto tentando di: iniziare a lavorare con wpml

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: il sito corretto

Invece ho ottenuto: gli errori che vedete: Warning: Use of undefined constant ICL_LANGUAGE_CODE - assumed 'ICL_LANGUAGE_CODE' (this will throw an Error in a future version of PHP)

March 18, 2019 at 11:33 am #3368711

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Il problema sembra provenire da uno dei plugin inclusi con il tema. Probabilmente l'autore ha inserito del codice per rendere il suo plugin/tema compatibile con WPML.

Credo che sarebbe necessario chiedere all'autore del tema di verificare il problema.

Nel frattempo, per proseguire nel debug del problema, potresti replicare il problema in questa installazione di prova creata appositamente?
Per accedere ti basta cliccare su questo link:
hidden link
Troverai nome utente e password nella Dashboard del sito.

Ti basterà installare il tema con i suoi relativi plugin e configurare WPML in maniera da riprodurre il problema.
Sarebbe molto utile se potessi inviarmi una lista dettagliata dei passaggi utilizzati per replicare il problema.

Grazie

March 18, 2019 at 11:49 am #3368893

carloD-9

ho installato nella sandbox il tema e wpml. Il problema non esiste lì. Ma effettivamente, disinstallando il plugin del tema, l'errore sparisce insieme a tutte quelle caratteristiche che però mi servono. Allego immagine.
Come mai nella sandbox nessun problema e sul mio sito sì?

March 18, 2019 at 1:25 pm #3369721

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie per il test.

Il problema potrebbe essere causato da qualche impostazione del tema o forse è necessario qualche altro passaggio per riprodurre il problema.

Per proseguire nel debug del problema, senza compromettere il sito online, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande (maggiore di 350 MB) si possono utilizzare i filtri di Duplicator per evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

March 18, 2019 at 1:33 pm #3369781

carloD-9

Ciao e grazie,
prima di avviare questa procedura aspetto il responso dei creatori del tema. Ti aggiorno appena ho risposta e nel caso procediamo come da tua richiesta.

March 18, 2019 at 1:34 pm #3369785

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Perfetto,

metto il ticket in attesa di un tuo feedback.

Buon lavoro

The topic ‘[Closed] ICL_LANGUAGE_CODE’ is closed to new replies.