This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.47 hours from now. Thank you for your understanding.

This topic contains 4 risposte, has 2 voci.

Last updated by Vincenzo 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
September 20, 2018 at 10:28 am #2751736

francescoP-39

Tell us what you are trying to do?
partiamo dal presupposto che è la prima volta che uso wpml, sto imparando. ho selezionato l'uso del Advanced Translation Editor, poichè sto usando il tema Theme.co Pro e i contenuti testuali sono inseriti tramite cornerstone. quando clicco su traduci apre il caricamento dell'ate senza mai finire, non capisco da cosa possa dipendere.

Is there any documentation that you are following?
non trovo nessun thread che parli di questo problema

Is there a similar example that we can see?

What is the link to your site?
hidden link

September 20, 2018 at 12:21 pm #2752071

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Non è facile stabilire la causa del problema in questo caso.

Prova questi passaggi:

1. Dalle informazioni di debug vedo che il valore di WP Memory Limit è inferiore ai requisiti minimi di WPML che richiede almeno 128M.
- https://wpml.org/home/minimum-requirements/

Per incrementare il valore di WP Memory Limit aggiungi queste righe in mezzo al file wp-config.php (dopo il tag di apertura del php)

define( 'WP_MEMORY_LIMIT', '256M' );

❌ IMPORTANTE ❌ Non inserire la riga alla fine del file ma sempre prima del seguente commento riguardo la fine delle modifiche):

/* Finito, interrompere le modifiche! Buon blogging. */

Puoi verificare quale sia il valore attuale di WP Memory Limit da WPML -> Assistenza nella sezione Info

Maggiori informazioni qui:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2. Apri la console del browser (tasto F12) e verifica se ci sono errori mentre apri l'Editor Avanzato.
- Posta eventuali errori qui sul forum

3. Potrebbe trattarsi di un errore PHP.
Per sapere qual'è l'errore è necessario attivare temporaneamente la modalità di debug di WordPress.

Per attivare la modalità di debug di WordPress bisogna:

- aprire il file wp-config.php e cercare la riga:

define('WP_DEBUG', false);

Cambiarla in:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

In questo modo gli errori verranno salvati nel file debug.log all'interno della cartella /wp-content/

Il file wp-config.php si trova nella root della tua cartella WordPress.

Una volta attivata la modalità di debug si deve provocare nuovamente l'errore in maniera da registrare il problema nel file di log.

A questo punto puoi postare il contenuto del file wp-content/debug.log qui sul forum o, se è troppo grande, su pastebin.com e postare qui il link al paste.

Grazie

Documentazione relativa:
- https://wpml.org/it/documentazione/informazioni-per-gli-sviluppatori/eseguire-il-debug-di-wpml/
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

September 20, 2018 at 5:48 pm #2752916

francescoP-39

Ciao Vincenzo, grazie per avermi risposto! ho fatto come hai detto, non cambia nulla aumentando a 256, e nel log da solo un problema con envira gallery:

[20-Sep-2018 17:44:12 UTC] PHP Notice: Undefined index: title in /web/htdocs/www.oliocorax.it/home/wp-content/themes/pro/cornerstone/includes/elements/classic/_alternate/envira-gallery.php on line 30

lasciando perdere l'editor avanzato ho provato anche a farei dei test con la pagina del 404, duplicandola, con traduzione separata, anche modificando il contenuto in lingua inglese quando poi verifico mi riprende il contenuto italiano dalla versione normale!

September 20, 2018 at 6:15 pm #2752976

francescoP-39

allego due screen della traduzione manuale

September 21, 2018 at 11:18 am #2755032

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

per individuare la causa del problema originale del ticket, puoi provare questi passaggi, preferibilmente in una versione di test del sito (staging):
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva tutti i plugin tranne WPML e i suoi addon, WooCommerce e WooCommerce Multilingual.
- Imposta un tema predefinito (per es. Twenty Sixteen).
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
Infine riattiva il tema.

- Puoi segnalarmi quando torna il problema?

Per il problema della traduzione della pagina 404 personalizzata, è possibile che si tratti di un problema di compatibilità con il plugin Custom 404.

Puoi provare a tradurre le stringhe impostate nelle opzioni di quel plugin seguendo i passaggi descritti nell'articolo seguente:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Se questo non dovesse funzionare, ti chiedo di aprire un nuovo ticket relativo a questo problema.
- La politica di assistenza prevede che si posti un solo problema per ciascun ticket.

Questo aiuterà altri utenti con problemi simili a trovare le soluzioni quando cercano nel forum.

Grazie

The topic ‘[Closed] Il cms ate carica senza fine’ is closed to new replies.