This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.97 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: dopo l'aggiornamento, WPML non accetta più la chiave di licenza

Solution: il sito ha cambiato indirizzo, quindi è necessario registrare una nuova chiave in https://wpml.org/account/sites/

This topic contains 11 risposte, has 2 voci.

Last updated by Laura 4 mesi, 1 settimana fa.

Assigned support staff: Laura.

Autore Post
June 4, 2019 at 1:38 pm #3951999

barbaraT-5

Sto tentando di: aggiornare 2 plugin "String Translation" e "Translation Management". Il plugin principale risulta aggiornato alla versione 4.2.6

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: i plugin aggiornati, come ho già fatto da quando è attivo l'account di WPML collegato a questo sito, licenza acquistata il 6 settembre 2018. Siamo a giugno 2019 e dovrei avere ancora 3 mesi di tempo prima di rinnovare la licenza.

Invece ho ottenuto: "Il tuo abbonamento sembra non essere più valido. Prova a registrare di nuovo il tuo sito utilizzando una chiave valida."

"L'aggiornamento di WPML non è stato completato
Stai eseguendo una versione aggiornata di sitepress-multilingual-cms, ma il seguente componente risulta non aggiornato:

wpml-string-translation
wpml-translation-management
Il tuo sito non funzionerà come dovrebbe con questa configurazione Aggiorna tutti i componenti che stai utilizzando. Per i componenti di WPML, puoi ricevere aggiornamenti dal tuo Account WPML.org o automaticamente, dopo la registrazione a WPML."

June 4, 2019 at 3:48 pm #3953469

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

puoi provare ad annullare la registrazione di WPML (con il pulsante apposito) e a reinserire la chiave?

Se non funziona, potresti provare a generare un'altra chiave dal tuo account su wpml.org? Dovrai cancellare il sito e riaggiungerlo.

Una di queste 2 operazioni dovrebbe risolvere il problema, se così non fosse fammi sapere che faccio effettuare un controllo al System team.

June 14, 2019 at 2:22 pm #4022027

barbaraT-5

Ciao Laura,

perdonami ma ho avuto una settimana molto piena e non ho più avuto tempo di mettermi dietro a WPML. Ho fatto come mi hai suggerito ma non mi riconosce più la chiave. 🙁

Ti allego degli screenshot.

Ho provato a reinserire la chiave da WordPress ma non me la prende più. (prima di questa operazione aveva la spunta verde)

Ho provato quindi a rimuovere e aggiungere nuovamente il sito direttamente dal pannello di WPML ma non me lo fa fare perché me lo riconosce come già registrato con una chiave che però non mi riconosce!

Attendo tue,
grazie

saluti

June 14, 2019 at 3:46 pm #4022771

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

per rimuovere il sito intendevo dire che prima devi cancellarlo da https://wpml.org/it/account/siti/ mentre dal tuo screenshot sembra che tu abbia provato ad aggiungerlo quando l'altro c'era ancora, in quel caso è normale che non ti faccia registrare un'altra chiave.

June 14, 2019 at 3:54 pm #4022833

barbaraT-5

ho ripetuto l'operazione rimuovendo il sito e inserendolo nuovamente (data 14 giugno), mi crea una nuova chiave ma non viene accettata comunque dentro WordPress

vedere screenshot

June 15, 2019 at 12:36 pm #4027277

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ma il sito è stato spostato? Perché vedo nel secondo screenshot che l'indirizzo è alfasolare.com/a_solar_restyle
Se c'è una differente installazione di WordPress serve una chiave diversa, non può essere la stessa. Il sito registrato è solo alfasolare.com.
Se clicchi sul link "register on WPML.org" dovrebbe rimandarti sul tuo account per la registrazione e già inserire il sito corretto. Cosa vedi, alfasolare.com/ o alfasolare.com/a_solar_restyle?

June 17, 2019 at 12:17 pm #4035241

barbaraT-5

Ciao Laura,

il sito è sempre stato nella stessa posizione, è installato dentro una cartella su WordPress chiamata "a_solar_restyle" poi "spostata virtualmente" da sottocartella a root a sito completato.

Invece il dominio e il sito risultano appunto come alfasolare.com

Detto questo, se vado nelle impostazioni di My Sites su WPML vedo registrato hidden link (vedere screenshot)

pensavo fosse sufficiente inserire il dominio, senza specificare che sia posizionato in una cartella secondaria, dimmi che ne pensi.

Grazie
Saluti

June 17, 2019 at 3:26 pm #4036657

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

normalmente il sito registrato deve corrispondere esattamente alla cartella dove si trova l'installazione di WordPress, indipendentemente da quale sia il dominio di primo livello. Quindi sì, questo potrebbe essere il problema. Solitamente diciamo che in caso di spostamento (perché appunto si passa da sito di test a sito live) bisogna rieffettuare la registrazione.

Se però mi dici che prima funzionava anche così la cosa mi rende perplessa. Farei comunque un tentativo anche perché se riporto il problema al system team sicuramente mi diranno di fare questo test prima di indagare oltre.

June 17, 2019 at 3:57 pm #4036813

barbaraT-5

Si, esatto, prima d'ora ha funzionato e ho potuto aggiornare senza problemi, fino a qualche settimana fa.

Quindi rifaccio la registrazione su My Sites includendo /a_solar_restyle ?

grazie

Saluti

June 17, 2019 at 4:50 pm #4037331

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Sì, prova così. Se neppure questo funziona, chiedo al system team di fare un controllo.

June 18, 2019 at 1:26 pm #4043999

barbaraT-5

Ha funzionato!

ho rimosso il link da MY SITES e inserito l'url con /a_solar_restyle e ora mi ha accettato la licenza e fatto fare l'aggiornamento dei plugin!

grazie per l'assistenza
saluti

June 18, 2019 at 1:38 pm #4044119

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Bene, sono contenta che il problema sia risolto.
Se hai ulteriori questioni contattaci senz'altro.