This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.24 hours from now. Thank you for your understanding.

This topic contains 7 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 5 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
May 14, 2018 at 10:05 am

Gloria

Ciao Abbiamo un problama con le immagini degli attributi nella seconda lingua (inglese). Quando inseriamo il prodotto nella seconda lingua le immagini non vengono caricate automaticamnte come immagine di copertina e galleria.
Abbiamo fatto il lavoro con "Editor di traduzione di WPML", ma quando ho visot che in fornt end le immagini degli attributi non venicano visualizzate ho provato a disattivarlo passando a "Schermata di editing dei prodotti WooCommerce nativa" e li ho visto che i campi "product gallery ... light blue" erano vuoti. Ho provato a caricare a mano le immagini nel "product gallery....", ma niente i campi nel front end restano vuoti anche se carico nuove immagini.
Potete aiutarci?

May 14, 2018 at 4:32 pm #2124557

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao e grazie per aver contattato il supporto WPML!

Sembra che i campi personalizzati relativi a quelle immagini siano impostati su "Non tradurre".

❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

Per trovare questi campi e impostarli su "Copia" o "Traduci" clicca sul link "Mostra i campi del sistema" che puoi vedere nei tuoi screenshot.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

May 15, 2018 at 7:22 am #2129934

Gloria

Grazie mille VIncenzo, purtroppo non risolve il problema, ho attivato i campi delle gallery su copia, ho salvato la pagina e poi aggiornato quella in inglese; ho provatoanche a prendere il primo prodotto e l'ho sovrascritto con quello con in italiano ma niente, le immagini non vengono prese.
Ho provato a contattare anche il supporto del tema ma pare ci capiscano meno di me nonstante garantiscano la compatibilità con wpml. Sono certa di aver dimenticato io qualche passaggio.. ma proprio non capisco quale, non è certo la prima volta che utilizzo wpml e woocomerce. 🙁

May 15, 2018 at 10:00 am #2135248

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

il problema non riguarda il tema ma il plugin WooCommerce Variation Swatch. Puoi provare a chiedere al loro supporto.

1. Puoi darmi il link al sito dove hai scaricato il plugin?

2. Puoi verificare se il plugin WooCommerce Variation Swatch è aggiornato all'ultima versione?

3. Prova ad impostare quei campi su "Traduci" e vai ad inserire le immagini anche nella versione Inglese. In questo modo funziona?

4. Puoi dirmi lo stato dell'opzione "Rettifica ID per la funzionalità multilingua" in WPML -> Lingue?
- Prova inoltre ad invertire lo stato dell'opzione. Cambia qualcosa?

5. Puoi provare un plugin alternativo a WooCommerce Variation Swatch?
- Puoi trovare una lista di plugin compatibili qui: http://wpml.org/documentation/plugins-compatibility/

Grazie

May 15, 2018 at 3:44 pm #2143870

Gloria

hidden link
ho caricato un clone qui, perchè intanto mi hanno fatto pubblicare il sito in italiano quindi meglio non fare prove su quello a questo punto
Ti risposno per punti:
1. Il plugin era compreso con il tema e tra i plugin "richiesti"
2. è aggiornato
3. ho messu tutto su Traduci, ho provato a copiare il contenuto da italiano (non ha messo le immagini) e poi ho provato a mettergli le imamgini a mano. Le immagini in backend adesso ci sono ma se vai sul prodotto in inglese ancora non si vedono nei pallini
4. Rettifica ID per la funzionalità multilingua ERA ATTIVO. Adesso ho provato a disattivarlo am la cosa non cambia
5. non vorrei cambiare il plugin perchè purtroppo il tema è stato scelto dal cliente e approvato in questa forma "estetica". Essendo praticamnte a lavoro concluso spererei di far funzionare questo.

In tutto questo ho scritto anche al supporto del tema ma per adesso navigano in acque ancroa più profonde.

Grazie mille per l'aiuto!
Gloria

May 15, 2018 at 7:13 pm #2146457

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Gloria,

hai provato ad impostare le immagini dei "pallini" in Inglese dalla scheda "Variation Swatch" del prodotto?

Vedo che alcuni campi personalizzati che sembrano coinvolti sono ancora impostati su "Copia". Prova ad impostare questi campi personalizzati su Traduci.

Infine, prova a creare la traduzione di un nuovo prodotto partendo da una duplicazione (usa il checkbox "duplica" nel widget Lingua di WPML)

Se così non risolvi, per proseguire nel debug del problema, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande (maggiore di 250 MB) si possono utilizzare i filtri di Duplicator per evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

May 16, 2018 at 8:48 am #2152401

Gloria

Ecco
"hai provato ad impostare le immagini dei "pallini" in Inglese dalla scheda "Variation Swatch" del prodotto?"
E' qui il problema, li ho messi a mano e funziona, ma mi domando, in fase di dupllicazione non dovrebbe prenderli da solo? Quindi devo usare la vecchia schermata di woocommerce e aggiungere le immagini nella seconda lingua 🙁
Per me non è un problema ma per il cliente un po si. Pazienza

Grazie mille per l'aiuto!

May 17, 2018 at 11:31 am #2174735

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Gloria,

solitamente impostando il relativo campo personalizzato su "Copia", questo dovrebbe avvenire automaticamente.
In questo caso però, sembra che il plugin in questione non sia compatibile con WPML.
Inoltre ho il dubbio che si tratti di un plugin modificato dagli autori del tema. Una specie di fork di un plugin ufficiale, ma non ne sono sicuro.

Se si riuscisse a stabilire la provenienza del plugin, potresti inviargli questo link per permettere al'autore del plugin di mettersi in contatto con il nostro Compatibility Team che lo aiuterebbe a rendere il plugin compatibile con WPML.
https://wpml.org/documentation/theme-compatibility/go-global-program/

Grazie