This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.83 hours from now. Thank you for your understanding.

This topic contains 4 risposte, has 2 voci.

Last updated by Vincenzo 2 anni, 2 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
August 12, 2017 at 8:12 am

Gabriele

I am trying to import a csv file that have contents only in italian language.
The problem is that instead every content is imported in english language.

How can I fix it?

August 12, 2017 at 8:23 am #1340676

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!
Mi occuperò di questo ticket.

Lo screenshot sembra mostrare le impostazioni corrette.

Ho provato ad effettuare il login con le credenziali fornite ma non funzionano.

1. Puoi passarmi un file csv che contiene 2-3 righe del file originale in maniera da poter effettuare qualche prova sulla mia installazione?
- Puoi usare Dropbox, Google Drive o servizi simili.

2. Se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

- Un BACKUP dei file e del database è fortemente consigliato -

Privacy e Sicurezza:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

August 12, 2017 at 8:49 am
August 12, 2017 at 1:42 pm #1340747

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

ho effettuato un test importando le prime tre righe del file csv nella mia installazione locale. Ho utilizzato le stesse impostazioni che ho trovato in All Import -> Manage Import -> news.csv all'interno del tuo sito di test.

Il risultato è stato che i 3 articoli sono stati correttamente importati in Italiano. Vedi screenshot allegato.

È possibile che gli articoli vengano importati in Inglese perché gli stessi articoli sono già presenti nel sito e sono impostati erroneamente su Inglese. In questo modo quello che avviene durante l'importazione è semplicemente un aggiornamento degli articoli già presenti nel sito.

Prova questi passaggi:
- Trova ed elimina definitivamente dal sito (anche dal cestino) i primi 3 articoli (quelli mostrati nel mio screenshot).
- Prova a reimportare nuovamente i primi 4 articoli del file.

Se i primi 3 vengono importati correttamente in Italiano ed il quarto rimane in Inglese, avremo la conferma della causa del problema.

Fammi sapere se hai bisogno di maggiori informazioni.

Grazie

August 13, 2017 at 7:35 pm #1341021

Gabriele

Buongiorno Vincenzo, direi che hai trovato il problema. Pensavo che l'update di wp all import andasse ad aggiornare anche il linguaggio, non ricordandomi della prima importazione che avevo effettuato in inglese. Ho cancellato 10 articoli e all'importazione seguente sono stati ricaricati in italiano.
Ora il problema è su come modificare il tutto:
1) posso forzare in fase di importazione l'update della lingua?
2) c'è la possibilità di cancellare tutti gli articoli di una determinata lingua (non abbiamo contenuti in inglese)
3) in alternativa, c'è la possibilità di modificare tutti gli articoli di una lingua in un'altra lingua?

Grazie

August 14, 2017 at 11:23 am #1341495

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

ho fatto qualche prova ma sembra che il modo migliore sia quello di cancellare gli articoli nella lingua sbagliata.

Prova uno di questi metodi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
⌥ Io uso spesso il plugin Duplicator per questo scopo.
Vedi: http://wordpress.org/plugins/duplicator/
1. Rimozione manuale
- Vai su Articoli -> Tutti gli articoli
- Imposta la lingua del backend su Inglese
- Su "Impostazioni schermata" aumenta il valore di "Numero di elementi per pagina:" (es. 100)
- Seleziona tutti gli articoli utilizzando il primo checkbox (accanto a Titolo).
- Scegli "Sposta nel cestino" su Azioni di gruppo
- Premi il pulsante Applica
- Svuota il cestino

2. Un alternativa più veloce potrebbe essere il plugin Bulk Delete
- hidden link

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie