Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Our next available supporter will start replying to tickets in about 6.53 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 14 risposte, has 3 voci.

Last updated by francescoM-34 3 mesi fa.

Assigned support staff: Alejandro.

Autore Post
March 4, 2021 at 6:12 pm #8230917

francescoM-34

Sto tentando di: far funzionare il reindirizzamento di CheckOut (nel lato italiano, sembra che il lato in inglese funzioni)

Link a una pagina dove è possibile vedere il problema:
hidden link
Questo è prodotto dal lato italiano. Dopo aver effettuato l'acquisto, il cliente si vede reindirizzare, anzichè alla Cassa ad una pagina 404 dove si informa che il prodotto non è disponibile. Fra l'altro questo è un prodotto virtuale e scaricabile quindi impossibile che questo accada.

Mi aspettavo di vedere: appunto il check out dell'acquisto

Invece ho ottenuto: la pagina 404

Schermata 2021-03-04 alle 19.03.40.png
March 5, 2021 at 9:19 am #8235095

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

C'è qualche plugin che gestisce il checkout?

Puoi provare a fare un test di compatibilità
- fai un backup del sito
- disattiva tutti i plugin tranne WooCommerce, WPML e le sue componenti
- passa ad un tema di default come TwentySeventeen
- controlla se il problema si presenta nuovamente
- se non lo fa, riattiva i plugin uno alla volta fino a trovare quello che causa il problema
- per ultimo, riattiva il tema

March 8, 2021 at 7:24 am #8248205

francescoM-34

Salve Laura.

Prima di contattare il vostro supporto, ho aperto un ticket con WooCommerce i quali, dopo avere fatto diversi test di acquisto, hanno appurato che il check-out funziona perfettamente nella parte del sito in Inglese, mentre quello in Italiano presenta l'errore 404.

Mi hanno suggerito che il problema potrebbe essere imputabile a qualche conflitto con WPML, dato che, fra l'altro lo avevano già riscontrato con altri clienti.

Perciò, per provare questo, ho disattivato WPML e ho fatto un acquisto con pagamento bancario. In questo caso il checkout ha funzionato, anche dal lato in italiano.

Il 5 marzo stesso, avevo aperto un ticket con voi anche in inglese, perchè all'apertura di questo, avevo ricevuto un messaggio secondo il quale non c'erano tecnici disponibili in lingua italiana.

Dal ticket in inglese, mi hanno chiesto di comunicare i dati ftp e admin. Purtroppo finora non ho ricevuto alcuna risposta, neanche di conferma, niente.

Stamattina ho cambiato le password e rifatto un back-up del sito.

Spero che possa aiutarmi a risolvere il problema, anche perchè non sto ricevendo nessun ordine.

Grazie mille per l'attenzione.

Raffaella

Schermata 2021-03-04 alle 18.24.22.png
March 8, 2021 at 11:49 am #8251117

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Penso che parli di questo ticket: https://wpml.org/forums/topic/checkout-wrong-redirect/

Io posso continuare ad aiutarti, ma dobbiamo chiudere uno dei 2 ticket in questo caso perché è contro le nostre regole di avere 2 ticket uguali lavorandosi insieme.

Ho dato una occhiata al tuo sito e ci sono 2 cosine che vorrei tu facessi:

1) Aumenta la memoria perché se usi WPML e WooCommerce, molto probabilmente 128M non sará abbastanza:

Per favore, aggiungi/modifica questo codice nel tuo file wp-config.php

define('WP_MEMORY_LIMIT','256M');

2) Controlla per favore se c'è qualcosa da fare in WooCommerce > WooCommerce Multilingual > Status.

se c'è qualcosa da sistemare in quella pagina, per favore fallo

3) Vai sul menu WPML > Assistenza > Risoluzione dei problemi
Premi i seguenti pulsanti, e controlla ad ogni premuta di pulsate se il problema si è risolto:
• "Cancella la cache di WPML"
• "Rimuovi dalle tabelle delle traduzioni le voci non correttamente collegate"
• "Correggi il confronto di element_type"
• "Inserisci informazioni sulla lingua"
• "Correggi l'assegnazione del tipo di articolo per le traduzioni"

Provaci e fammi sapere come va.

Per favore chiudi l'altro ticket se desideri continuare qui, altrimenti chiudi questo ticket se desideri continuare in Inglese.

March 8, 2021 at 12:15 pm #8251205

francescoM-34

Salve AleJandro.
Ho chiuso il precedente ticket e proseguo con questo.
Grazie per l'assistenza anzitutto.
Ho seguito le tue istruzioni, aumentando la memoria ecc. ma il problema continua a persistere.
Attendo ulteriori istruzioni.
Grazie,
Raffaella

March 8, 2021 at 12:44 pm #8251569

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

1) Prima di continuare, avrò bisogno di accesso al tuo sito.

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

2) Mi puoi dare un prodotto di riferimento per poter fare i test sempre con questo, per favore?

Grazie in anticipo.

March 8, 2021 at 2:14 pm #8253189

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puoi controllare la password? sembra che quella che mi hai dato è incorretta.

March 8, 2021 at 2:37 pm #8253309

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Vedi qui: hidden link

Come puoi vedere nello screenshot, c'èra qualcosa da fare. una cosa importantissima (installare le pagine).

Ora, molte volte questo siginifica semplicemente che non avevi le pagine assegnate e sembra che sia il caso dello shop: hidden link

Assegna per favore questa pagina perché è necessaria perché WooCommerce Multilingual funzioni.

Dopodiché magari dovrai cambiare il tipo di rindirizzamento visto che quello che usi in questo momento è deprecated, come ti si indica nella notifica di WooCommerce che poi ti porta a questa pagina: hidden link

Provaci e fammi sapere come va.

installa pagine WooCommerce.png
March 8, 2021 at 2:51 pm #8253691

francescoM-34

Quando ho installato da circa due anni il plugin, si sono formate automaticamente le pagine per il corretto funzionamento.

Non saprei come fare questa operazione e ho un gran timore di combinare qualche casino.

Se clicco su 'crea pagine' mi viene questa schermata hidden link e francamente non vorrei che si bloccasse tutto.

Ho creato una mia pagina STORE che non avevo collegato ai prodotti perchè se collegata non mi faceva modificare il contenuto (con il tema Enfold) e avevo visto che se anche non la collegavo tutto funzionava lo stesso.

Inoltre anche se, come ho fatto ora, collego la pagina Store ai prodotti, il problema del checkout pagina 404 sulla pagina italiana continua a presentarsi.

March 8, 2021 at 3:18 pm #8254297

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Se mi dici quali sono le pagine (il nome), sopratutto dello shop, posso provare a farlo io, perché in realtá ho visto che non devi proprio crearle ma soltanto assegnarle a WooCommerce. l'unica pagina che manca è quella dello shop, che è necessaria perché WooCommerce Possa funzionare bene con WPML. e basta assegnarla qui: hidden link

Se sai come si chiama, crea un backup, per andare sul sicuro e poi semplicemente assegnala in quel link che ti ho inviato e fammi sapere come va.

March 8, 2021 at 3:24 pm #8254363

francescoM-34

La pagina dello STORE l'ho già assegnata hidden link
Le pagine che hanno a che fare con WooCommerce sono queste hidden link
Quella che non funziona (sul lato italiano) è questa hidden link

March 8, 2021 at 4:44 pm #8255193

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Il problema sono gli endpoint. li vedo creati e sono stati creati male. mi sapresti dire come li hai creati?

Puoi vedere qui a cosa mi riferisco: hidden link

Ora, per sistemare il problema:

- Vai su WPML > Traduzione Stringhe
- Filtra per dominio: "WP Endpoints" (ecco il link diretto: hidden link )

- Qui troverai un sacco di endpoint che sono tutti in Italiano e con spazi (quei + sono gli spazi). cancellali.

- Se questi endpoint li hai aggiunti da qualche parte, eliminali da dove l'hai aggiunti, visto che compaiono direttamente in Italiano e con spazi e questo è un errore umano

- Dopo il problema dovrebbe essere risolto 🙂

Provaci e fammi sapere come va

March 8, 2021 at 4:58 pm #8255243

francescoM-34

Ti ringrazio, Non ho minimamente idea di come si siano formati quegli Endpoints. Non lo so, non li ho fatti io di proposito. Quindi dovrei sempre stare attenta a controllarli. Mi segno il link che mi hai dato e ogni tanto controllo. Hai riscontrato qualche altro problema per caso? Comunque ora il Check out funziona regolarmente. Ti auguro una buona serata Alejandro. Ciao Raffaella

March 8, 2021 at 5:02 pm #8255381

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Non ho riscontrato altri problemi no. ho solo seguito i passaggi che ho menzionato sopra e poi sicome il resto era giá stato fatto, tutto ha funzionato.

Saluti.

March 17, 2021 at 12:24 pm #8331963

francescoM-34

Mi è caduta la linea