Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 8 risposte, has 3 voci.

Last updated by Laura 2 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
April 9, 2019 at 2:28 pm #3568049

Romana

Hi! I've updated both Avada Theme and WPML plugins to latest versions but I still have a big issue:
I'm trying to translate the Library Global Container Element.
I've tried this way:
1- on english page I've created a container with some text.
2- I've saved this container as global element in Avada Library.
3- I went to Avada Library, clicked on the global container just created and clicked on "add translate for italian language"
4- On italian version of this global container I've copied the english content and edited with italian words.
5- I've saved this italian global container
6-When I reopen the translated container, the content went lost.

This happens also with already created containers and it is a big issue for me.

Can youj help me in some way?
Thanks

April 9, 2019 at 3:44 pm #3569065

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/London (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!

Ho appena effettuato un test di traduzione di un container globale nella mia installazione locale e non sono riuscito a riprodurre il problema.

Per la creazione e traduzione ho seguito i passaggi mostrati nel video presente in questa documentazione:
- https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translate-fusion-builder-global-elements

Dalla descrizione del problema, potrebbe trattarsi di un problema di cache del server o di un problema di compatibilità con qualche altro plugin.

1. Prova questi passaggi, preferibilmente in una versione di test del sito (staging):
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva tutti i plugin tranne WPML e i suoi addon.
- Imposta il tema parent
- Prova nuovamente tutti i passaggi per riprodurre il problema
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
Infine riattiva il tema.

- Puoi segnalarmi quando torna il problema?

Grazie

April 10, 2019 at 7:09 am #3572971

Romana

Buongiorno,
purtroppo avevo già fatto questa prova ma continua a non funzionare. 🙁

April 10, 2019 at 8:53 am #3573743

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/London (GMT+01:00)

Buongiorno,

Per proseguire nel debug del problema, potresti replicare il problema in questa installazione di prova creata appositamente?
Per accedere ti basta cliccare su questo link:
hidden link

Troverai nome utente e password nella Dashboard del sito, cliccando su WP Sandbox.

Ti basterà installare il tema, attivare e configurare WPML.
Sarebbe molto utile se potessi inviarmi una lista dettagliata dei passaggi utilizzati per replicare il problema nella Sandbox.

Grazie

April 11, 2019 at 8:19 am #3584833

Romana

Purtroppo non riesco ad attivare il plugin "Fusion Builder" e non posso accedere agli erro log per capire quale sia l'errore, quindi non posso replicare il problema.

April 11, 2019 at 10:52 am #3586409

Romana

Sono riuscito ad installare fusion builder e replicare il problema.
Ecco il video che mostra il bug
hidden link

April 11, 2019 at 4:36 pm #3590675

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/London (GMT+01:00)

Salve,

grazie per il video.

Sono riuscito a riprodurlo e si tratta di un problema conosciuto su cui i nostri sviluppatori stanno già lavorando.
- https://wpml.org/errata/incorrect-translation-status-displayed-on-avada-global-elements-listing-page/

Sembra che si tratti di un problema nella visualizzazione degli elementi globali all'interno della pagina della Dashboard.

Puoi dirmi se il problema si presenta anche nel frontend del sito?

Ti aggiorno non appena sarà disponibile un workaround o una soluzione definitiva.

Grazie per la pazienza

April 15, 2019 at 7:01 am #3610167

Romana

Si, il problema si replica anche in frontend facendo comparire il container nella lingua di origine e quindi non tradotta.

July 16, 2021 at 11:43 am #9216945

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Fixed in WPML 4.3.12