This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.46 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 18 risposte, has 2 voci.

Last updated by Laura 3 mesi, 2 settimane fa.

Assigned support staff: Laura.

Autore Post
June 28, 2019 at 8:59 am

claudioB-4

modificando la home page italiana, la home page inglese sparisce e mi appare nuovamente quella italiana.

June 28, 2019 at 11:06 am #4106767

claudioB-4

Per favore, è abbastanza urgente.

Se provate voi stessi a fare una modifica sulla home page ITA, vedrete che la home page ENG sparisce e viene sostituita da quella ITA.

Purtroppo questa cosa mi succede spesso e ogni volta devo inserire nuovamente la pagina nella lingua corretta.

Potete cortesemente dirmi come devo fare?
Ho sempre seguito le vostre istruzioni ma continua ad esserci qualcosa che non va.
Grazie

June 28, 2019 at 12:44 pm #4107439

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Prima di fare ulteriori indagini, potresti aggiornare WPML all'ultima versione (4.2.7.1)?

June 28, 2019 at 2:01 pm #4108203

claudioB-4

Pensavo fosse aggiornato,
non me lo da' come aggiornamento.
Come mai?

June 28, 2019 at 3:22 pm #4108975

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

senza ulteriori informazioni è difficile capire perché gli update non sono stati visualizzati.
Comunque andando in Plugin -> Aggiungi nuovo -> Commerciale e cliccando sul pulsante "check for updates" dovresti riuscire a visualizzarli e ad aggiornare.

June 28, 2019 at 3:58 pm #4109297

claudioB-4

ok, fatto, aggiornato tutto

June 29, 2019 at 12:44 pm #4111583

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

il problema si presenta ancora dopo l'aggiornamento? Se è una cosa casuale, potrebbe essere un problema di server o di cache.

Puoi provare ad abilitare il debug log di WordPress?
Per farlo inserisci queste righe all'inizio del file wp-config.php dopo il tag di apertura:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

dopodiché riproduci l'errore e dovresti trovare un file debug.log nella cartella wp-content.

Copia le ultime righe qui. Se necessario, rimuovi le informazioni sensibili.

June 29, 2019 at 1:51 pm #4111781

claudioB-4

Ciao Laura,
non ho minimamente idea di come come fare per editare il wp-config e Il problema persiste ancora dopo l'aggiornamento.
Puoi fare tu tutte le prove?
Vi ho dato l'accesso ftp e tutti i codici di wordpress.
Grazie

June 30, 2019 at 3:12 pm #4114357

claudioB-4

Ciao,
avrei bisogno di una risposta al più presto, non posso più fare alcuna modifica sul sito senza che anche la parte inglese venga toccata.

Ho solo bisogno che, facendo una modifica su una pagina, tutto il resto non venga toccato.
Puoi aiutarmi per favore?
Grazie

July 1, 2019 at 6:16 am #4115723

claudioB-4

Ciao Laura,
stamattina ho disabilitato tutti i plugin a parte quelli di wpml, ho fatto una modifica sulla home page ITA e, dopo il salvataggio, la home page ENG (hidden link) è diventata uguale a quella ITA.

Ho una decina di siti gestiti con wpml, ho bisogno urgente di una soluzione.
grazie molte

July 1, 2019 at 7:06 am #4115949

claudioB-4

Dimenticavo,
ho anche messo il flag su "non aggiornare traduzione perchè modifica minima" o qualcosa del genere

July 1, 2019 at 7:24 am
July 1, 2019 at 10:29 am #4117821

claudioB-4

Fatto.
Grazie

July 1, 2019 at 3:06 pm #4120503

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

la home page inglese non è una traduzione, ma un duplicato, quindi è del tutto normale che modificando l'italiano l'inglese venga sovrascritto, perché i duplicati devono essere identici all'originale.
Quando hai tradotto la pagina inglese, avresti dovuto avere un pop up che chiedeva se volevi tradurre separatamente - non so come hai fatto ad inserire una traduzione senza salvare la pagina come indipendente.

Comunque, aprendo la pagina di editing dall'inglese, clicca sul pulsante "Traduci separatamente" e dovresti risolvere.

July 1, 2019 at 4:48 pm #4121257

claudioB-4

Ciao Laura,
tanto per non sbagliare: io adesso devo inserire una nuova parte di testo nella home page ITA.
Cosa devo fare esattamente?
Grazie