This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.08 hours from now. Thank you for your understanding.

This topic contains 14 risposte, has 2 voci.

Last updated by Alejandro 1 mese, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
February 19, 2020 at 10:07 am #5522299

ignazioT

La funzione traduzione massiva, mi da solo un contenuto parziale da tradurre che fra l'altro è già stato tradotto.

hidden link

Perchè non riesco a vedere tutti gli articoli da tradurre e mi risultano degli articoli sbagliati nella lista?

E' possibile che vi sia stata una corruzione negli indici? E' possibile aggiustare la situazione con una query?

February 20, 2020 at 9:53 am #5531327

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Mi pare che il problema che hai al momento ha a che fare con la data del filtro, potresti vedere se senza i filtri delle date funziona?

Il problema della data lo conosciamo e lo stiamo sistemando. il problema è semplicemente che il sistema riconosce male le date e quindi non ti da i risultati corretti.

Se invece il problema continua, potresti spiegarmi meglio, magari elencandomi i passi che fai e il risultato che vorresti ottenere e quello che invece ottieni o anche meglio facendo un video veloce (puoi usare loom.com per questo scopo) dove mi fai vedere il problema?

Così posso controllare cosa succede con i nostri sviluppatori di ATE.

Saluti.

February 22, 2020 at 4:38 pm #5546629

ignazioT

Cambiando i valori delle date effettivamente mi fa vedere un paio di valori in più. Sfortunatamente mi fa vedere anche dei valori sbagliati di elementi che sono già stati tradotti completamente o di elementi la cui lingua iniziale è sbagliata. Un paio di valori in più comunque, non mi fa vedere gli altri. Non so come fare sinceramente per usare il sistema automatico in queste condizioni. Sono problemi conosciuti? Il Vostro team sta lavorando per risolvere il problema? Grazie.

February 24, 2020 at 11:07 am #5553561

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

mi potresti dare accesso al sito e darmi un pio di lavori di traduzione che vorresti usare con la traduzione massiva per poter controllare meglio e darti una risposta più precisa?

Ho attivato i campi per le credenziali per la tua prossima risposta.

Il problema delle date nel filtro è un problema conosciuto anche se mi hanno appena avvisato che è un po difficile da sistemare perché non è un problema che viene dal nostro plugin ma invece da altri plugin che in qualche modo modificano il formato delle date.

Se mi dai accesso posso provare a controllare quale può essere il miglior modo per risolvere il tuo problema, anche temporaneamente mentre lavoriamo alla soluzione permanente.

Saluti.

February 24, 2020 at 11:14 am #5553749

ignazioT

Potrei sapere più nel dettaglio in merito al problema delle date così provo a modificare io direttamente? Quale formato di data non è riconosciuto?

February 24, 2020 at 12:20 pm #5554147

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

il problema è che a volte tu inserisci la data normalmente: diciamo 1 di febbraio 2020, giusto?

per il sistema questa data è: 1/2/2020, e il formato della data è giorno/mese/anno.

A volte ci sono dei plugin che possono cambiare il modo in cui la data viene controllata, cioè invece di usare il formato descritto sopra, leggono mese/giorno/anno e quindi a volte ritorna risultati oppure si blocca (quando ad esempio si parla del 25 dicembre 2020, dove controlla la data 25/12/2020 ma controlla usando il formato mese/gg/anno e quindi non funziona proprio, si blocca perché questa condizione non può essere controllata correttamente).

è un problema un po' difficile da controllare sinceramente, ma se disabiliti i plugin e attivi il tema twentytwenty e hai un risultato diverso, allora il problema viene da una compatibilità, altrimenti il problema viene da Translation Management.

February 25, 2020 at 10:26 am #5561333

ignazioT

Assolutamente no, il mio formato data è 2020/02/25 anno, mese e giorno. Ho usato questo standard perchè è quello riconosciuto a livello internazionale naturalmente. Sebbene ammettiate che sia un problema riconducibile ai plugin, temi e quant'altro. Io credo che il mio problema sia di natura diversa. Infatti vedo dei campi che non dovrebbero esserci. Io sono convinto che in qualche modo il sistema di traduzione automatica abbia "come spesso accade con i plugin" sporcato le tabelle e quindi le query con le relazioni non fuzionano bene in determinati contesti. C'è un modo per resettare gli indici della traduzione massiva e ripristinarli? Grazie. Faccio presente, che io ho speso parecchi soldi per prendere la licenza del software e che utilizzando il sistema di traduzione automatica ne ho spesi veramente parecchi. Quindi adesso se il sistema di traduzione automatica non funziona oppure ho perso funzionalità oppure dovrò perdere i contenuti già tradotti, abbiamo un problema. Grazie mille, rimango in attesa di una vostra cortese risposta. Buon lavoro.

February 25, 2020 at 12:04 pm #5562051

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dare accesso al sito per poter controllare cosa sta succedendo? se mi guidi e mi dici cosa sospetti che non funziona bene, io posso dare una controllata con i nostri sviluppatori e darti una risposta più concreta.

Ho attivato i campi per le credenziali, puoi inserirli lì.

Se invece non vuoi che accediamo al tuo sito, possiamo creare un sito di staging e migrare tutto il sito, per evitare di creare rischi per te.

Fammi sapere per capire come procedere.

February 27, 2020 at 7:54 am #5576395

ignazioT

Buongiorno, dovresti mandarmi nuovamente la richiesta per inserire nome utente e password perchè quando me l'hai mandata la prima volta è stata skippata. Il problema è che quando creo nuovi articoli non me li vede nella traduzione massiva. Inoltre mi vede degli articoli come se la lingua originale fosse inglese ma la lingua originale è italiano. Quindi ci deve essere senza dubbio un malfunzionamento nei riferimenti del database. Sarebbe fantastico se vi fosse una procedura con delle query per resettare i riferimenti delle traduzioni massive e per ripristinarle. La traduzione massiva è fondamentale perchè mi fa risparmiare veramente moltissimo tempo quando importo un gran quantitativo di articoli. Posso dire che è il motivo per il quale ho scelto il plugin. Comunque, se mi reinvii la richiesta per le credenziali vedrò di fornirtele.

February 27, 2020 at 9:58 am #5576955

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

L'ho abilitata di nuovo, per favore dammi una pagina di riferimento che non compare nella traduzione massiva, così posso controllare meglio con i nostri sviluppatori.

Saluti.

February 27, 2020 at 11:00 am #5577309

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Potresti controllare la password? sembra che non sia corretta.

February 27, 2020 at 3:45 pm #5579329

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, ho dato una controllata e oltre ad un aggiornamento di WPML non ho visto niente di anormale. Ecco qui un video dove puoi vedere tutto quello che ho fatto: hidden link

Quello che ho controllato te lo scrivo qui sotto seguendo come guida i problemi che avevi riscontrato:

- Il problema del filtro vedo che è stato sistemato quindi non è presente sul tuo sito (l'ho controllato)

- Dicevi: "vedo dei campi che non dovrebbero esserci".
Io ho creato un post qualunque ma non ho visto questo problema (titolo test e pagina test 2, entrambi dei post anche se il titolo del secondo effettivamente è un po' misleading).

Potresti darmi un post/pagina di riferimento dove vedi questo problema?

- Dicevi "Inoltre mi vede degli articoli come se la lingua originale fosse inglese ma la lingua originale è italiano."
Il caso che ho trovato qui era la "privacy policy" ma questa veramente è prima in Inglese e poi dall'inglese si sono tradotte le pagine alle altre lingue. questo lo puoi vedere andando alla versione in Inglese della pagina "Privacy Policy" e vedendo lo switch per l'editor di traduzione
(tutto questo nella sezione "Languages" della sidebar) e in tutte le traduzioni, nella sezione "Languages" vedrai che c'è un campo "Translation Of" dove compare che è una traduzione della versione In inglese di questa pagina.

Questo non è un errore, è stato fatto così, forse per sbaglio o forse no. Se invece hai un altro riferimento, fammelo sapere per controllarlo.

February 28, 2020 at 10:17 am #5584285

ignazioT

Ciao Alejando, grazie innanzitutto per aver dedicato tanto tempo al mio problema. Di seguito ho fatto un video che puoi vedere solo tu perchè può essere visualizzato solo da chi ha il link.

hidden link

February 28, 2020 at 3:10 pm #5586595

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In questo video ti spiego tutto: hidden link

è un po' lungo perché ho provato a spiegarti tutto in dettagli. Certamente prima non avevi visto tante cose perché sono tutte nuove, molto nuove e che sono ancora in sviluppo.

I nostri sviluppatori continuano a fare cambiamenti per migliorare il sistema per renderlo più intuitivo e il tuo caso l'invierò ai nostri sviluppatori perché così possano vedere come le persone interagiscono con la piattaforma e quindi probabilmente potrai fare in futuro cose come cancellare questi lavori che erano rimasti attivi.

Nel frattempo per evitare di avere i lavori attivi su ATE, per favore cancellali prima su WPML > Translation management > Translation jobs e poi se lo desideri puoi cancellare la pagina/post che non ti interessa tradurre più.

Saluti.

February 28, 2020 at 3:10 pm #5586597

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ah dimenticavo, questa è la documentazione per poter collegare/scollegare i post per poter poi cambiare la lingua principale degli stessi: https://wpml.org/faq/how-to-link-already-translated-pages/