This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 8 risposte, has 2 voci.

Last updated by Laura 2 mesi, 1 settimana fa.

Assigned support staff: Laura.

Autore Post
August 2, 2019 at 1:54 pm #4330643

guidoM

Buongiorno,
non vediamo le bandiere delle lingue solo nel menu mobile, da desktop si.

Abbiamo provato anche a fare l'aggiornamento del plugin, ma non è cambiato nulla.

Rimaniamo in attesa di un riscontro, saluti

August 3, 2019 at 11:03 am #4334399

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Innanzitutto ti suggerirei di provare ad aumentare il WP Memory Limit. Per farlo, aggiungi questo snippet all'inizio del file wp-config.php, dopo il tag di apertura <?

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

Il file wp-config si trova nella root del sito, è lo stesso file che contiene la configurazione del database. Per modificarlo ti servirà un accesso FTP o SFTP. Per controllare il valore registrato del WP Memory Limit puoi andare in WPML -> Assistenza
Ulteriori informazioni:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Se questo non risolve il problema, come è stato fatto ilo meù, con le opzioni di WordPress o viene direttamente dal tema? Se è fatto con WordPress e basta, di suggerirei di provare questo test di compatibilità:
- fai un backup del sito
- disattiva tutti i plugin tranne WPML e le sue componenti
- passa ad un tema di default come TwentySeventeen
- controlla se il problema si presenta nuovamente
- se non lo fa, riattiva i plugin uno alla volta fino a trovare quello che causa il problema
- per ultimo, riattiva il tema

August 6, 2019 at 8:14 am #4345007

guidoM

Buongiorno,
abbiamo fatto tutti i passaggi richiesti, ma il problema persiste ancora.

Rimaniamo in attesa di riscontro, saluti.

August 6, 2019 at 10:26 am #4346401

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

non hai risposto alla mia domanda: come è stato fatto il menù, con le opzioni di WordPress o viene direttamente dal tema?

Se è fatto con WordPress e basta, di suggerirei di provare questo test di compatibilità:
- fai un backup del sito
- disattiva tutti i plugin tranne WPML e le sue componenti
- passa ad un tema di default come TwentySeventeen
- controlla se il problema si presenta nuovamente
- se non lo fa, riattiva i plugin uno alla volta fino a trovare quello che causa il problema
- per ultimo, riattiva il tema

Se neppure con tutti i plugin disattivati e un tema di default le bandiere sono visibili, puoi provare ad aggiungere un nuovo menù come test, magari nel footer? In quel caso le bandiere sono visibili?

Se invece il menù viene dal tema, quali sono le opzioni che lo attivano?

August 6, 2019 at 1:40 pm #4347879

guidoM

Il menu è fatto con WordPress e le impostazioni le sistemo dal plugin di WPML.
Ho creato il test e anche nel mobile si vedono, quindi in teoria dovrei ricreare di nuovo il menu per il main?

August 7, 2019 at 7:38 am #4352491

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

se creando un nuovo menù e assegnandolo alla stessa posizione si vede correttamente, probabilmente è il modo più rapido per risolvere il problema, altrimenti dovrei prendere una copia del sito e cercare di capire qual è l'errore in quello specifico menù - ammesso che sia possibile.

August 8, 2019 at 7:50 am #4360509

guidoM

Ciao,
non funziona ancora, abbiamo anche aggiornato la versione di wordpress a 5.2, ma il problema persiste, se lo metto nel footer si vede anche dal mobile, invece nell'header no, si vede solo nel desktop.

August 8, 2019 at 4:03 pm #4364633

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

mi puoi fornire le credenziali del sito così posso fare ulteriori prove?
Mi confermi che hai provato il test di compatibilità?

August 8, 2019 at 5:12 pm #4364983

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

scusa forse non ho capito bene, se usi un altro tema o comunque con l'installazione minima il problema non sussiste? Perché se questo è il caso dobbiamo testarlo in un'installazione pulita.

The topic ‘[Closed] Le bandiere delle lingue nel menu mobile non si vedono’ is closed to new replies.