This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 risposte, has 2 voci.

Last updated by Alejandro 4 mesi, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
July 8, 2019 at 3:02 pm

cristianM-15

Il sito in questione è tradotto in 4 lingue.
Regolarmente, quando torno a navigarci dopo un periodo di tempo, mi rendo conto qualche contenuto del sito in inglese è invece in italiano.
Più volte ormai ho già ricontrollato tutte le pagine e sistemato le traduzioni in inglese mancanti, tuttavia il problema continua a ripresentarsi dopo qualche mese. Quindi credo che ci siano delle traduzioni che vengano sostituite con il testo in lingua originale (italiano).

Questo problema si presenta soltanto con la lingua inglese.
Ora ho corretto le traduzioni mancanti ma regolarmente il problema si presenta nella call to action della scheda prodotto e talvolta nella descrizione prodotto: hidden link

Vorrei capire se ci sono dei conflitti tra plugin o tra tema e plugin che causano questo disagio e come poter evitare che si ripeta.

July 9, 2019 at 7:43 am #4168231

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Cominciamo con raggiungere i requisiti minimi di WPML:

Per favore, aggiungi questo codice nel tuo file wp-config.php, subito dopo l'informazione del database

define('WP_MEMORY_LIMIT','128M');

Come seconda cosa ti chiedo gentilmente di fare un backup del sito e di aggiornare tutti i nostri plugin, visto che dalla tua versione ci sono stati tantissime migliore e fix di bug.

Fammi sapere come va, per poter continuare se sarà ancora necessario.

July 9, 2019 at 9:48 am #4169323

cristianM-15

Ciao!
Ho eseguito tutti gli aggiornamenti e il backup, e funziona tutto.
Possiamo fare dei test per verificare che l'errore non si ripresenti tra qualche mese?

July 9, 2019 at 12:13 pm #4170495

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Per ora il problema potrebbe succedere di nuovo. sono entrato proprio ora al sito e ho visto che il tuo sito sta usando 137M, quindi ti consiglio di aggiornare il codice che ti ho dato prima e di incrementare il valore a 256M.

Poi potresti aggiungere questo codice, sempre nel file wp-config.php, anche sotto del codice che ti ho passato prima:

define('WP_DEBUG',true);
define('WP_DEBUG_LOG',true);
define('WP_DEBUG_DISPLAY',false);

(assicurati che non esistano, prima di aggiungerli. Di solito il WP_DEBUG c'è ma dice "false" invece di "true", se è questo il tuo caso, elimina il codice che c'è e scambialo per questo che ti ho dato)

Con questo codice abiliteremo un registro di log che servirà per monitorare se ci sono problemi con WPML, con il tema o con qualunque altro elemento del server. è l'unica cosa che puoi fare anche se penso che aumentando la memoria sistemerà il problema.

Puoi anche monitorare l'uso di memoria della tua installazione WordPress tramite il parametro "Utilizzo della memoria" che trovi su WPML > Assistenza, così saprai se dovrai aumentare di nuovo il valore del primo codice che ti ho scritto ( https://wpml.org/it/forums/topic/le-traduzioni-in-inglese-a-distanza-di-tempo-saltano/#post-4168231 )

Fammi sapere se sono stato chiaro o se hai bisogno di ulteriore aiuto.

Saluti.

July 10, 2019 at 7:36 am #4176643

cristianM-15

Ok, ho aggiunto le stringhe che hai indicato e incrementato la memoria, grazie.

July 10, 2019 at 11:31 am #4179481

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

Perfetto, allora lascerò questo ticket aperto, visto che tutto è apposto ora non possiamo fare altro che aspettare.

Il ticket sarà aperto per 14 gg oltre all'ultima risposta per parte tua, per ora monitora il sito e se il problema si ripete, per favore controlla il directory "wp-content" per vedere se si è creato un file chiamato "debug.log", se lo trovi, fammelo sapere (e inviamelo)

Saluti.

July 10, 2019 at 12:28 pm #4180211

cristianM-15

Ok, grazie, ciao.

July 10, 2019 at 4:09 pm #4182479

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Figurati, grazie a te!

The topic ‘[Closed] Le traduzioni in inglese a distanza di tempo saltano’ is closed to new replies.