Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 3 risposte, has 2 voci.

Last updated by Alejandro 1 mese, 3 settimane fa.

Assigned support staff: Alejandro.

Autore Post
October 10, 2021 at 11:06 am #9754755

andreaB-24

Uso Smart Slider. Ho fatto due slider diversi per la homepage bredagenetics.com: uno in Italiano e uno in Inglese. Quello Italiano è impostato per essere mostrato sulla homepage italiana, quello in inglese è impostato per essere mostrato sulla homepage in inglese (esiste un wizard apposito per Smart Slider in ogni pagina wordpress per fare questa operazione). Inizialmente sembrano funzionare, ma poi lo slider in Italiano prevale su quello in inglese e viene mostrato anche nella versione inglese del sito.
Smart Slider suggerisce che dovrebbe essere il plugin che gestisce le lingue ad avere ulteriori opzioni per assicurare la corretta visualizzazione di slider diversi su lingue diverse del sito. Voi cosa mi suggerite?

hidden link

October 11, 2021 at 8:30 am #9757651

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!

Prova a confiurarli e poi:

- Aggiungi un carattere nella pagina italiana e salvala
- Controlla se lo slider inglese si è ripristinato e ora si vede quello in italiano.

Ti dico questo perché sospetto che si tratti di un problema di sincronizzazione di campi personalizzati (quello che menzioni col nome "wizard" in ogni pagina di WordPress, cioè una opzione dove puoi sceglierle).

Di essere così, prova a seguire questa guida e cambia i campi personalizzati che fanno riferimenti allo slider a "traduci" in modo di poter selezionare libera ed independentemente gli slider tra le lingue: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Provaci e fammi sapere come va.

October 11, 2021 at 5:19 pm #9764745

andreaB-24

Sorry, I didn't understand. Maybe it's better if we go on in English.

For your information: the slider for the English home page is named as "Slider Home Page - EN" whereas the slider for Italian home page is named "Slider Home Page - IT". In the page wizard for the slider I have selected the names accordingly. So it should work, but now I can only see the Italian slider everywhere (the slider in English does not appear on the English version, which is curious, even because the English one is the m,aster version of the website, being Italian just a secondary translation).

October 12, 2021 at 8:24 am #9768525

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

In order to stablish what to do, i need to know if this "wizard found on each page" you're talking about is just a custom field.

Everything that is added to a page, post or any post type is usually a custom field thus requiring its translation preferences to be configured.

This is usually done by the plugin/theme authors but if this plugin is not WPML compatible, it will not be automatically configured and you'll have to reconfigure it manually following the guide i sent on my previous reply: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

- If you still don't understand what i mean, please upload the slider plugin on this site: hidden link

- Activate WPML with the languages of your site

- translate a slider

- Add it to a page and translate it.

try to recreate the problem you have on your website and let me know the steps to do so, this wy i'll be ale to test and hopefully figure out how to solve the problem.

The topic ‘[Closed] Lo slider non funziona nel modo giusto’ is closed to new replies.