This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 37 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 6 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
May 8, 2018 at 11:42 am #2029275

nicola strumia

Si era già multisite quando ho registrato wpml. Il sito secondario in realtà non serve. Può rispondere solo hidden link. Ho aggiornato il network.

May 8, 2018 at 12:09 pm #2029776

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Forse disattivando il Multisite nel sito entrambi i problemi si risolvono.

Per proseguire nel debug del problema, senza compromettere il sito online, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande si possono utilizzare i filtri di Duplicator per evitare di includere la cache, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

May 8, 2018 at 1:37 pm
May 8, 2018 at 5:33 pm #2037380

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho installato il sito sul mio server locale ma non parte correttamente perché la versione gratuita di Duplicator non effettua la duplicazione corretta dei Multisite.

Ad ogni modo ho disabilitato il Multisite dal file wp-config.php e sono riuscito a far partire il sito e risolvere il problema della registrazione.
- Ho dovuto però riconfigurare le opzioni di WPML

Puoi provare a disattivare i plugin WPML dal Network e abilitarli nella pagina dei plugin del sito in questione (subsite)?

May 8, 2018 at 5:42 pm #2037532

nicola strumia

ok ho fatto come mi hai chiesto. che faccio adesso? provo a registrare i plugin ?

May 8, 2018 at 5:45 pm #2037585

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sì, prova a registrare i plugin e fammi sapere se il problema continua o si risolve.

Grazie

May 8, 2018 at 5:46 pm #2037612

nicola strumia

ok. domanda. Faccio il revalidate? Oppure Annullo la registrazione?

May 8, 2018 at 5:48 pm #2037641

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Nella mia copia locale il revalidate non ha funzionato ed ho dovuto annullare e registrare nuovamente WPML.

Prova prima il revalidate e successivamente ad annullare e registrare nuovamente.

May 8, 2018 at 5:52 pm #2037738

nicola strumia

Niente da fare. Sempre lo stesso errore. Una osservazione (vedi immagine): devo cancellare prima la vecchia key?

May 8, 2018 at 5:54 pm #2037752

nicola strumia

I gestori di wpml non possono forzare in qualche modo questa cosa dal gestionale? Nel senso di resettare tutto in modo che io possa fare una nuova registrazione ex-novo intendo....

in ogni caso per me è prioritario sistemare il problema delle immagini non visibili nelle altre lingue in questo momento...

May 8, 2018 at 6:19 pm #2038141

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Domattina, se ho il tuo permesso, proverò ad effettuare una duplicazione del sito completa anche del Multisite.

Nel frattempo, per risolvere il problema delle immagini, puoi provare a tradurre la pagina fotogallery in maniera manuale?

Prova questi passaggi:

- Apri la pagina Fotogallery in Italiano
- Utilizzando il selettore lingue nella barra in alto, passa alla versione Inglese.
- Se ti viene chiesto, premi sul pulsante "Modifica comunque"
- Traduci la pagina manualmente inserendo le immagini nell'elemento Gallery come hai fatto nella versione Italiana.
- Salva la traduzione
- Se ti viene chiesto, premi nuovamente sul pulsante "Modifica comunque"

Vai a vedere la traduzione Inglese della pagina per verificare che il problema è risolto.

Tienimi aggiornato.

May 9, 2018 at 6:48 am #2043993

nicola strumia

Niente da fare. Anche premendo Modifica comunque il risultato è lo stesso.

May 9, 2018 at 7:33 am #2044848

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Buongiorno,

1. Puoi dirmi se ho il permesso di installare e attivare un plugin per effettuare il duplicato dell'intero Multisite?

Grazie

May 9, 2018 at 7:38 am #2045016

nicola strumia

certamente Vincenzo. Dimi come vuoi procedere: mi fai risposta privata e ti lascio credenziali di accesso? ti credo un account admin con la tua email? Dimmi tu

May 9, 2018 at 7:44 am #2045150

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ti attivo una risposta privata per passarmi le credenziali del sito, preferibilmente di un account super admin per gestire il Multisite. Come indirizzo email per il nuovo account puoi inserire uno dei tuoi.

Grazie