Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 39 risposte, has 2 voci.

Last updated by Alejandro 3 settimane, 1 giorno fa.

Assigned support staff: Alejandro.

Autore Post
October 19, 2021 at 2:52 pm #9819531

micolF

è da questa mattina che non riesce a fare la migrazione (vedi screen) e non ho modo di aprire un ticket, servono i vostri dati di accesso al servizio per caso?

Schermata 2021-10-19 alle 16.47.52.png
October 19, 2021 at 3:00 pm #9819635

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Grazie mille!

Attendo tue.

October 20, 2021 at 1:42 pm #9827685

micolF

Ti confermo che da ancora problemi nella migrazione come da screen che ho inoltrato ieri.

October 21, 2021 at 7:09 am #9832521

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Puoi provare di nuovo, per favore? ho pulito il server perché probabilmente il tuo sito è molto grande e richiedeva più spazio.

se ancora non funziona per favore usa un plugin come duplicator oppure "All In One Migration" e crea una copia del sito assicurandoti di:

- NON caricare backups e altri file pesanti
- Non caricare la directory degli UPLOADS
- Creare diversi backup:
+ Uno per il database
+ Uno per i temi
+ Uno per i plugin.

- Poi carica questi file in un posto come wetransfer, dropbox o qualunque altra piattaforma di tua preferenza ed inviami il link di download, per poter fare io la migrazione.

October 22, 2021 at 7:55 am #9841529

micolF

Ho riprovato ma non ha funzionato ancora, ti sto quindi mandando un wetransfer con l'estrazione del sito, che ho in realtà fatto dal cPanel, dal quale ho poi tolto la raccolta dei backup precedenti più i file di upload..troverai anche il file del DB che ho estratto sempre dal cPanel.
hidden link

October 23, 2021 at 2:59 pm #9849403

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Scusami se non ti ho risposto ancora, siccome mi hai inviato i file direttamente dal cpanel ho dovuto cambiare manualmente il dominio in tutto il database e ci sono diverse cose da sistemare per farlo funzionare (per quello ti avevo chiesto prima di farlo con un plugin, per risparmiare questo tempo 😉 )

appena finisco, vedo se il problema succede pure qui e poi invio il caso ad un nostro sviluppatore

October 25, 2021 at 10:28 am #9856063

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho bsogno del tuo aiuto.

Quando si migrano i siti, si cancellano le immagini ma il problema qui è che anche con le immagini, non veniva assegnato il menu mobile, non si vede mai.

Potresti entrare nel sito di staging e provare a rendere visibile questo menu e dirmi come l'hai fatto, così posso provare ad inviare il caso ai nostri sviluppatori.

October 25, 2021 at 2:06 pm #9858133

micolF

Perdonami per i file della migrazione, ma anche se sembra strano siccome ho avuto poco tempo per me quella era la via più breve.
Comunque adesso provo a inviarti quello che Duplicator mi ha esportato, "All In One Migration" invece mi ha esportato 4gb in tutto e non riesco a spacchettarlo per pulirlo.
hidden link

In allegato ti metto lo screen dei settings del manu mobile, in quale a me risulta già visibile e attivo sia su hidden link che su hidden link.
Ho intanto tolto la password di sicurezza che sta sull'ultimo link così magari siete più liberi.

Fammi sapere se c'è altro

Setting-menu-mobile.png
October 25, 2021 at 3:41 pm #9858781

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Grazie per il duplicator, ma lo stesso avevo risolto quel problema prima (lo stesso l'ho usato) 🙂

Quello che ti chiedevo era di vedere il sito migrato: hidden link

e di vedere che qui non si aggiungeva il menu e sospetto che è perché in realtá questo menu funziona con altri plugin. io li ho disabilitati tutti tranne elementor e WPML ma non compare il menu e mi domando se c'è bisogno di un altro plugin per farlo comparire.

Potresti accedere a quel sito e vedere cosa succede, per poi dirmelo? per favore NON abilitare tutti i plugin perché sto provando ad isolare il problema e non lo posso fare con tutti i plugin che non c'entrano con il problema, attivi.

October 25, 2021 at 4:01 pm #9858853

micolF

Il mega menu viene gestito anche dal plugin JetMenu di Crocoblock, bisognerebbe provare ad attivare anche quello per fare i test.

October 26, 2021 at 8:33 am #9862629

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Allora.

Ti chiedo una cosa:

- Il test che cerco di fare è d'isolare il problema. mi piacerebbe che tu attivassi questo menu mobile SENZA altri plugin, perché potrebbe essere che il problema arriva proprio da un conflitto con questi plugin e WPML.

Potresti farlo nel sito che ho migrato per te, per favore? quando l'avrai fatto, prova a vedere se il problema succede qui e scrivimi i passi che hai seguito per far vedere il menu.

----------------

Ripeto, NON attivare nessun altro plugin, voglio vedere soltanto il menu mobile nel sito, quello che arriva da Elementor, per vedere se il problema è con il widget + WPML oppure se si tratta di un problema di conflitto con altri plugin.

October 26, 2021 at 4:04 pm #9866451

micolF

Dunque ho attivato semplicemente Jet Menu, adesso il menu compare e guardandolo da mobile ho ancora il problema che in italiano mi carica il menu in inglese ad esempio.

October 27, 2021 at 7:23 am #9870943

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Allora il problema non è con elementor, è con JETMENU. questo cambia totalmente il problema.

nonostante tutto peró io il menu mobile lo vedo solo quando accedo in elementor, non quando accedo alla home del sito con il telefonino o anche senza, con la finestra piccola per far scattare il modo mobile.

Mi potresti dire come funziona "jet menu" in elementor? così magari riesco a risolvere e far visibile il menu.

Guarda come vedo io quella zona: hidden link

è veramente l'unica cosa che mi manca per poter inviare il caso ai nostri sviluppatori, sperando di avere un workaround o anche una soluzione temporanea.

November 2, 2021 at 10:43 am #9907527

micolF

Guarda sono riuscito a riverificare solo oggi, quando sono entrato la prima volta io avevo una visione del sito diversa, ossia tutto bianco con i testi neri (senza temi attivi apparentemente) e attivando JetMenu ero comunque riuscito a rendere attivo il menu.
Entrando oggi vedo che il sito è tornato come da nostra stilizzazione ma effettivamente non vedevo più neanche io il menu, quello era dato dal fatto che non c'era più attivo il widget del mega menu all'interno del template (vedi screen 1 dove a destra del logo c'è solo un +), a questa pagina ci arrivi facendo mouse over su Modifica con Elementor e poi click sulla voce del template dell'header (screen 3).
Adesso ho a grandi linee reimpostato il menu da desktop e da mobile e dovresti vederlo.

Ti segnalo che, come da screen 2, il sito mi è andato un paio di volte il Fatal error dopo aver provato a cambiare lingua, ma disattivando/attivando il JetMenu sembra essere tornato funzionate. Sospetto che la causa possa anche essere che faccio fatica ad attivare le licenze di Elementor e Crocoblock, senza licenze potrebbero precludersi alcuni funzionamenti.

Spiegarti come funziona JetMenu è un po' complicato, ma i sui settaggi li puoi trovare o

3.png
2.png
1.png
November 2, 2021 at 10:47 am #9907603

micolF

Guarda sono riuscito a riverificare solo oggi, quando sono entrato la prima volta io avevo una visione del sito diversa, ossia tutto bianco con i testi neri (senza temi attivi apparentemente) e attivando JetMenu ero comunque riuscito a rendere attivo il menu.
Entrando oggi vedo che il sito è tornato come da nostra stilizzazione ma effettivamente non vedevo più neanche io il menu, quello era dato dal fatto che non c'era più attivo il widget del mega menu all'interno del template (vedi screen 1 dove a destra del logo c'è solo un +), a questa pagina ci arrivi facendo mouse over su Modifica con Elementor e poi click sulla voce del template dell'header (screen 3).
Adesso ho a grandi linee reimpostato il menu da desktop e da mobile e dovresti vederlo.

Ti segnalo che, come da screen 2, il sito mi è andato un paio di volte il Fatal error dopo aver provato a cambiare lingua, ma disattivando/attivando il JetMenu sembra essere tornato funzionate. Sospetto che la causa possa anche essere che faccio fatica ad attivare le licenze di Elementor e Crocoblock, senza licenze potrebbero precludersi alcuni funzionamenti.

Spiegarti come funziona JetMenu è un po' lunga, ma i sui settaggi li puoi trovare o sotto la voce Crocoblock del menu di WP (screen 4) o sotto aspetto-->menu e come da screen 5 e 6 ci sono altri parametri.

6.png
5.png
4.png
3.png
2.png
1.png