Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problema: Molti link in Elementor non si traducono automaticamente.

Soluzione: Aggiorna tanto elementor come WPML alla versione più recente e se il problema continua, per favore usa il fix in questo commento: https://wpml.org/it/forums/topic/molti-link-non-vengono-aggiornati-con-lurl-corretto-della-lingua-ttiva/page/2/#post-3599893

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Our next available supporter will start replying to tickets in about 6.08 hours from now. Thank you for your understanding.

This topic contains 21 risposte, has 2 voci.

Last updated by matteoF-24 2 anni, 3 mesi fa.

Assigned support staff: Alejandro.

Autore Post
March 10, 2019 at 10:49 am #3303773

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Grazie, ho aggiornato i nostri dev a riguardo e aspetterò la loro risposta per procedere ad aggiornarti. Saluti.

March 11, 2019 at 7:38 am #3308125

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi hanno confermato che l'attributo URL del widget "headline" non è stato registrato ancora.

Il tuo caso è stato inviato al nostro team di compatibilità.

Ti aggiornerò appena mi daranno risposte a riguardo.

Saluti.

March 12, 2019 at 8:30 am #3319285

matteoF-24

Ok, nel frattempo li modifico manualmente con elementor, editando la pagina in lingua.

Resto in attesa di aggiornamenti.
Grazie!

March 12, 2019 at 8:43 am #3319475

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, il problema è stato trovato e i nostri sviluppatori stanno già lavorando ad una soluzione.

Ti chiedo di non rispondere questo messaggio per ora, così il ticket rimane sempre alla vista dei nostri sviluppatori (altrimenti ritorna a me).

Ti terrò aggiornato, saluti.

April 11, 2019 at 6:35 am #3584077

matteoF-24

Ciao,

in aggiornamento al ticket rimane da risolvere questo problema:

"Mi hanno confermato che l'attributo URL del widget "headline" non è stato registrato ancora."

April 12, 2019 at 2:29 pm #3599893

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

I nostri sviluppatori ci hanno detto che il prossimo aggiornamento sistemerà questo problema ma nel frattempo ho creato una funzione che lo sistema così puoi continuare a lavorare (e l'ho anche inserita nel file functions.php del tema child).

Ecco il codice:

add_action( 'wp_enqueue_scripts', 'oceanwp_child_enqueue_parent_style' );

/**
 * Translate Heading widget by Elementor Pro
 * @param array $widgets
 * @return array
 */

add_action( 'wpml_elementor_widgets_to_translate', 'wpml_translate_widget_compsupp_3723' );
function wpml_translate_widget_compsupp_3723($widgets) {
    $widgets['heading'] = [
    'conditions' => ['widgetType' => 'heading'],
    'fields'     => array(
                    'link' => array(
                        'field'       => 'url',
                        'type'        => __( 'Icon: Link URL', 'sitepress' ),
                        'editor_type' => 'LINK'
                        
                    ),
                    [ 'field'       => 'title',
		      'type'        => __( 'Heading', 'sitepress' ),
		       'editor_type' => 'LINE'
		    ]
                    
                )
                
    ];
    
    return $widgets;
}

Saluti!

April 12, 2019 at 6:37 pm #3601257

matteoF-24

My issue is resolved now. Thank you!