This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 risposte, has 2 voci.

Last updated by Vincenzo 1 anno, 1 mese fa.

Assigned support staff: Vincenzo.

Autore Post
September 19, 2018 at 2:31 pm

Alain Rubeli

Sto tentando di:
Ho cambiato una foto di un prodotto nella lingua principale Italiano.
Link a una pagina dove è possibile vedere il problema:
hidden link
Mi aspettavo di vedere:
Nelle altre lingue la nuova foto uguale invece tiene quella vecchia. Cosa posso fare?
Invece ho ottenuto:
La foto diversa nelle altre lingue.

September 19, 2018 at 5:42 pm #2749656

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

1. Puoi verificare se il problema avviene con i nuovi prodotti?

2. Per risolvere, puoi provare questi passaggi:

- Rimuovi l'immagine dal prodotto originale
- Salva/aggiorna il prodotto
- Inserisci nuovamente l'immagine (preferibilmente effettuando un nuovo upload)
- Salva/aggiorna il prodotto
- Verifica se l'immagine della traduzione è stata aggiornata.

3. Se il problema dovesse persistere, prova questi passaggi:
- Vai su WooCommerce -> WooCommerce Multilingual -> Impostazioni
- Seleziona l'opzione "Schermata di editing dei prodotti WooCommerce nativa"
- Salva

Da questo momento, la traduzione dei prodotti avverrà nella schermata classica di WooCommerce.
- Modifica la traduzione del prodotto e cambia manualmente l'immagine.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

September 20, 2018 at 8:44 am #2751473

Alain Rubeli

Buongiorno,
utilizzando la modalità nativa funziona ma porta via un sacco di tempo in più per ricaricare l immagine in ogni lingua.
Come mai non funziona più?
Ha funzionato da quasi un anno questo sistema che stiamo usando..

September 20, 2018 at 4:22 pm #2752817

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

la soluzione che ho inviato dovrebbe servire solo a risolvere il problema nei prodotti interessati.

Una volta risolto il problema, si può riattivare il metodo di traduzione precedente.

1. Puoi verificare se il problema avviene anche con i nuovi prodotti?

2. Puoi verificare se il problema si ripete con i prodotti a cui sono stati applicati i passaggi descritti nella mia risposta precedente?

3. Se il problema dovesse ripetersi, prova questi passaggi, preferibilmente in una versione di test del sito (staging):
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Disattiva tutti i plugin tranne WPML e i suoi addon, WooCommerce e WooCommerce Multilingual.
- Imposta un tema predefinito (per es. Twenty Sixteen).
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
- Infine riattiva il tema.

Puoi segnalarmi quando torna il problema?

Grazie

September 21, 2018 at 7:44 am #2754186

Alain Rubeli

Buongiorno,
ho provato a rimetterlo ma:
con i nuovi prodotti funziona, invece con i vecchi non funziona più.

Per il test mi ci vorrà una vita, il nostro sito è molto pesante.. £
Il test che ho non ha i vostri plugin aggiornati può essere un problema?

Saluti

September 21, 2018 at 9:40 am #2754605

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

Avrei bisogno di questo ulteriore dettaglio:
- Puoi verificare se il problema si ripete con i vecchi prodotti a cui sono stati applicati i passaggi descritti nella mia risposta precedente?

Prova inoltre questi passaggi preferibilmente nel sito di test:
- Vai su WPML -> Impostazioni
- Scorri in fondo alla pagina nella sezione "Traduzione dei contenuti multimediali"
- Seleziona tutte le opzioni della sezione specifica e premi il pulsante "Avvia"

L'aggiornamento dei plugin prima del test è importante.
Inoltre, se il problema non si risolve disattivando tutti i plugin, non è necessario continuare con gli altri passaggi.

Grazie

The topic ‘[Closed] Non cambiano le immagine nelle altre lingue per i prodotti’ is closed to new replies.