This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.23 hours from now. Thank you for your understanding.

Autore Post
October 3, 2018 at 3:26 pm #2785060

giuseppeu

I can not translate "item (s)" in the Italian section, you can translate it with "articolo" / "articoli" --> hidden link

www.**********.it
user: ************
pass: ****************

October 4, 2018 at 2:40 pm #2787843

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML!

Ho rimosso le credenziali dal forum pubblico per motivi di sicurezza.

Ad ogni modo le credenziali non permettono di accedere alla bacheca di WordPress e quindi non ho potuto verificare il problema.
- Prova ad impostare l'utente su Administrator.

Nel frattempo prova le seguenti soluzioni:
1. Puoi confermare che sul sito sono installate le ultime versioni di WPML e dei suoi add-on plugin (se li usi)?
Puoi verificare quali siano le ultime versioni andando su "Conto -> Download" su questo sito.
- https://wpml.org/account/downloads/

Se necessario, queste sono le istruzioni per l'aggiornamento:
- https://wpml.org/it/faq/come-installare-wpml/

❌ Assicurati d'avere un backup del sito prima di procedere! ❌

2. Puoi confermare che la stringa in questione è stata tradotta da WPML -> Traduzione stringhe?

3. Se la stringa non si trova su Traduzione stringhe, e la stringa è stata impostata dalle opzioni del tema, prova a seguire i passaggi in questo articolo per registrare e tradurre la stringa:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

4. Prova ad attivare l'opzione "Memorizza un cookie della lingua per supportare il filtro Lingua per AJAX" da WPML -> Lingue -> Filtro Lingua per le operazioni AJAX

Grazie

October 4, 2018 at 10:01 pm #2788858

giuseppeu

ciao Vincenzo grazie per l'aiuto.
Dove posso inviarti le credenziali di accesso con utente amministratore?

ho fatto questo passaggio: hidden link
la mia versione sembra aggiornata.

non riesco a capire come impostare o tradurre la stringa.

Fammi sapere per favore dove posso inviarti i dati per l'accesso
grazie

October 4, 2018 at 10:02 pm #2788860

giuseppeu

ho visto che il ticket è stato segnalato come chiuso. Attendo risposta all'ultima mia risposta grazie

October 5, 2018 at 7:14 am #2789689

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Buongiorno,

se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

October 5, 2018 at 9:04 am #2789967

giuseppeu

open

October 5, 2018 at 9:17 am #2790072

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

ho ricevuto le credenziali ed ho reso privato il messaggio precedente.

Per quanto riguarda la chiusura del ticket, credo che, quando rispondi, in qualche modo venga selezionata la casella che segnala il ticket come risolto.

Do un'occhiata al sito e ti aggiorno appena possibile.

October 5, 2018 at 4:24 pm #2791295

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

da quello che posso vedere nel file /wp-content/themes/siezz/woocommerce/minicart-ajax.php, il problema è causato dal fatto che la stringa ' item(s)' non è stata inserita all'interno di una chiamata GetText, secondo i canoni di WordPress.

Prima di effettuare le modifiche seguenti, credo sia meglio aggiornare il tema. C'è la possibilità che questo errore sia già stato corretto nella versione aggiornata.

Se anche nella versione aggiornata del tema il problema rimane lo stesso, prova ad effettuare questi passaggi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Apri il file /wp-content/themes/siezz/woocommerce/minicart-ajax.php
- Trova la riga seguente. Dovrebbe trovarsi intorno alla riga 12 del file

<div class="number-item"><?php echo esc_html__('There are ','siezz').'<span class="item">' .$woocommerce->cart->cart_contents_count.' item(s)</span>'.esc_html__(' in your cart','siezz');?></div>

Modifica la riga in:

<div class="number-item"><?php echo esc_html__('There are ','siezz').'<span class="item">' .$woocommerce->cart->cart_contents_count .' ' . esc_html__('item(s)','siezz').'</span>'.esc_html__(' in your cart','siezz');?></div>

- Salva il file
- Vai su WPML -> Localizzazione del tema e dei plugin
- Effettua la scansione del tema Siezz
- Vai su WPML -> Traduzione stringhe
- Traduci la stringa

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 5, 2018 at 5:51 pm #2791457

giuseppeu

ciao, ho aggiornato il tema ma senza successo, allora ho recuperato un backup perchè mi aveva anche sovrascritto delle modifiche.

ho inserito le stringhe come mi hai indicato, ora vedo le stringhe:
hidden link

la traduzione è apparsa per un secondo poi è sparita., nella traduzione ho lasciato uno spazio dopo articolo(i) per dare appunto uno spazio e non avere le parole attaccate.

per ora non è tradotto:hidden link magari aspetto si deve aggiornare.

Posso chiederti un supporto per 4 domande in riferimento al tema? il support non mi risponde purtroppo. Te ne sarei davvero grato:

1) in this category: I need to order the product in this way: marugnò, vermentinu, Frina, Trame, Murischeddu, Innitu, Murruai, Sorso d’oro, Abà, brundhedda, ch’ea 50 ch’ea 20 mirto 50 mirto 20
2) I don't know how can I translate "item (s)" in the Italian section, you can translate it with "article" / "articles" -> hidden link

3) The "other" button does not work. (cart, my account, other, screenshot card-product-mobile.jpg) ==> You have to go to admin => appearance => menu => create a menu and add submenu for it => then scroll down to the menu => then check the parameters of the mobile menu. ok, I have tried without success. CAN you help me? THANK YOU

4) About the mobile device revolution slider, I checked and verified that you are not enabling mobile layout mode and do not set the mobile content page. I have tried without success. CAN you help me? THANK YOU THANK YOU

5) Here in the products on the home page in the section "Discover the best delphine products: hidden link and here: hidden link" the packs "appears the title and the small description only with the passage of the mouse, I would like to have the title and the small description always visible like this: hidden link

6) Please can you move the position (on the mobile view) of the cart like this: hidden link

7) I would like to add this function that reminds you that there are products in the cart, and puts the button on the box, exactly as in the demo: hidden link

October 8, 2018 at 11:46 am #2795859

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Buongiorno,

ho dato un'occhiata al sito e, da quello che posso vedere, le traduzioni appaiono correttamente per tutte e tre le stringhe.

Puoi confermare?

Per le altre domande, la politica di assistenza prevede che si posti un solo problema per ciascun ticket. Posso chiederti di aprire un nuovo ticket per ciascuna delle altre domande?
Puoi farlo da questo indirizzo: https://wpml.org/it/forums/forum/supporto-in-italiano/

Questo aiuterà altri utenti con problemi simili a trovare le soluzioni quando cercano nel forum.

Grazie

October 12, 2018 at 12:08 pm #2811882

giuseppeu

ciao, ho aggiornato il tema e i plugin.
Ho rifatto i passaggi che mi avevi detto tra cui sostituire la stringa, ma aimè si è presentato lo stesso errore:

itesm(s) e non articoli: hidden link
qua sembra tutto ok...hidden link come risolvo? grazie

October 12, 2018 at 12:09 pm #2811883

giuseppeu

mm forse ok sembra essersi aggiornato..

October 15, 2018 at 2:48 pm #2817989

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

credo che il ritardo nel visualizzare le modifiche possa dipendere da un sistema di cache del server o forse del tema.

Sono comunque contento che il problema sia risolto.

In caso di altri problemi o domande non esitare ad aprire un nuovo ticket.

Buon lavoro