This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problema: Utilizzo la traduzione manuale con il gtema Enfold. Provo a duplicare la pagina e poi a tradurla manualmente ma le mie modifiche non vengono salvate. Soluzione: Per risolvere prova ad installare ed attivare il plugin Classic Editor - https://it.wordpress.org/plugins/classic-editor/

Etichettato: 

This topic contains 14 risposte, has 2 voci.

Last updated by giacomoT-2 5 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
May 6, 2019 at 9:35 am #3746533

giacomoT-2

Sto tentando di:
Duplicare le pagine e modificare separatamente i testi
Link a una pagina dove è possibile vedere il problema:
hidden link
Mi aspettavo di vedere:
Modifiche effettuate
Invece ho ottenuto:
Gli aggiornamenti con i nuovi testi non vengono memorizzati, quando cerco di tradurre separamente mi ricarica la pagina senza apportare modifiche. E di conseguenza le modifiche che cerco di effettuare successivamente, non vengono considerate.

May 6, 2019 at 12:36 pm #3748353

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

1. Puoi dirmi quali sono i passaggi che effettui nel dettaglio?

2. Prova ad usare i passaggi illustrati in questo articolo:
- https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Grazie

May 6, 2019 at 1:58 pm #3749523

giacomoT-2

Grazie per l'aiuto Vincenzo. Eseguo esattamente tutti i passaggi illustrati dall'articolo, ma nel cliccare il pulsante "Translate independently" mi appare il pop up " Vuoi ricaricare il sito? Le modifiche apportate potrebbero non essere salvate." E posso solo annullare o ricaricare, ma la pagina non mi permette il passaggio successivo, in cui inserire i testi tradotti.

May 6, 2019 at 2:00 pm #3749555

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Questo messaggio appare anche se salvi la pagina prima di premere il pulsante "Translate independently"?

May 6, 2019 at 2:14 pm #3749613

giacomoT-2

Ho provato a duplicare un'altra pagina, Ora mi appare anche subito dopo aver duplicato, se clicco sulla matita ho di nuovo il pop-up.

May 6, 2019 at 2:20 pm #3749711

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

per proseguire nel debug del problema, senza compromettere il sito online, avrei bisogno di replicare il sito localmente nel mio server.

Per questo normalmente raccomandiamo il Plugin gratuito “Duplicator”
- https://wordpress.org/plugins/duplicator/

★ Istruzioni:
hidden link
https://wpml.org/it/faq/come-fornire-ai-supporter-una-copia-del-vostro-sito/

Se il file risultante è troppo grande (maggiore di 350 MB) si possono utilizzare i filtri di Duplicator per evitare di includere la cache, la cartella wp-uploads, i file media e gli archivi per ridurre la dimensione dell'archivio.

A me serve il file archive che il plugin genera. Puoi incollare il link al file nella prossima risposta.

Puoi usare servizi come Google Drive o Dropbox per inviarmelo.

Ti attivo una risposta privata così puoi inviarmi il link al file in maniera sicura.

Fammi sapere se hai bisogno di aiuto nel creare il duplicato.

Grazie

May 7, 2019 at 9:58 am #3756135

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

ho installato la copia del sito sul mio server locale ed ho potuto vedere il problema.

Per ovviare al problema del popup ho effettuato questi passaggi:
- Apro in modifica la pagina Italiana da tradurre
- Se vedo il messaggio "C'è un salvataggio automatico di questo articolo che è più recente della versione qui sotto", premo il pulsante Aggiorna.
- Seleziono il box "Duplica" in corrispondenza della lingua Inglese
- Premo il pulsante "Duplica"
- Clicco sull'icona a forma di matita per modificare la traduzione.
- Modifico la traduzione
- Premo il pulsante Aggiorna
- Rispondo OK all'avviso che WPML sta impostando l'articolo su tradurre separatamente"

Fammi sapere se questa sequenza di passaggi risolve o se hai bisogno di maggiori informazioni.

Grazie

May 7, 2019 at 2:22 pm #3759211

giacomoT-2

Grazie dell'aiuto, ma purtroppo il problema rimane. Eseguendo esattamente questi passaggi, provo ad esempio a tradurre in Homepage la parola "Benvenuti" con "Welcome" e aggiorno. L'anteprima mi fa leggere ancora "Benvenuti" e se aggiorno ancora la pagina in modifica, in effetti mi ritrovo "Benvenuti" e non la traduzione che avevo inserito.

May 7, 2019 at 2:51 pm #3759455

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Puoi verificare se questo problema si presenta anche con altre pagine o solo con la homepage?

May 7, 2019 at 3:07 pm #3759595

giacomoT-2

Purtroppo il problema è presente in tutte le pagine.

May 8, 2019 at 3:58 pm #3768821

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

nelle pagine già esistenti, se apro la console del browser (tasto F12), vedo diversi errori.

Ho provato a creare una nuova pagina ed eseguire la procedura di duplicazione e il problema non si presenta più.

Puoi provare a creare una nuova pagina in Italiano e a tradurla con la procedura indicata?
Se riesci a riprodurre il problema, puoi darmi i passaggi che hai utilizzato per creare la nuova pagina?

Grazie

May 10, 2019 at 7:33 am #3781999

giacomoT-2

Buongiorno e grazie per l'aiuto. Ho provato questa soluzione, ma anche qui il problema si ripresenta. L'unico modo che ho trovato per aggiornare le traduzioni inserite è switchare il tasto blu "Editor standard" due volte e poi aggiornare. In questo modo le pagine funzionano.

May 10, 2019 at 3:38 pm #3786293

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

in effetti questo potrebbe essere un indizio del problema.

Puoi provare ad installare ed attivare il plugin Classic Editor?
- hidden link

Nella mia copia locale questo plugin ha rimosso gli errori dalla console nella versione originale e le traduzioni vengono salvate correttamente.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

May 16, 2019 at 4:12 pm #3827893

giacomoT-2

Grazie del prezioso aiuto. In questo modo funziona tutto!
Grazie ancora

May 16, 2019 at 4:13 pm #3827899

giacomoT-2

My issue is resolved now. Thank you!