This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 4 risposte, has 2 voci.

Last updated by Noman 2 mesi, 3 settimane fa.

Assigned support staff: Noman.

Autore Post
July 30, 2019 at 4:30 pm #4309695

alessioV-2

Sto tentando di visualizzare il flag delle lingue nel menu

Link a una pagina dove è possibile vedere il problema: hidden link (la versione francese su hidden link)

Mi aspettavo di vedere: il solito selettore delle lingue di BeTheme (perfetto secondo me)

Invece al contrario di altre volte non riesco a visualizzare il flag del selettore lingue

Potete aiutarmi a capire come risolvere per favore? Grazie mille

July 31, 2019 at 4:25 am #4311431

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to answer this in English, I hope that is ok, if you still need help in Italian please let me know.

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. To display language switcher on the front-end, please make sure these two things are met:
a) Your developer should have added the language switcher to one of the site’s menus or as a widget/shortcode.
b) The contents you are viewing on the front-end must be translated. You can translate one page yourself to see if the language switcher appears correctly.
https://wpml.org/documentation/beginners-guide-to-site-translation/

3. Please delete all sorts of caches on your site / server cache / plugin cache (WP Fastest Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Fastest Cache plugin temporarily.

Thank you

July 31, 2019 at 12:32 pm #4314319

alessioV-2

Hi, I did it, but nothing has change.

Please can you help me? Usually with BeTheme everything was right
thank you

July 31, 2019 at 2:14 pm #4315185

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

August 1, 2019 at 5:24 am #4318819

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and added language switcher from WPML >> Languages > Menu Language Switcher as you can see in the attached screenshot. I have displayed language switcher as dropdown and you have the choice to display it as list from language switcher settings.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Thank you