This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.53 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Ho tradotto una pagina ma non compare come tradotta anche se ho finito di tradurre tutto al 100% nell'editor di traduzione.

Solution: Incrementa il valore del tuo MaxInputVar ad un valore superiore a 5000 se è possibile.

Documentazione Rilevante: http://it-serv.it/max_input_vars_cosa_e_come_risolvere_problema/

Etichettato: 

This topic contains 14 risposte, has 3 voci.

Last updated by Alejandro 5 mesi, 2 settimane fa.

Assigned support staff: Alejandro.

Autore Post
April 18, 2019 at 1:13 pm #3639375

elenaG-21

Sto tentando di: visualizzare i contenuti del mio sito in inglese

Mi aspettavo di vedere: il link nel menù principale per visualizzare i contenuti in inglese

Invece ho ottenuto: nel menù principale compare solo la dicitura "italiano" (che è la lingua in cui è stato realizzato il sito)

April 18, 2019 at 1:52 pm #3639717

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Se i contenuti sono tradotti e pubblicati, il selettore lingue, aggiunto tramite WPML -> Lingue, dovrebbe mostrare le lingue alternative.

1. Se non fosse così, verifica se la lingua secondaria non sia stata nascosta tramite le opzioni in WPML -> Lingue.

2. Puoi incollare le Informazioni di debug nell'apposito campo?
- https://wpml.org/it/faq/come-fornire-le-informazioni-di-debug-per-unassistenza-piu-rapida/

Grazie

April 24, 2019 at 12:01 pm #3672395

elenaG-21

In allegato anche uno screenshot che magari può essere utile.

Grazie

April 26, 2019 at 9:15 am #3689113

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Visto che Vincenzo non è attualmente disponibile, prenderò il suo posto qui nel forum, se non è un problema per te.

Prima di tutto ti consiglio di controllare questa documentazione del tuo tema su WPML: hidden link

Poi, quello che stai menzionando di solito è una cosa che succede quando non hai tradotto ancora quella pagina.

Vedi, il selettore di lingue non compare "globalmente" con le bandierine di tutte le lingue attive. Invece compariranno solo le bandierine/lingue di quelle che siano già tradotte.

Per questo ti chiedo di controllare se la/le pagine dove ti compare solo l'italiano siano effettivamente tradotte, cioè se la traduzione nell'editor di traduzione ti compare completa al 100% (altrimenti non comparirà pubblicata la traduzione di quella pagina).

poi fammi sapere, per capire come procedere.

April 26, 2019 at 3:50 pm #3692115

elenaG-21

Ciao,
ti ringrazio per l'assistenza.
Effettivamente la traduzione della pagina non va a buon fine, nel senso che scrivo tutte le traduzioni fino a raggiungere il 100%, poi salvo. Se chiudo e riapro la pagina, però, non rimane caricato il 100%, e si vede caricato solo parte del materiale.
Cosa significa?
Può essere che ho impostato nel modo sbagliato il plugin quando l'ho installato?
Grazie

April 27, 2019 at 11:24 am #3695281

elenaG-21

Può essere che il problema sia legato alla schermata in allegato?
Potrei risolvere inserendo quanto segue nel file .htaccess?

# BEGIN WordPress

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . /index.php [L]

</IfModule>

# END WordPress

è corretto?
L'ho trovato al seguente link sul sito WPML:

https://wpml.org/it/documentazione/guida-introduttiva/configurazione-della-lingua/impossibile-attivare-le-directory-delle-lingue/

Grazie

April 29, 2019 at 6:47 am #3700393

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Dici: "Effettivamente la traduzione della pagina non va a buon fine, nel senso che scrivo tutte le traduzioni fino a raggiungere il 100%, poi salvo. Se chiudo e riapro la pagina, però, non rimane caricato il 100%, e si vede caricato solo parte del materiale."

Mi potresti spiegare meglio questa parte, intendi che quando salvi e provi a riaprire la traduzione, ti riapre in uno stato diverso dal 100%?

Oppure non ti salva proprio i cambiamenti fatti?

In qualunque modo, inserisci per favore le credenziali nei campi che ho appena attivato, e dimmi per favore in quale pagina posso verificare questo problema.

Saluti.

April 30, 2019 at 7:28 am #3708679

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Penso di aver visto il problema, ho provato diverse volte a finire la traduzione e sembra che non si salvasse per niente. Sembra che questa traduzione sia proprio corrotta.

- In questo caso ti chiedo di salvare le stringhe tradotte e poi di andare su WPML > Gestione Traduzioni.

- Configura tutto e poi clicca la scheda "Lavori di traduzione"

- Cerca lì, la pagina (homepage) e poi cancellala. una volta avrai fatto questo, prova di nuovo a tradurre tutto.

Fammi sapere se dopo aver fatto questo il problema continua e mantieni le stringhe della traduzione salvata da qualche parte perché se il problema continua dovrò fare alcune prove che potrebbero cancellare il contenuto dei campi da tradurre.

Saluti.

April 30, 2019 at 8:00 am #3708953

elenaG-21

Buongiorno Alejandro,
non riesco a cancellare la pagina... mi da lo stesso problema che avevo prima, nel senso che sembra si cancelli, invece se riapro la pagina la traduzione, in backend, la trovo ancora all'80% e non riesco a cancellarla.

Ho salvato tutte e traduzioni sul pc.

April 30, 2019 at 2:12 pm #3712099

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Nel messaggio di prima (è privato) ti ho inviato le istruzioni per una migrazione, ti chiedo gentilmente di seguirle e di farmi sapere quando sarà finito perché probabilmente dovrò controllare diverse cose tra cui il database per cercare cosa sta succedendo quel che ti succede.

Fammi sapere.

April 30, 2019 at 3:05 pm #3712639

elenaG-21

Che tipo di prove dovete fare? Siete riusciti a capire dove risiede il problema?
Eventualmente potreste gestire voi la migrazione? Questo previa nostra conferma.
Il mio cliente sta avendo dei problemi a causa del fatto che non riusciamo ad avere il sito in inglese e io sto investendo troppo tempo per gestire questa attività.
È possibile sentirci telefonicamente per capire come procedere?
Il cliente mi chiede, se non dovessimo riuscire a risolvere in pochi giorni, se è possibile richiedere un rimborso per poter acquistare un altro plugin.
Grazie

May 2, 2019 at 8:35 am #3722741

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Sono prove a livello di database, ma per quello dobbiamo anche a vere tutti i plugin disattivati tranne quelli di WPML e un tema base attivo(twenty nineteen, ad esempio).

Certamente se mi dai permesso posso gestire io la migrazione, anche se probabilmente è più vloce se lo fai tu (visto che puoi farlo subito. Invece io devo aspettare una tua risposta).

La migrazione è questione soltanto di scaricare un plugin e di inserire le informazioni che ti ho inviato nel messaggio privato, da lì in poi ce la vediamo noi.

Per le regole del supporto, possiamo soltanto sentirci qui o tramite la chat e per il rimborso, si puo' chiedere eventualmente su questo link ma si devono rispettare le condizioni che troverai di seguito (sempre in quella pagina): https://wpml.org/it/purchase/politica-sui-rimborsi/

Fammi sapere, io dovrei parlare direttamente con gli sviluppatori che sono incaricati del editor avanzato per cercare al più presto una soluzione, ma sarebbe opportuno farlo prima del weekend visto che altrimenti dovremo aspettare a lunedì.

Saluti.

May 2, 2019 at 3:01 pm #3725837

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Mi sa che ho trovato la soluzione!

Non si salvano le traduzioni perché il valore del "max_input_var" della tua installazione è di 1000 mentre ci sono esattamente 2338 input nella traduzione.

Chiedi al tuo hosting di aumentare il valore a qualcosa di molto alto (10.000 ad esempio).

Puoi anche seguire questa guida in caso il hosting ti permetta di farlo autonomamente: http://it-serv.it/max_input_vars_cosa_e_come_risolvere_problema/

May 3, 2019 at 8:28 am #3732139
elenaG-21

Ciao,
ho fatto la modifica al valore "max_input_var" e ho inserito le traduzioni (che saranno poi da sistemare) ed ora effettivamente nel menù principale del sito compare il link per la versione del sito in inglese, ma cliccando si apre la pagina che puoi vedere nello screenshot allegato.
Cosa significa?
Elena

May 3, 2019 at 2:10 pm #3735065

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Visto che questo problema si è risolto, ti chiedo gentilmente di chiedere questo ticket.

Ho aperto un altro ticket per l'altro problema visto che possiamo rispondere soltanto un problema per ticket. questo serve ad evitare confusioni tra di noi e a mantenere il forum pulito per le altre persone che forse avranno un caso simile al tuo.

Ho già risposto l'altro ticket quindi fammi sapere quando potrai.

Saluti.