This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 6 risposte, has 2 voci.

Last updated by Noman 5 mesi fa.

Assigned support staff: Noman.

Autore Post
May 16, 2019 at 9:04 am

antonioV-10

Sto tentando di: inserire il selettore lingua nel menu ma non lo visualizzo

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: il selettore lingua nel menu

Invece ho ottenuto: che non si vede nulla, non vorrei che fosse stato modificato qualcosa nel CSS ma a me sembra tutto ok

May 16, 2019 at 9:56 am #3824361

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to answer this in English, I hope that is ok, if you still need help in Italian please let me know.

Could you please follow below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

=== Please backup your database and website ===

2. Please upgrade your server’s PHP version to a higher level: https://wpml.org/home/minimum-requirements/

- PHP is 5.5.38 which is lower than the required for WPML, Please upgrade it to more up-to-date version for better performance and stability. You can contact your website hosting company to upgrade this for you.

3. I have noticed that you are using an older version ( 1.6.1 ) of ‘LAON WINE HOUSE’ theme and latest version of ‘LAON WINE HOUSE’ theme is 1.7, please update the theme and see if this resolves your issue.
hidden link

4. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

May 16, 2019 at 10:18 am #3824533

antonioV-10

Salve,
ho aggiornato il PHP, ho inserito la stringa in wp-config.php ma non è cambiato nulla. Non posso aggiornare il tema Laon perché ha un costo.
Come possiamo risolvere? Perchè 10 giorni fa il selettore veniva visualizzato nel menu e adesso no? è strano davvero.... puoi controllare che non ci siano problemi nel CSS? ho l'impressione che sia solo un problema di visualizzazione visto che se nel menu di WPML selezione la visualizzazione delle lingue sul footer, il selettore appare. Solo nella barra menu non appare

May 16, 2019 at 12:33 pm #3825825

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Do you remember, did you do any update or performed any particular action in your site that cause this issue?

Could you please follow these steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

And let me know results, please.

Thank you

May 16, 2019 at 1:27 pm #3826269

antonioV-10

ho disattivato i plugin e sono passato al tema twenty seventeen e tutto funziona bene, anche se attivo i plugin. Se invece passo a Laon theme theme non visualizzo il più il selettore delle lingue

May 16, 2019 at 1:34 pm #3826381

antonioV-10

Ho risolto il mio problema! qui >> https://wpml.org/forums/topic/secondary-language-not-displayed-in-menu/

May 16, 2019 at 6:06 pm #3828691

Noman
Supporter

Languages: Inglese (English )

Timezone: Asia/Karachi (GMT+05:00)

Glad to see your issue is resolved and thanks for sharing solution with us.