This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 3 risposte, has 2 voci.

Last updated by Paola Mendiburu 1 mese, 2 settimane fa.

Assigned support staff: Paola Mendiburu.

Autore Post
April 3, 2020 at 10:41 am #5830823

alessioP-9

Buongiorno,

quando vado in:
WPML > Menu del selettore della lingua > +Aggiungi un nuovo selettore della lingua a un menu
Nuovo menu del selettore della lingua: la dropdown "menu:" non funziona.
Seleziono il menu ma la scelta fatta non rimane selezionata e naturalmente non posso salvare

April 3, 2020 at 2:52 pm #5833483

Paola Mendiburu
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Benvenuto al supporto cliente WPML.

Farò del mio meglio per aiutarti a risolvere questo problema.

Prima di tutto, aggiorna WPML all'ultima versione https://wpml.org/account/downloads/

Se il problema persiste, provare i seguenti passaggi:

Potresti provare a fare i seguenti passi:
- Disattiva temporaneamente i plug-in non WPML. Sei in grado di aggiungere un menu al selettore di lingua?
- Mantenendo disattivati i plug-in non WPML, cambia temporaneamente il tema attivo a Twenty Twenty. Non riesci ancora ad aggiungere il menu?

Per favore, dimmi cosa trovi.

Grazie,

Paola

April 9, 2020 at 8:41 pm #5879321

alessioP-9

Buonasera,
aggiornato WPML all'ultima versione, disattivati i plugin e cambiato tema ma il problema persiste.
Se le può essere di aiuto, negli strumenti per sviluppatori appare l'errore che allego.
Grazie mille

April 10, 2020 at 9:34 am #5882601

Paola Mendiburu
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Ciao,

Grazie per la tua collaborazione.

Potresti fare quanto segue per favore:
❌ Prima di procedere, ti consiglio di fare un backup completo del tuo sito ❌

Vai sul menu WPML > Assistenza > Risoluzione dei problemi
Premi i seguenti pulsanti, e controlla ad ogni premuta di pulsate se il problema si è risolto:
• "Cancella la cache di WPML"
• "Rimuovi dalle tabelle delle traduzioni le voci non correttamente collegate"
• "Correggi il confronto di element_type"
• "Inserisci informazioni sulla lingua"

Se il problema persiste, potresti per favore seguire le istruzioni che trovi in questo link per creare un registro di debug: https://wpml.org/it/documentazione/informazioni-per-gli-sviluppatori/eseguire-il-debug-di-wpml/

Dopo di aver inserito nel tuo file wp-config.php il codice presente nel link di sopra, cerca di ricreare il problema (quindi prova a salvare) e poi vai alla cartella "wp-content" della tua installazione WordPress. Se ci saranno stati problemi nel sito comparirà un file "debug.log"

Se riesci a incollare il tuo debug.log su https://pastebin.com/ e fornirmi quel link, sarebbe fantastico! (Questo è il modo più pulito, perché a volte i registri sono lunghi e creano un disordine completo in discussione).

Dopodiché darò una occhiata al file e determinerò quale strada prendere.

Questa ultima procedura mi aiuterà a capire come procedere.

Grazie,

Paola