This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 8 risposte, has 2 voci.

Last updated by Alejandro 4 giorni, 6 ore fa.

Assigned support staff: Alejandro.

Autore Post
November 8, 2019 at 2:26 pm #4914041

Marco

Sto creando un sito in italiano e in inglese, diversamente da come ho sempre fatto con altri siti, continua a volermi imporre di usare il sistema di traduzione di WPML (dove si vedono solo i campi da tradurre, anche se ho disabilitato l'editor di traduzione WPML.
A volte quando cerco di modificare una pagina in italiano mi diventa tutto grigio e per meno di un secondo mi esce l'errore indicato, poi scompare e rimane tutto bloccato (grigio) e devo chiudere la finestra. A meno che non clicco velocemente sul box al momento che compare (operazione che va più a fortuna che altro...). Come posso disabilitare del tutto questa cosa e poter modificare a mio piacimento le pagine in entrambe le lingue?

November 8, 2019 at 6:17 pm #4915863

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Quello non è un errore, e se rimane tutto grigio è perché qualcosa nel sito sta creando problemi e non permette la visione del popup. prova a scendere per vedere se lo trovi sotto.

Questo non è un errore, significa che al momento hai iniziato a tradurre questa pagina ma ancora non è stata 100% tradotta.

Come vedi nello screenshot, puoi selezionare, non mostrare più questo avviso per evitare che te compaia ogni volta.

Nello stesso screenshot vedo che lo stile del popup è tutto rovinato, il che indica che forse hai qualche caching o qualcosa del genere che non sta facendo caricare bene i file CSS.

Se hai cloudflare, Caching a livello di server o qualunque altro tipo di caching, puliscilo e disabilitalo nel frattempo, aspetta 4-5 min (Se usi cloudflare al meno) e poi pulisci anche il cache del tuo browser. poi prova di nuovo.

Se il problema continua allora probabilmente avrai un plugin che sta interferendo con i file CSS del popup. prova a disattivare temporaneamente tutti i plugin tranne quelli di WPML e vedi se così sparisce il problema.

Fammi sapere come va.

November 8, 2019 at 8:11 pm #4916649

Marco

Ciao Alejandro,
grazie della risposta, purtroppo non mi è possibile segnare "non mostrare più" in quanto faccio fatica già solo a cliccare "Ne sono consapevole" perché il messaggio scompare in meno di un secondo e rimane tutto grigio. Il popup non è visibile da nessuna parte, rimane solo per una frazione di secondo poi tutto è grigio / bloccato e non posso più fare niente.

Si può togliere questo avviso dai settings di WPML in modo che posso lavorare come ho sempre fatto?

Non ho cloudflare e non mi risulta ci sia caching a livello di server.

Ho alcuni plugin attivi e risultano compatibili con WPML (ho acquistato un tema su ThemeForest). Se li disattivo non risolvo il problema in quanto io non voglio proprio questo avviso / servizio. Voglio poter gestire le traduzioni come ho sempre fatto (cioè poter modificare le pagine in entrambe le lingue senza nessun popup).

Grazie mille
Marco

November 9, 2019 at 10:11 am #4917689

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi potresti dare accesso al tuo sito (ho attivato i campi appositi per l'inserimento sicuro e privato).

Così posso vedere cos'è che sta creando questo e sopratutto perché non riesci a disattivare l'editor di traduzione perché quello non è normale per niente.

Saluti.

November 9, 2019 at 10:15 am #4917761

Marco

Sono riuscito ad aggirare il problema forzando la traduzione, però è già capitato altre volte in questi giorni. Si può lasciare il ticket aperto in caso si ripresenta il problema? in questo caso mando subito i dati di accesso al sito per verificare.

November 9, 2019 at 12:06 pm #4918011

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Certamente. i ticket si chiudono autoamticamente dopo 14gg di inattività ma per ricreare il problema basterebbe creare una pagina "test", aggiungi del contenuto e poi semplicemente prova a tradurla con l'editor di traduzione ma non finirla (esempio: se ci sono 2 campi. finisci uno ma l'altro lascialo senza segnare "Traduzione completata". Salva tutto ed esci dalla traduzione)

Quello dovrebbe creare di nuovo questo popup e quindi se c'è ancora il problema, lo vedrai ancora.

Nel frattempo ti lascio il campo delle credenziali attivo per la tua prossima risposta.

Saluti.

November 12, 2019 at 11:40 am #4931327

Marco

Il problema si ripresenta. Ho scoperto che dipende al 100% dal plugin "WPML Translation Management", però se lo disabilito mi dà errore con WooCommerce. C'è modo di tenerlo attivo ma senza la gestione attiva? a me non servono quegli avvisi (e come detto non posso mettere il check perché scompare il popup).
Ho provato anche a rimuovermi ma non cambia niente.
Non ho idea di come mai ci sia questo avviso in quanto, come detto, uso gli stessi plugin anche su altri siti e non mi è mai uscito l'avviso per pagine non tradotte.

November 12, 2019 at 4:19 pm #4933085

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi potresti dare accesso al sito (tramite i campi che ho attivato per questa prossima risposta), perché purtroppo senza Translation management non funziona WooCommerce Multilingual, ma questo problema si deve sicuramente al translation management (perché è quello che crea il popup) ma anche ad un altro plugin o ad un altra cosa presente nella tua installazione.

November 12, 2019 at 4:43 pm #4933537

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Scusa, puoi aggiungere ora le credenziali.