Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 35 risposte, has 2 voci.

Last updated by Alejandro 1 mese fa.

Assigned support staff: Alejandro.

Autore Post
October 25, 2021 at 9:01 am #9854985

davideT-3

ok, ci ho provato 2 volte con lo stesso risultato

October 25, 2021 at 9:10 am #9855061

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok il problema sembra essere che il hosting blocca le richieste per la migrazione.

Non è un problema, potresti usare un plugin come All In One Migration ed esportare diverse copie del sito?

1) 1 con solo il database
2) Una con la directory dei media (uploads)
3) Una con i temi
4) una con i plugin

questo è necessario se vedi che un backup unico è più grande di 400MB.

puoi usare il plugin che desideri per fare i backup, basta che poi tu mi dica quale hai usato 🙂

October 25, 2021 at 9:51 am #9855725

davideT-3

se mi dici quale richieste devo dire al mio hosting di sbloccare gliele faccio sbloccare

October 25, 2021 at 11:09 am #9856427

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Non saprei dirti quali sono, ma non arrivano risposte dal tuo server quando il plugin fa la richiesta di migrazione.

Puoi chiedere al tuo hosting se hanno qualche sistema di sicurezza che blocchi richieste entranti ed uscenti oppure se hanno i permessi delle directory ristretti in modo tale che i plugin non possano scrivere dati o meno.

October 25, 2021 at 11:10 am #9856429

davideT-3

ok, grazie...ho già chiesto se c'è qualcosa che blocca...vediamo cosa mi dicono

October 25, 2021 at 11:35 am #9856675

davideT-3

ok mi hanno risposto così:
il plugin è di terze parti e non ne conosciamo il funzionamento, pertanto ha contattato il relativo supporto del fornitore e chiesto con esattezza quali sono questi errori tecnici? Può fare abilitare un debugging avanzato del plugin per capire quale sia l'errore e riportarci i dettagli tecnici?

October 25, 2021 at 11:53 am #9856857

davideT-3

Allora ho fatto così: Ti ho fatto un clone esatto del sito sul mio hosting:

hidden link

I parametri per entrare nel ftp e nel admin del sito sono quelli che ti ho girato prima...uguali.

Cambia la cartella del ftp che ora è /wpml.colomboleopoldo.com/

Fammi sapere
Grazie

October 25, 2021 at 2:21 pm #9858227

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Allora, ho fatto una pagina di test, con una colonna e un testo e tutto funzionava.

Poi ho cancellato la traduzione della pagina che dava problemi e ho lasciato soltanto la sezione che ha le colonne e guarda: hidden link

Come puoi vedere è tutto apposto qui, quindi il problema non arriva da WPML ma dalla pagina stessa, apparentemente.

Puoi provare a cancellare le traduzioni della pagina (anche dal cestino) e poi prova a ritradurre la pagina per vedere cosa succede.

October 25, 2021 at 3:47 pm #9858801

davideT-3

allora ho fatto delle prove e ho scoperto che un modulo delle "preview delle news" (ved.allegato) sviluppato dalla Divi Den (plugin di terzi) che ha sicuramente dei css e js (autonomi, nel senso che loro hanno una libreria dei codici per i vari moduli che io non posso vedere), va in conflitto con alcuni moduli (o alcune funzioni dei moduli divi) solo nella lingua inglese.

Perchè in Italiano tutto lavora perfettamente anche con questo "modulo preview news"

Quindi tirando le somme:

Alcune pagine lavorano bene con questo "modulo preview news" + wpml

Altre pagine non lavorano bene con questo "modulo preview news" + wpml + moduli o elementi divi che non ci sono nelle pagine che funzionano bene. (quindi come nel caso della pagina delle barche, che è quella dove stiamo controllando il perchè si spacca, il modulo divi con le foto delle barche conflitta con wpml e "modulo preview news" ), perchè in italiano non vanno in conflitto.

Un bel casino..

Quindi siccome la cosa sembra irrisolvibile in tempi stretti, io proverò cmq a contattare l'assistenza del plugin Divi Den, nel frattempo userò un altro modulo per le news in preview.

Grazie Davide

Schermata 2021-10-25 alle 17.43.04.png
October 26, 2021 at 7:57 am #9862397

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok!

Ti consiglio di fare una prova in questo modo se vuoi contattare divi den:

- Disattiva tutti i plugin tranne quelli di divi den
- Cambia la lingua principale del sito all'inglese in impostazioni > Generali
- Crea una pagina vuota dove aggiungi questo elemento e ricrei la situazione (fai vedere il problema)

- Questa pagina la puoi usare per inviarla al loro supporto, così velocizzi un po' la soluzione.

Nel frattempo chiudo questo ticket ma sentiti libero di aprire uno nuovo se hai qualche altro problema con WPML.

October 26, 2021 at 12:25 pm #9864305

davideT-3

Buongiorno, ho creato una pagina test "barche tre" e ho inserito tutti gli elementi e i moduli della pagina e tutto funziona in tutte e 2 le lingue.

Ora appena aggiungo il modulo Postit Blog Module di Divi Den la pagina in inglese si spacca.

Ho provato ad aprire la pagina in inglese direttamente dalla pagina dove vedo tutti i moduli e non da advanced tranlsation e ho scoperto che il modulo in questione compare con degli errori.

Ti giro gli allegati per farti vedere che tipo di errori escono.

Io li ho corretti tutti (rendono il modulo identico all'originale funzionante in italiano) ho salvato e me li ha mantenuti, vado sul frontend della pagina in lingua inglese e si vede ancora spaccata.

Allora sono entrato nella pagina inglese questa volta tramite advanced translation e ho salvato...vado sul frontend e la pagina è ancora spaccata.

Ritorno sulla pagina in inglese direttamente dove vedo tutti i moduli e andando sul modulo Postit Blog Module le correzioni che avevo fatto prima non ci sono più e il modulo ha ancora gli errori.

Quindi sembra che wpml non traduca in modo corretto il modulo e che le correzioni fatte direttamente sulla pagina inglese non vengano prese in considerazione.
Come mai? nel frattempo sto chiedendo assistenza anche a Divi Den che mi ha fatto notare questi errori creati da wpml nella traduzione del modulo.

Grazie Davide

Schermata 2021-10-26 alle 14.04.10.png
Schermata 2021-10-26 alle 14.04.29.png
Schermata 2021-10-26 alle 14.05.24.png
Schermata 2021-10-26 alle 14.05.38.png
October 26, 2021 at 12:53 pm #9864607

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Prova a ricreare il problema qui, così posso vedere se riesco a trovare una soluzione. immagio che divi den non sia compatibile con WPML e quindi non si configura per questo.

Prova ad installare divi e divi den qui: hidden link

Poi, prova ad attivare le lingue del tuo sito in WPML e per ultimo vedi se anche qui succede la stessa cosa.

October 26, 2021 at 3:28 pm #9866217

davideT-3

quindi la situazione è questa: se aggiungo il modulo Postit Blog Module dalla libreria nella pagina inglese (in visualizzazione pagina dove ci sono tutti i moduli di costruzione della pagina), la pagina in inglese fuzniona.
Appena entro da advanced translation in questa pagina (che funziona adesso), modifico qualcosa o anche senza modificare e salvo, la pagina non va più e si spacca.
Entrando di nuovo in modalità visualizzazione pagina, il Postit Blog Module (che prima era giusto e funzionava) è tornato ad avere gli errori e non funziona (come nelle schermate che ti ho girato prima).
Come mai? Grazie Davide

October 26, 2021 at 3:35 pm #9866321

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Purtroppo non ti posso dire "come mai" perché non conosco il plugin né come funziona. per favore fai quello che ti avevo chiesto qui: https://wpml.org/it/forums/topic/pagine-che-si-spaccano/page/2/#post-9864607

così posso studiare la situazione e capire meglio cosa succede e possibilmente come sistemare il tutto.

October 26, 2021 at 6:30 pm #9867853

davideT-3

Certo scusa non avevo letto il messaggio. Ho caricato tutto al link che mi hai dato e come puoi vedere mi esce ancora l'errore della pagina che in inglese si spacca.
Prova a vedere come ho fatto io, segui quello che ho scritto nell ultimo messaggio.
Grazie
Davide

The topic ‘[Closed] pagine che si "spaccano"’ is closed to new replies.