Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

La sua lettura è permessa a tutti, ma la pubblicazione è riservata esclusivamente ai clienti di WPML. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Our next available supporter will start replying to tickets in about 0.62 hours from now. Thank you for your understanding.

This topic contains 35 risposte, has 2 voci.

Last updated by Alejandro 2 mesi, 3 settimane fa.

Assigned support staff: Alejandro.

Autore Post
October 27, 2021 at 10:49 am #9873005

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Puoi provare ora nel sandbox? forse ho risolto il problema semplicemente registrando il loro shortcode e quindi questo vuol dire che devi fare lo stesso per i diversi shortcode (i.e: elementi di divi) che offrono loro

L'ho testato qui: hidden link vedi che ora funziona?

Comunque prova a creare una pagina e ricreare il problema se puoi anche tu: hidden link

------------

Per registrare gli elementi divi di questo divi den puoi seguire questa guida: https://wpml.org/documentation/support/maintaining-divi-builder-compatibility-wpml/

In questo caso il codice che devi aggiungere su WPML > Impostazioni > Codice XML Personalizzato è questo:

<wpml-config>
  <shortcodes>
    <shortcode>
      <tag>et_pb_blog</tag>
      <attributes>
        <attribute>admin_label</attribute>
      </attributes>
    </shortcode>
  </shortcodes>
</wpml-config>
October 28, 2021 at 11:23 am #9882481

davideT-3

Ok grazie, ora funziona quasi correttamente, come puoi vedere la pagina inglese non rispecchia esattamente quella in italiano.
I box sono sparpagliati in inglese, in italiano ci sono 3 box per ogni linea, in inglese ci sono 3 box sulla prima linea, 1 sulla seconda (al centro) e 2 sulla terza.
Poi le categorie in rosso sopra a destra (dentro al box) sono 5 categorie nel primo box e 1 categorie nel secondo, come se le categorie degli altri box (dove manca) se li prende tutte il primo box.
Come si possono risolvere queste cose?.
Se ho problemi del genere con altri elementi o moduli di Divi Den come faccio a capire(dove lo vedo) qual'è il <tag>et_pb_blog</tag> e quali gli attributi? <attribute>admin_label</attribute>
Nel senso come faccio a capire quali sono le peorpietà che devo inserire nel xml?
Grazie
Davide

Schermata 2021-10-28 alle 13.16.16.png
October 28, 2021 at 4:01 pm #9885553

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sospetto che il problema che mi fai vedere nello screenshot è che i post in quella lingua non esistono ancora o se esistono hanno una data diversa di quello in lingua originale. puoi controllare se è questo il caso?

di essere così, prova ad aggiungere la stessa data e assicurati che sia tradotto, per provare a ritradurre la pagina dove si trova quel blog post.

----------------

In questo link trovi anche le immagini di cosa devi fare: https://wpml.org/documentation/support/maintaining-divi-builder-compatibility-wpml/

il tag è il nombre dello shortcode e invece gli attributi sono soltanto quelli che hann ovalori che si devono tradurre.

se hai una cosa tipo:

[nome_shortcode titolo="titolo dello shortcode"]

"titolo" sarebbe l'attributo e "nome_shortcode" sarebbe il "Tag"

October 29, 2021 at 7:54 am #9889293

davideT-3

i post sono tutti uguali e tutti creati nello stesso giorno e tradotti nello stesso giorno, eppure si scombinano..cosa possiamo fare?
Grazie per la spiegazione del'xml

October 30, 2021 at 11:20 am #9895517

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Prima di continuare, avrò bisogno di accesso al tuo sito, visto che prima si era chiuso il ticket e si è cancellato per sicurezza.

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

November 2, 2021 at 2:40 pm #9910269

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Quale pagina ha quel problema che hai menzionato? perché ho visto:

- Barche tre
- Barche 2
- Barche test

e tutte avevno i post in grid ma erano tutti apposto in entrambe le lingue.

The topic ‘[Closed] pagine che si "spaccano"’ is closed to new replies.