Skip Navigation

Questo è il forum di assistenza tecnica di WPML, il plug-in multilingue di WordPress.

Tutti possono leggerlo, ma solo i clienti di WPML possono pubblicare qui. Il team di WPML risponde sul forum 6 giorni su 7, 22 ore su 24.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 6 risposte, has 2 voci.

Last updated by massimoD-8 5 anni, 4 mesi fa.

Assigned support staff: Vincenzo.

Autore Post
June 11, 2015 at 1:32 pm #636433

massimoD-8

Salve,
ho impostato la stringa

/%category%/%postname%/

come permalink personalizzato ma così facendo ho un errore 404 sulle varie pagine ad esclusione della home page. Ho provato a fare delle ricerche ma non riesco a risolvere in alcun modo.

Potreste gentilmente aiutarmi?

Grazie

June 11, 2015 at 3:29 pm #636549

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Salve e grazie per aver contattato il supporto WPML.
Mi occuperò di questo ticket.

- L'errore si manifesta solo nelle pagine in Inglese?

- Le categorie sono tradotte? WPML -> Traduzione della Tassonomia

- Il problema continua se si cambia il formato degli URL in 'Directory con lingue diverse' in WPML -> Lingue?

- impostando un altro formato di Permalink (/%postname%/) l'errore persiste?

- Impostando la base delle categorie e poi traducendola in WPML -> Traduzione stringhe, risolve il problema?

Inoltre vedo che nel sito ci sono delle gallerie immagini ma manca il plugin WPML Media che si occupa proprio di tradurre le immagini.

Grazie

June 15, 2015 at 9:56 am #638250

massimoD-8

Salve,
rispondo soltanto ora in quanto non ho ricevuto alcuna notifica via email. Dunque:

- L'errore si manifesta solo nelle pagine in Inglese?
No, modificando i permalink non funziona nemmeno la lingua principale (italiano)

- Le categorie sono tradotte? WPML -> Traduzione della Tassonomia
Non erano tradotte totalmente. Ho provveduto ma il problema persiste.

- Il problema continua se si cambia il formato degli URL in 'Directory con lingue diverse' in WPML -> Lingue?
Sì, purtroppo il problema continua.

- impostando un altro formato di Permalink (/%postname%/) l'errore persiste?
Sì, purtroppo l'errore persiste.

- Impostando la base delle categorie e poi traducendola in WPML -> Traduzione stringhe, risolve il problema?
Credo di aver tradotto tutto anche qui ma il problema rimane.

Ho installato, inoltre, il plugin per le immagini ma ora il sistema mi dà questo avviso nonostante abbia installato le ultime versioni di tutti i componenti:

You are running updated wpml-media-translation, but the following WPML component is not updated yet:
sitepress-multilingual-cms
wpml-sticky-links
wpml-string-translation
wpml-translation-management
Your site will not work as it should in this configuration Please update all WPML components which you are using. You can receive updates from your WPML.org account or automatically, after you register WPML.

Grazie

Saluti

June 15, 2015 at 11:49 am #638386

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Vorrei chiederti un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema.
Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente tu ed io possiamo vederle ed averne accesso.

June 15, 2015 at 1:45 pm #638570

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Da quello che ho visto sembra un problema del server, forse del file .htaccess

Il problema è che non posso verificarlo perché le credenziali FTP non funzionano.

Potrebbe verificarle e reinviarmele?

Per il problema delle notifiche consiglio di verificare che l'opzione sia attiva qui:
- https://wpml.org/account/account-settings/

Grazie

June 15, 2015 at 2:21 pm #638642

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ho sostituito il file .htaccess che era esistente ma vuoto, con uno nuovo e adesso sembra tutto corretto.

Potrebbe verificare e confermare?

Grazie

June 15, 2015 at 2:38 pm #638677

massimoD-8

Salve Vincenzo,
ho verificato ed ora tutto sembra funzionare correttamente! Grazie mille per l'assistenza!