This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.87 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 7 risposte, has 2 voci.

Last updated by annalisaM-2 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
September 26, 2018 at 9:52 am #2766701

annalisaM-2

Buongiorno,
credo di avere un problema di permalink nel sito: hidden link

In lingua inglese tutto funziona correttamente e se cambio lingua non si riscontrano problemi.
Se invece di visualizzare la pagina in inglese e poi in un'altra lingua provo a visualizzarla direttamente in una lingua diversa non trova la pagina tradotta e da errore 404.

Ad esempio: Impostando come lingua il rumeno e provando ad aprire la pagina
PROJECT ACTIVITIES --> Study tours
la pagina che il sito tenta di visualizzare non viene trovata
(hidden link).
Aprendo invece la stessa pagina prima in lingua inglese e successivamente cambiando la lingua in Rumeno la pagina tradotta in lingua rumena viene visualizzata correttamente (hidden link)

Come si può vedere i due permalink differiscono per un trattino (-) e uno slash (/), per questo ho pensato fosse un problema di permalink.

Questo si verifica per tutte le pagine tradotte, potreste indicarmi come risolvere il problema?
Grazie mille

Annalisa

September 26, 2018 at 10:22 am #2766817

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve Annalisa, grazie per aver contattato il supporto WPML!

Da quello che posso vedere online, PROJECT ACTIVITIES è il "genitore" della pagina Study tours.

1. Puoi verificare se la pagina PROJECT ACTIVITIES è stata tradotta in tutte le lingue e la sua traduzione non richiede aggiornamenti?

2. Assicurati che l'opzione "Imposta la relazione alla pagina "Genitore" in accordo con quella impostata nella lingua originale" sia attiva in WPML -> Impostazioni -> Sincronizzazione delle pagine e degli articoli.
- Se così non fosse, attiva l'opzione e salva nuovamente la pagina Study tours

3. Prova inoltre a salvare nuovamente i permalink da Impostazioni -> Permalinks

Grazie

September 26, 2018 at 1:52 pm #2767539

annalisaM-2

Ciao Vincenzo,
grazie per i suggerimenti ma purtroppo NON abbiamo risolto.

1. Puoi verificare se la pagina PROJECT ACTIVITIES è stata tradotta...
l'ho tradotta copiando i contenuti in inglese giusto per fare una prova ma non è cambiato nulla se non che ora giustamente nella pagina study tour mi fa selezionare PROJECT ACTIVITIES come pagina parente.
ma nella navigazione ancora da gli stessi problemi.

2. Assicurati che l'opzione "Imposta la relazione alla pagina "Genitore" in accordo con quella impostata nella lingua originale" sia attiva in WPML -> Impostazioni -> Sincronizzazione delle pagine e degli articoli....

Questo lo avevo già verificato prima di scriverti, ti mando screenshot

3. Prova inoltre a salvare nuovamente i permalink da Impostazioni -> Permalinks

Anche questo lo avevo già verificato prima di scriverti 🙂

Come procediamo?
Grazie
Annalisa

September 26, 2018 at 4:30 pm #2768098

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Annalisa,

una volta tradotta la pagina PROJECT ACTIVITIES ed impostato correttamente la relazione nella pagina "study tour" in lingua originale, puoi provare a salvare queste due pagine?
In questo modo la relazione dovrebbe passare anche alle versioni tradotte.

Prova inoltre a tradurre nuovamente la pagina "study tour" per verificare se lo slug è impostato correttamente in tutte le lingue.

Grazie

October 1, 2018 at 2:14 pm #2778412

annalisaM-2

Ciao Vincenzo,

scusa il ritardo della risposta ma aspettavo mi arrivasse un allert con la tua risposta che invece non è arrivato.
Ad ogni modo, ho fatto le prove che mi dicevi ma ancora non funziona. Hai altre prove da suggerirmi? vuoi una chiave d'accesso al backend?
Grazie per l'aiuto
Annalisa

October 1, 2018 at 2:41 pm #2778532

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Annalisa,

se fosse possibile adesso vorrei chiedere un accesso temporaneo (wp-admin e FTP) al sito per dare un’occhiata più approfondita al problema. Preferibilmente ad una versione test dove è stato riprodotto l'errore.

Troverai i campi necessari per far questo sotto l’area commenti quando effettuerai il log in per rispondere.
Le informazioni che inserirai sono private, il che significa che solamente noi possiamo vederle ed averne accesso.
Se non vedi il modulo sottostante, non postare le credenziali perché risulterebbe visibili nel forum pubblico:
hidden link

Potrei aver bisogno di replicare il tuo sito localmente. Per questo avrei bisogno di installare temporaneamente un plugin chiamato "Duplicator". Questo mi permetterà di creare una copia del tuo sito. Una volta risolto il problema, cancellerò la copia del sito. Fammi sapere se sei d'accordo.

Grazie

October 2, 2018 at 12:28 pm #2781397

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Annalisa,

sembra che il problema sia causato dal fatto che la pagina in Rumeno abbia come titolo, e quindi come slug, "study tour" e non "study tours".

Questo è il motivo per cui il link diretto che hai postato all'inizio del ticket non funziona.

Per risolvere, puoi modificare il titolo della pagina in Rumeno oppure modificare lo slug della pagina attivando il campo "slug" tramite le "Screen Options" in alto a destra.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

Documentazione relativa:
https://codex.wordpress.org/Administration_Screens#Screen_Options

October 3, 2018 at 11:04 am #2784271

annalisaM-2

Con l'assistenza di Vincenzo ho risolto il problemino!
Grazie per la pazienza e l'aiuto 🙂