This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.21 hours from now. Thank you for your understanding.

This topic contains 9 risposte, has 2 voci.

Last updated by Vincenzo 1 anno fa.

Assigned support staff: Vincenzo.

Autore Post
October 4, 2018 at 12:30 pm

nethics-sasd

Buongiorno,
per il sito ugetti.it riscontro i seguenti problemi:
1 – l’accesso alla pagina dello shop in lingua non funziona correttamente. Al momento si accede all’IT hidden link mentre non si accede alle versioni in lingua
hidden link
hidden link
Se salvo i permalinks lo shop in lingua a volte torna a funzionare TEMPORANEAMENTE; non so per quale motivo dopo un po’ l’accesso alle pagine in lingua non funziona nuovamente.
Altre volte salvando i permalinks si disabilita l’accesso allo shop in italiano e funziona correttamente l’accesso allo shop nelle altre 2 lingue. Non ho individuato alcuna logica.
2 – la tabella del DB delle string translations è molto grande (8 MiB ) (29.962 stringhe). Se disabilito le string translations il sito non funziona più in parte. Vorrei quindi disabilitare l’opzione per cui “le stringhe di tutti i text domain verranno registrate automaticamente” ed andare manualmente a selezionare i text domains per cui effettuerò le traduzioni. Ma una volta selezionati i text domains il numero di stringhe non diminuisce, né diminiusce la tabella del DB. Come faccio a rimuovere quanto non in uso?

October 4, 2018 at 4:43 pm #2788319

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve e grazie per aver contattato il supporto WPML!

Da quello che posso vedere, le pagine shop tradotte risultano vuote.

Visitando WooCommerce -> WooCommerce Multilingual -> Stato, vedo il seguente avviso "La base dei permalink del prodotto non è stata tradotta in:"

Per risolvere, prova i seguenti passaggi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Rimuovi le pagine Shop in tutte le lingue.
- Crea nuovamente una pagina Shop nella lingua predefinita del sito
- Usa il pulsante in WooCommerce -> WooCommerce Multilingual -> Stato per creare automaticamente le traduzioni mancanti della pagina Shop

Verifica se il problema è risolto.
Se non è così, prova i seguenti passaggi:

- Vai su Impostazioni -> Permalink
- Imposta nuovamente tutti i permalink in Italiano. In particolare prova ad impostare la Base personalizzata tutta in minuscolo.
- Salva i Permalink
- Vai su WooCommerce -> WooCommerce Multilingual -> URL del negozio
- Traduci nuovamente i tipi di slug che iniziano per "Base..."

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

October 5, 2018 at 8:49 am #2789915

nethics-sasd

Buongiorno,
le pagine shop sono vuote perchè sono pagine di woocommerce. Andando ad indicare nelle impostazioni di woocommerce hidden link (Woocommerce - impostazioni - prodotti - pagina negozio) quale sia la pagina shop, in automatico questa si "popola" con i prodotti. O meglio si dovrebbe popolare....Mentre scrivo si accede solo alla pagina shop italiana.

La base permalink prodotto non è tradotta ma in realtà le schede prodotto sono le uniche a funzionare anche in lingua. Esempio
hidden link
hidden link

Ho comunque fatto quanto indicato:
- rimosso le pagine Shop in tutte le lingue.
- creato nuovamente una pagina Shop nella lingua predefinita del sito (e associata in woocommerce come pagina shop predefinita)
- Usato il pulsante in WooCommerce -> WooCommerce Multilingual -> Stato per creare automaticamente le traduzioni mancanti della pagina Shop

Problema non risolto. le pagine si sono viste per qualche minuto, poi di nuovo è rimasto solo l'italiano e l'accesso alle lingue non ha più funzionato.

Ho dunque impostato nuovamente tutti i permalink in Italiano + Base personalizzata tutta in minuscolo.
- andata su WooCommerce -> WooCommerce Multilingual -> URL del negozio e tradotto nuovamente i tipi di slug che iniziano per "Base..." SENZA RIUSCIRE ad impostare correttamente "Base attributi prodotto"

Accedevo SOLO allo shop in FRANCESE e non allo shop in italiano ed inglese.
RISALVATO i permalinks --> è tornato lo shop SOLO in italiano :(((

Inoltre il backend rimane molto lento. Potrebbe essere legato alla seconda segnalazione che ho indicato nel ticket? (tabella DB string translations...)

October 5, 2018 at 2:50 pm #2791126

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

1. Per "ripulire" la tabella contenente le stringhe puoi provare i seguenti passaggi:
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Vai su WPML -> Traduzione stringhe
- Individua il drop-down "Seleziona quali stringhe visualizzare:" e seleziona l'opzione "Traduzione necessaria".
- Seleziona il dominio delle stringhe che desideri rimuovere
- Seleziona le stringhe di quel dominio testuale tramite il primo checkbox
- Premi il pulsante "Elimina le stringhe selezionate"
- Ripeti le operazioni per gli altri domini che non desideri tradurre
Se serve, puoi aumentare il numero di stringhe visualizzate tramite il selettore "Stringhe per pagina", in basso a destra.

2. Per il problema principale, dalle informazioni di debug vedo che il valore di WP Memory Limit è inferiore ai requisiti minimi di WPML che richiede almeno 128M.
- https://wpml.org/home/minimum-requirements/

Per incrementare il valore di WP Memory Limit aggiungi queste righe in mezzo al file wp-config.php (dopo il tag di apertura del php)

define( 'WP_MEMORY_LIMIT', '256M' );

❌ IMPORTANTE ❌ Non inserire la riga alla fine del file ma sempre prima del seguente commento riguardo la fine delle modifiche):

/* Finito, interrompere le modifiche! Buon blogging. */

Il file wp-config.php si trova nella cartella principale di WordPress.

Puoi verificare quale sia il valore attuale di WP Memory Limit da WPML -> Assistenza nella sezione Info

Maggiori informazioni qui:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

3. Potrebbe anche trattarsi di un problema di compatibilità o di qualche conflitto.

Prova i seguenti passaggi, preferibilmente in una versione di test del sito (staging):
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌
- Cancella tutta la cache e disattiva i plugin di cache.
- Se esiste un sistema di cache attivabile dal pannello del servizio di hosting, disattiva temporaneamente anche quello.
- Disattiva tutti i plugin tranne WPML e i suoi addon, WooCommerce e WooCommerce Multilingual.
- Imposta un tema predefinito (per es. Twenty Sixteen oppure Storefront).
- Se il problema si risolve, comincia ad attivare i plugin uno alla volta finché il problema non torna.
Infine riattiva il tema.

- Puoi segnalarmi quando torna il problema?

Grazie

October 8, 2018 at 10:10 am #2795490

nethics-sasd

Ho fatto quanto indicato.
Ho aumentato WP Memory Limit
Ho creato una copia del sito all'interno della quale possiamo fare tutti i test del caso hidden link
E' successo questo:
Ho disabilitato tutti i plugin (tranne woocommerce, woocommerce multilingual e WPML + addon) e lasciato il tema DIVI --> Le pagine shop si vedevano
Ho iniziato a riabilitare un plugin per volta e quando sono arrivata ad Inifinite WP la pagina shop non era più raggiungibile.
L'ho disabilitato (Infinite WP) nuovamente ma la pagina shop non è tornata raggiungibile.
Ho disabilitato tutti i plugin e nulla, le pagine shop in lingua non erano raggiungibili.
Ho disabilitato allora il tema e le pagine shop in lingua sono tornate raggiungibili.
Con il tema twenty seventeen ho ripreso a riabilitare i plugin ad uno ad uno.
Questa volta le pagine shop sono scomparse quando ho riabilitato Divi map extended module.
Allora l'ho nuovamente disabilitato ma nulla, le pagine in lingua non tornano disponibili.
La situazione attuale è:
tema --> twenty seventeen
Plugin tutti disabilitati (tranne woocommerce, woocommerce multilingual e WPML + addon)
La pagina shop in italiano è ok hidden link
Le pagine in lingua no
hidden link
hidden link

Non c'è dunque una casistica a fronte della quale la pagine shop in lingua tronano raggiungibili e lo restano stabilmente.

Tra l'altro il sito si rallenta tremendamente dopo le prime operazioni nel backend.

Può accedere al hidden link con le stesse credenziali fornite in apertura di ticket (attenzione ad accedere a hidden link e non all'ambiente indicato in apertura ticket :))

Può fare tutti i test e le verifiche del caso.
Grazie

October 9, 2018 at 11:50 am #2799769

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

sembra che il problema possa essere causato dal fatto che è stata scelta una sottopagina come pagina di Shop.

Sto effettuando alcuni test per cercare di riprodurre il problema su un'installazione di prova.

Nel frattempo, come workaround, puoi provare ad utilizzare una pagina che non sia una sottopagina, come pagina Shop di WooCommerce?

In questo modo, il problema si risolve?

Grazie

October 10, 2018 at 2:31 pm #2804784

nethics-sasd

Buongiorno! Sì in questo modo risolvo il problema e le pagine negozio sono accessibili in tutte le lingue.
L'impossibilità però di far dipendere la pagina shop da una pagina padre mi crea attualmente dei problemi al menu di navigazione. Cercherò di risolverli rivedendo il menu ma.... lato vostro non è stato possibile trovare una soluzione? 🙂
Grazie

October 12, 2018 at 5:39 pm #2812831

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve,

il problema è che non riesco a riprodurre il problema in una installazione nuova di WordPress + WooCommerce + WPML

Anche impostando la pagina Shop allo stesso modo del tuo sito, il problema non si presenta.

Se lo desideri, posso creare un'installazione nuova di WordPress dove puoi provare a riprodurre il problema.
In questo modo potrò mostrare il problema al supporto di secondo livello e provare a risolverlo.

Grazie

October 16, 2018 at 8:38 am #2820125

nethics-sasd

Buongiorno, chiedo di verificare il funzionamento per quanto riguarda la cancellazione delle stringhe. Nell'ambiente di test al quale vi ho dato accesso hidden link, sezione WPML - Traduzione stringhe.
Seleziona quali stringhe visualizzare --> traduzione necessaria
Seleziona le stringhe all'interno del dominio --> admin_texts_wpseo_titles
Provo a cancellare solo una stringa, come test --> [wpseo_titles]company_name
MI chiede "sei sicuro di voler cancellare........? E clicco su OK
Appena ritorno nella sezione traduzione stringhe noto che la stringa selezionata NON è stata cancellata.
Può verificare?
Grazie

October 16, 2018 at 9:18 am #2820244

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Buongiorno,

puoi verificare se il dominio testuale in questione è stato disattivato dall'invio automatico delle stringhe?
Puoi verificarlo da WPML -> Traduzione stringhe, nella sezione "Attiva invio automatico delle stringhe in traduzione".
Clicca sul pulsante "Modifica" all'interno di quella sezione e disattiva i domini testuali delle stringhe che non vuoi registrare.

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie