This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 38 risposte, has 2 voci.

Last updated by Alejandro 1 settimana, 3 giorni fa.

Assigned support staff: Alejandro.

Autore Post
January 24, 2020 at 5:10 pm #5358527

paoloG-8

Buongiorno,

dopo l'ultimo aggiornamento WPML (in data odierna), alcuni testi del plugin yith-woocommerce-request-a-quote-premium non compaiono più nella loro traduzione in inglese, ma restano in italiano (vedi eng1.jpg - eng2.jpg).

Inoltre i testi "Category:", "DESCRIPTION" e "Description" (credo siano gestiti dal plugin woocommerce) restano in inglese anche nella versione in italiano (vedi ita1.jpg).

Le traduzioni sono tutte presenti in "Traduzione stringhe" e prima dell'aggiornamento funzionavano tutte.

Elenco testi plugin yith-woocommerce-request-a-quote-premium:

Chiedi a Tizzio questa opera > Ask Tizzio this work

Questo quadro è già nella lista della richiesta di preventivo > This painting is already on the quote request list

Vedi l'elenco > See the list

Quadro aggiunto > Painting added

Testi pagina prodotto:

Category: > Categoria:

DESCRIPTION > DESCRIZIONE

Description > Descrizione

PS1: Ho provato anche a rifare la scansione del plugin yith in "Localizzazione del tema e dei plugin", ma senza risolvere.

PS2: Oltre a WPML, si sono aggiornati anche i plugin yith-woocommerce-request-a-quote-premium e woocommerce (WP e tutti i plugin sono aggiornati alle ultime versioni).

Grazie e cordiali saluti.

January 24, 2020 at 5:28 pm #5358673

paoloG-8

Qualche anno fa avevo aperto il ticket "Compatibilità con “Yith Woocommerce request a quote”" con Vincenzo e avevamo risolto (vedi ticket).
Poi la soluzione, che consisteva nell'aggiunta di un file wpml-config.xml, è stata integrata dal produttore nelle nuove versioni di yith ed è andato tutto liscio fino ad oggi.

January 27, 2020 at 3:38 pm #5371039

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

I plugin di YITH, dovrebbero essere tutti compatibili in questo momento, però loro hanno avuto degli aggiornamenti recenti per sistemare alcuni problemi.

Menzioni di aver aggiornato tutti i plugin ma puoi controllare direttamente nel loro sito che gli aggiornamenti siano gli ultimi?

Prova a vedere se per caso su WPML > How to Localize themes and update ti compare all'inizio della pagina un elemento di sfondo grigio con il testo "Search and import MO Files", se compaiono, per favore caricali e poi risalva le stringhe.

Altrimenti risalva le stringhe in questione su WPML > String Translation.

Se niente di questo funziona, allora ti chiedo di darmi accesso al sito (tramite i campi appositi che ho abilitato per te), se ti è possibile, così da poter dare una occhiata da vicino al problema.

Saluti.

January 28, 2020 at 11:19 am #5376737

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Potresti controllare il link per accedere al admin panel? perché mi dice che non esiste la pagina.

Parlo di questo link: hidden link (il link è nascosto per tutti tranne che per noi supporter e per te).

Fammi sapere per poter accedere e continuare.

January 28, 2020 at 11:24 am #5376761

paoloG-8

Scusami, sono rimaste delle maiuscole per sbaglio:

hidden link

January 28, 2020 at 4:39 pm #5379339

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi potresti dire se questo sito ha qualche tipo di caching di livello server attivo? perché faccio alcune modifiche e non vedo mai i cambiamenti e questo è tipico dei caching a livello PHP.

Potresti dirmi per favore? se hai attivo qualunque tipo di caching di livello server (Memcache, OPcache, varnish, redis) per favore dimmi quale e disattivalo per il dominio di test mentre faccio le prove.

Poi, quella stringa "categoria" la sta aggiungendo il tema e non WooCommerce.

Poi, così come sta il sito (con quasi tutto disattivato) potresti per favore seguire queste istruzioni:

❌ Prima di procedere, ti consiglio di fare un backup completo del tuo sito ❌

Vai sul menu WPML > Assistenza > Risoluzione dei problemi
Premi i seguenti pulsanti, e controlla ad ogni premuta di pulsate se il problema si è risolto:
• "Cancella la cache di WPML"
• "Rimuovi dalle tabelle delle traduzioni le voci non correttamente collegate"
• "Correggi il confronto di element_type"
• "Inserisci informazioni sulla lingua"
• "Correggi l'assegnazione del tipo di articolo per le traduzioni"

Fammi sapere come va e se il problema si risolve, ti ringrazierei tantissimo se potessi dirmi quale opzione ha risolto il problema. Altrimenti possiamo provare altre soluzioni.

January 28, 2020 at 5:01 pm #5379531

paoloG-8

Nessun tipo di cache.

In quanto alle modifiche vedo che "Ask Tizzio this work" è apparso sulla pagina prodotto in inglese.

January 28, 2020 at 5:05 pm #5379567

paoloG-8

"Poi, quella stringa "categoria" la sta aggiungendo il tema e non WooCommerce."

Ok, comunque prima compariva in italiano (come la stringa Descrizione).

January 28, 2020 at 5:07 pm #5379577

paoloG-8

Domani sono fuori ufficio, ci aggiorniamo giovedì mattina.

January 28, 2020 at 6:11 pm #5379947

paoloG-8

Vedo che anche gli altri testi di Yith sono comparsi in inglese correttamente (mi diresti cosa hai fatto per risolvere?).

A questo punto mancano solo questi:

Testi pagina prodotto:

Category: > Categoria:

DESCRIPTION > DESCRIZIONE

Description > Descrizione

Le prove che mi hai chiesto sul menu WPML > Assistenza > Risoluzione dei problemi, non hanno cambiato niente.

January 29, 2020 at 12:10 pm #5384085

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Mi sa che allora c'è qualcos'altro che ha un tipo di cache, sarà che si tratta dei plugin di YITH?

L'unica cosa che ho fatto per far comparire tutto correttamente è una di queste due:

1) Ho ritradotto le stringhe e risalvato
2) Ho cancellato le stringhe e le ho riscannerizzato usando la funzione "Look for strings while pages are rendered" che trovi in WPML > String translation (Devi accedere alla pagina nel front-end e aggiornarla se era già aperta e WPML registrerà le stringhe).

Ho anche provato a cancellare le stringhe che avevano lo stesso dominio, perché c'erano 2-3 che erano state duplicate (stesso dominio, stesso contenuto) e questo sicuro creava il problema che hai riscontrato.

Però quando ho provato io non si vedevano i cambiamenti, il che mi ha fatto pensare che il cambiamento aveva a che fare con alcun tipo di cache.

Prova a fare la stessa cosa, forse aspetta un po' e vedi tanto le stringhe vecchie come le stringhe nuove (quelle che hai menzionato nella tua ultima risposta) per vedere se scompaiono (se ritornano alla lingua originale in entrambe traduzioni) e fammi sapere come va.

January 30, 2020 at 12:11 pm #5391861

paoloG-8

Ho provato la procedura 2) sul sito in produzione hidden link

Quando attivo la funzione "Look for strings while pages are rendered", tutti i testi tornano a posto (Ask Tizzio... ecc., Categoria:, Descrizione).
Appena la distattivo, tutto torna come prima.

Ho provato a cancellare le stringhe, poi ho attivato "Look for strings while pages are rendered" e ho fatto scansionare di nuovo le stringhe, ho inserito le traduzioni, tutto funzionante.
Poi disattivo "Look for strings ..." e tutto torna come prima (ho atteso anche che si disattivasse da solo dopo le due ore, ma continua a ripristinarsi l'errore).

January 30, 2020 at 12:31 pm #5391955

paoloG-8

Sul sito staging ho disabilitato anche il plugin YITH e le stringhe "Category:" e "Description" continuano a non comparire in italiano (nella pagina del prodotto sono gestite da Woocommerce).

January 30, 2020 at 8:27 pm #5395081

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Scusa, ma questo vorrebbe dire che dopo essere ricomparse sono scomparse di nuovo queste stringhe?

Chiedo questo perchè qui: https://wpml.org/it/forums/topic/plugin-yith-woocommerce-request-a-quote-premium/#post-5379947 hay menzionato che alcune stringhe si erano sistemate.

Fammi sapere per conoscere come procedere.

January 31, 2020 at 2:19 pm #5399955

paoloG-8

Nel post #post-5379947 mi riferivo al tuo intervento sul sito di staging (hidden link), poi ho provato la procedura 2) del tuo post #5384085 sul sito in produzione hidden link e non sono riuscito a risolvere come sei riuscito tu (sul sito staging sei riuscito a far comparire tutte le traduzioni dei testi YITH, ma sono rimasti insoluti i testi "Category:" e "Description").

Procedura 2)
Sul sito hidden link ho provato a cancellare le stringhe, poi ho attivato "Look for strings while pages are rendered" e ho fatto scansionare di nuovo le stringhe, ho inserito le traduzioni, e sono tornate a comparire (sia i testi YITH che quelli "Category;" e "Description").
Poi disattivo "Look for strings ..." e tutto torna come prima (ho atteso anche che si disattivasse da solo dopo le due ore, ma continua a ripristinarsi l'errore).
Se riattivo "Look for strings ..." le traduzioni tornano a posto, ma non posso lasciare attiva in eterno questa opzione.

Tutto chiaro?