This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client wasn't able to automatically update his plugin Solution: After giving instructions and providing the screencast on how to create and add properly a site_key in installation of WPML the plugin was updated succesfully.

Screencast: http://screencast.com/t/nhRozB9TBtBi

This topic contains 5 risposte, has 2 voci.

Last updated by Dimitris 5 anni, 1 mese fa.

Assigned support staff: Dimitris.

Autore Post
January 8, 2015 at 1:56 pm #539228

danielab-3

I am trying to: upgrade the plugins WPML CMS Nav, WPML Media, WPML Multilingual CMS, WPML String Translation but it does not work. The message error is: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
What can I do?

I visited this URL: hidden link

I expected to see:

Instead, I got:

January 8, 2015 at 3:54 pm #539351

Dimitris
Supporter

Timezone: Europe/Athens (GMT+02:00)

Hi Daniel,

We've released an update on our site for this. Could you try this again?

Also, can you check with your hosting provider if you have the following option in comments in your php.ini file?
; mbstring.func_overload = 7

Regards,
Dimitris

January 12, 2015 at 1:15 pm #541017

danielab-3

Hi Dimitris,
I am sorry but I cannot find the update on your website. Could you please send me the URL of the page. For the php.ini I will ask my provider.

January 13, 2015 at 11:33 am #541612

Dimitris
Supporter

Timezone: Europe/Athens (GMT+02:00)

Hello,

I'm sorry for the misundertanding. What I meant is that we've released an update for our own site that we use to provide the updates and validate site_keys. The validation of the site key is required for the auto-update.

Because of that, please make sure that you've added the site key correctly. I would suggest deleting your old one and creating a "fresh" one and update it on your site too. You can check the screencast on how to do this here: hidden link

Another thing you can try is the solution described here: http://wpml.org/errata/installer-site-key-always-recognized/ This was a temp-fix for an issue with older versions but this is considered resolved now. Either way, please try this as this might fix your issue

If none of the above helps, please post your WP and FTP details in the private fields below the comment area, when you log in for your next reply.

Regards,
Dimitris

January 13, 2015 at 11:55 am #541631

danielab-3

I entered the site-key and now everything is ok. Thanks

January 13, 2015 at 11:59 am #541640

Dimitris
Supporter

Timezone: Europe/Athens (GMT+02:00)

Glad you resolved this 🙂