This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 risposte, has 2 voci.

Last updated by Laura 3 settimane fa.

Assigned support staff: Laura.

Autore Post
November 15, 2019 at 4:05 pm #4955453

rosarioR

Hello
I think I have a problem with the media.
As you can see in the video, some pages do not show the images contained. Depends on what?
hidden link

The pages are all built with WpBakery.
I have installed all the plugins and addons.
hidden link

Thank you

November 16, 2019 at 3:02 pm #4958719

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Salve,

grazie per averci contattato.

Dal video si nota che il checkbox "Duplica i file multimediali creati nelle traduzioni" non è selezionato. Se nelle traduzioni non si vedono le immagini, probabilmente dipende da questo.

Se invece succede solo con la lingua di default, perché il problema dovrebbe essere correlato a WPML? Disattivandolo le immagini compaiono?

November 17, 2019 at 8:55 am #4959953

rosarioR

Salve,
grazie per averci risposto.

Forse non sono riuscito a spiegare bene il problema.

Le immagini non compaiono nel pannello traduzioni, come mostrato all'inizio del video.
Successivamente il video mostra il back-end della pagina solo per mostrare dove le immagini sono posizionate.

Il checkbox su "Duplica i file multimediali creati nelle traduzioni" all'interno della pagina, non l'ho selezionato perché l'ho già selezionato nelle impostazioni generali, infatti altre pagine mostrano le immagini nel pannello traduzioni.

Tra l'altro se non sbaglio il "Duplica i file multimediali creati nelle traduzioni" non duplica veramente i file, ma assegna ai file solo una traduzione diversa.

Grazie

November 19, 2019 at 8:17 am #4969323

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

nel video vedo la pagina Gestione Traduzioni, e poi apri una singola pagina con l'editor di WordPress.

Se stai utilizzando Gestione Traduzioni, non dovresti utilizzare l'editor di WordPress ma l'editor di WPML.

Inoltre, se in WPML > Impostazioni hai selezionato di duplicare le immagini, il checkbox dovrebbe essere automaticamente selezionato di default, e invece non lo è.

Infine la pagina che si vede nel video è in italiano, che è la lingua di default, quindi non mi è chiaro quale dovrebbe essere il problema con la traduzione.
Se il problema è con la lingua di default, sei sicuro che si presenti anche senza WPML installato? Cosa succede se provi a tradurre?

November 19, 2019 at 9:57 am #4970491

rosarioR

Ciao,
credo di non essere riuscito a spiegare il problema.

Faccio un riepilogo:
Il sito attualmente in Italiano ed è costruito con Wpbakery, questo deve essere inviato ai traduttori, perciò mi reco nella pagina "Gestione Traduzioni" e da qui seleziono le pagine e i relativi file multimediali da inviare per la traduzione.
Qui nasce il problema, alcune pagine non mostrano i file multimediali.
Lo vedi all'inizio del video.

Nel video si vede come una pagina che non mostra i file multimediali dentro "Gestione Traduzioni" siano invece presenti e si vedono in front-end e in back-end.
Infatti nel video mostro il back-end per far vedere soltanto come è costruita la pagina e come siano presenti le immagini.

Puoi spiegare cosa intendi per:
"Se stai utilizzando Gestione Traduzioni, non dovresti utilizzare l'editor di WordPress ma l'editor di WPML."

Le pagine sono costruite con Wpbakery
Le traduzioni verranno gestite dai traduttori dalla pagina "Traduzioni".

Infine come dicevo ho già selezionato in impostazioni "duplicare le immagini" lo vedi in questa screenshot.
hidden link

Spero di essere riuscito a piegare questa volta il problema.

November 19, 2019 at 12:30 pm #4971969

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

se disattivi WPML le immagini si vedono?

November 19, 2019 at 3:25 pm #4973915

rosarioR

Ma si vedono dove?

Le immagini si vedono sempre, non è questo il problema.
Il sito mostra correttamente le immagini sia in front-end che in back-end.

Non vengono solo visualizzate dentro "Gestione Traduzioni" per inviarle alla traduzione.

November 19, 2019 at 5:20 pm #4974687

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Una volta completata la traduzione sono visibili? Dal video sembrano immagini di sfondo, se così fosse non dovrebbero essere incluse nella traduzione perché sono elementi del layout e non del contenuto.

November 20, 2019 at 8:47 am #4977665

rosarioR

La traduzione come già detto non è stata fatta ancora, ma di sicuro le immagini si vedranno, non è questo il problema...

Si quelle immagini del video sono immagini di fondo, ma in mezzo ci sono anche immagini di contenuto, ma se non compaiono in Gestione Traduzioni, come faccio ad inviare quelle da tradurre?
Le altre pagine infatti mostrano le immagini in Gestione Traduzioni, e da li ho scelte quelle da tradurre.

Ancora non mi è chiaro se sono riuscito a spiegarle il problema...
Grazie

November 20, 2019 at 12:42 pm #4980009

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ho capito il problema, ma se le immagini sono parte dello sfondo non si possono tradurre tramite Gestione Traduzioni.

Se invece sono inserite dentro moduli di page builders può darsi che ci sia bisogno di registrarle in qualche modo. Non è possibile stabilirlo avendo solo il video come informazione.

Potresti comunque provare a selezionare il check "duplica le immagini" nella pagina originale? Come ti ho detto dovrebbe essere ugualmente selezionato anche se è stato impostato direttamente in WPML > Impostazioni.
Nella pagine che non presentano il problema il check è selezionato oppure no?

Hai una copia di staging dove posso verificare meglio?

The topic ‘[Closed] Problem with media translation’ is closed to new replies.