This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This thread is resolved. Here is a description of the problem and solution.

Problem: se uso Formato URL per domini, i diversi loghi finiscono per sovrascriversi e si vede lo stesso in entrambe le lingue

Solution: Vai su WPML > Lingue > Formato URL per domini > Passa gli argomenti della sessione tra i domini tramite il selettore di lingua

Abilita "Passa gli argomenti tramite POST" (oppure tramite GET) e risalva i permalink

This topic contains 13 risposte, has 2 voci.

Last updated by bossiR 2 mesi fa.

Assigned support staff: Alejandro.

Autore Post
October 30, 2019 at 12:21 pm

bossiR

Buongiorno,

riscontro alcuni problemi legati alla gestione delle lingue con 2 diversi domini.

PREMESSE:
il sito gira istanza Bitnami WordPress di Amazon AWS, senza sistema di cache.
ho impostato WPML per avere 2 lingue con 2 domini differenti.
I DNS fanno puntare entrambi i domini allo stesso server IP.
La lingua principale è l'italiano (hidden link), la secondaria è l'inglese (hidden link)

Sto utilizzando il tema Divi e rispettivo builder:
quando provo a modificare un articolo in lingua ITA, il builder funziona correttamente e vedo che nella barra degli indirizzi, il sistema mantiene il dominio principale in italiano(hidden link); viceversa, se provo a modificare un articolo in lingua inglese, quindi usando il modulo di cambio lingua direttamente nella dashboard di wordpress, il builder non viene caricato. Per far caricare il builder devo cambiare il dominio manualmente nella barra degli indirizzi e ricaricare la stessa pagina con il dominio inglese.
(Vedi img allegate "Dominio IT.png" e "Dominio EN.png")

Inoltre, riscontro problemi nella traduzione delle stringhe, precisamente, per avere 2 differenti loghi.
La traduzione avviene ma, dopo qualche modifica generica al sito, viene imposto il logo inglese anche nell'italiano.

Vi ringrazio anticipatamente.
R.

November 4, 2019 at 12:21 pm #4880755

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Cominciamo con raggiungere i requisiti minimi di WPML:

Per favore, aggiungi questo codice nel tuo file wp-config.php, subito dopo l'informazione del database

define('WP_MEMORY_LIMIT','128M');

Poi, come seconda cosa, rinomina il file .htaccess e vai poi su settings > Permalinks e risalva i permalinks.

Poi, come terza cosa, mi potresti dire se i multidomain funzionano nel front-end e quindi il problema è soltanto con DIVI nel back-end?

Grazie in anticipo per le risposte!

November 4, 2019 at 2:00 pm #4881803

bossiR

Ciao Alejandro,

grazie per la risposta.

il file wp-config.php era già impostato con

define('WP_MEMORY_LIMIT','256M');

, adesso l'ho settato con

define('WP_MEMORY_LIMIT','128M');

.

Nella root di WordPress non ho il file .htaccess , al momento va a leggere quello di default:

# Only allow direct access to specific Web-available files.

# Apache 2.2
<IfModule !mod_authz_core.c>
        Order Deny,Allow
        Deny from all
</IfModule>

# Apache 2.4
<IfModule mod_authz_core.c>
        Require all denied
</IfModule>

# Akismet CSS and JS
<FilesMatch "^(form\.js|akismet\.js|akismet\.css)$">
        <IfModule !mod_authz_core.c>
                Allow from all
        </IfModule>

        <IfModule mod_authz_core.c>
                Require all granted
        </IfModule>
</FilesMatch>

# Akismet images
<FilesMatch "^logo-full-2x\.png$">
        <IfModule !mod_authz_core.c>
                Allow from all
        </IfModule>

        <IfModule mod_authz_core.c>
                Require all granted
        </IfModule>
</FilesMatch>
</Directory>

Supporto: (hidden link)

Cosa intendi per "rinominare" il file .htaccess?
I permalink sono stati salvati nuovamente.

I multidomain nel frontend funzionano.
ESEMPIO: sono in un articolo nella sezione ITALIANA del sito > cambio lingua (EN) > provo a costruire sul frontend (IMG 1) > il dominio cambia con quello inglese, ma non sono più loggato dentro wordpress.(IMG 2)

November 4, 2019 at 3:38 pm #4882777

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Allora, dici questo:

"Nella root di WordPress non ho il file .htaccess , al momento va a leggere quello di default:"
Il WordPress, per default crea un file .htaccess, quindi se non ce l'hai fai questo:

- Crea un file chiamato .htaccess e salvalo
- Vai su Impostazioni > Permalink > Premi il pulsante alla fine della pagina per salvare i permalink
- Vedi se questo file .htaccess che hai creato (e che era prima vuoto) ora ha del contenuto.

- Se è vuoto, copia il contenuto da qui: https://wordpress.org/support/article/htaccess/#basic-wp

e di nuovo salva i permalink e controlla che si possa navigare tra i diversi domini nel front-end.

Poi, il fatto di non essere più loggato a WordPress si deve ad una funzionalità che devi abilitare su WPML > Lingue > Formato URL delle lingue > Auto sign-in /out users from all domains

Per ultimo, prova ad aggiornare WPML alla versione che è uscita poche ore fa: https://wpml.org/it/account/downloads/

queste nuove versioni hanno tanti bug di DIVI sistemati, anche se probabilmente dovrai aggiornare DIVI alla versione 4, visto che anche loro hanno sistemato alcuni bug con WPML.

Fammi sapere come va.

November 5, 2019 at 10:16 am #4887605

bossiR

Ho fatto tutti i passaggi:

- adesso c'è il file .htaccess, scritto direttamente da WordPress, con all'interno lo stesso testo che trovo qui (https://wordpress.org/support/article/htaccess/#basic-wp).
- Funzione "Auto sign-in /out users from all domains" abilitata.
- WPML aggiornato.
- DIVI aggiornato.

Still having prob:
Se accedo dal dominio ITA, qualsiasi azione io faccia all'interno del sito (anche un cambio lingua) il dominio rimane ITA.
Stessa cosa se uso il dominio INGLESE.

Anche la funzione "Auto sign-in /out users from all domains" non funziona; ho abilitato la funzione, disconnesso dai domini (sia EN che ITA) ma continuo a dover fare il login sia per il dominio ITA che per quello EN.

Stessa cosa se provo a modificare un articolo in lingua EN, accedendo dal dominio ITA.

Ho notato che quando uso il selettore lingua, le informazioni vengono passate tramite URL, come se fosse attiva la funzione "Nome della lingua aggiunto come parametro (hidden link)

November 5, 2019 at 4:35 pm #4891627

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Per evitare che gli argomenti vengano passati tramite URL, puoi cambiare il metodo da GET a POST, proprio sotto la definizione dei domini su WPML > Lingue > Formato URL delle lingue.

Ho visto l'errore e vedo che dice:

"Refused to display 'hidden link' in a frame because it set 'X-Frame-Options' to 'sameorigin'."

Questo significa che visto che usi apache, c'è un codice nel .htaccess che probabilmente sta aggiungendo le X-Frame-Options a "sameorigin"

Rimuovi quella riga o chiedi al tuo hosting di cambiare quel valore.

Ecco l'errata per questo problema: https://wpml.org/errata/single-sign-on-feature-not-working-due-to-setting-the-x-frame-options-to-sameorigin/

Saluti.

November 11, 2019 at 2:25 pm #4925659

bossiR

Ciao Alejandro,

il problema persiste.
La mia priorità è risolvere la questione di avere 2 loghi differenti, uno ITA e l'altro EN.
C'è un modo di forzare la scrittura di questo paramentro/stringa?
In questo momento, dopo aver settato i loghi corretti(tramite string translation), basta una piccola modifica agli articoli/pagine per sconvolgere le stringhe del logo ( mi ritrovo quello inglese nel dominio italiano e viceversa).

Qualche idea?

Grazie.

November 11, 2019 at 3:24 pm #4926269

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

"In questo momento, dopo aver settato i loghi corretti(tramite string translation), basta una piccola modifica agli articoli/pagine per sconvolgere le stringhe del logo ( mi ritrovo quello inglese nel dominio italiano e viceversa)."

Questo in effetti non è normale, ma non è nemmeno una cosa che posso riprodurre, ho provato a farlo in un sito di sandbox e niente, quindi per forza ci deve essere qualcosa che sta creando questo problema in questo sito, forse qualche plugin, ecc.

Potresti controllare le credenziali di nuovo, per favore? ho provato ad accedere e niente, non riesco proprio ad accedere più con le credenziali di prima.

Poi, un altra cosa. mi puoi dare i passi per inserire la stringa nel sito per favore? mi sa che c'è qualche passo che ancora mi manca.

Grazie.

November 11, 2019 at 5:15 pm
November 12, 2019 at 10:50 am #4930839

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Il problema che vedo io è che in inglese la fonte dell'immagine non è il dominio principale ma "leformedellacarta.it", dominio che non vedo da nessuna parta.

Per questo il logo sparisce, sinceramente è un miracolo che il logo in Inglese comparisse per la prima volta visto che sembra che tu abbia fatto una migrazione da un dominio all'altro e invece il dominio vecchio ha lasciato qualche traccia attiva ancora sul tuo sito.

Mi sono registrato mentre ti facevo il troubleshooting del problema: hidden link

Se il problema sono di "leftovers" allora puoi usare un plugin come https://it.wordpress.org/plugins/better-search-replace/

lì, puoi selezionare tutte le tabelle del sito e scambiare "leformedellacarta.it" per "leformedellacarta.duckdns.org" e poi vai alla stringa de logo, editala un po, e salvala, così si aggiornerà e funzionerà.

Saluti.

November 12, 2019 at 3:10 pm #4932709

bossiR

Scusami, non mi ero accorto che su WPML il dominio in inglese era impostato su "theformsofpaper.com".

Ti spiego:
abbiamo un sito in produzione "leformedellacarta.it" - "theformsofpaper.com" ma ho richiesto il supporto su "leformedellacarta.duckdns.org" - "theformsofpaper.duckdns.org" cioè il mio sito di test per evitare di lavorare sull'ambiente di sviluppo. Dopo un ripristino dell'ambiente di test è rimasto un refuso del sito copia che abbiamo trasferito.

I due siti sono una copia esatta e girano entrambi su istanza Bitnami.

Mi hai fatto notare che il dominio in inglese del sito di test, era sbagliato (era impostato su "theformsofpaper.com" - cioè usava il dominio inglese del sito in produzione) ma adesso l'ho corretto in "theformsofpaper.duckdns.org". Quindi dovremmo essere allineati.

Detto ciò il problema del logo rimane, a riguardo vorrei farti notare una cosa:
Dopo aver impostato nel string translation di WPML la stringa del logo con l'url corretto sia per l'ITA che per l'ENG e aver verificato il corretto funzionamento in entrambi i domini, per qualche motivo, tornando nel string translation, troviamo un link (all'immagine) diverso da quello impostato. È come se WPML non mantenesse la stringa impostata. In altre parole: quando l'errore si manifesta è perché la stringa di traduzione "cambia da sola".
Chi scrive la stringa al posto nostro? C'è qualche servizio/controllo di WPML che va a sostituire la mia stringa di traduzione?

Grazie

November 12, 2019 at 5:33 pm #4933853

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Penso di aver trovato il problema.

Si tratta della configurazione del formato URL per domini.

Ho visto che su WPML > Lingue > Formato URL per domini > Passa gli argomenti della sessione tra i domini tramite il selettore di lingua

Avevi selezionato "Disabilita questa funzione" e vedo che Divi sembra richiedere un parametro per poter funzionare. tu non lo passi e quindi ogni singola volta L'URL su divi > Theme Optiona > Logo, cambia a quello della traduzione In Inglese ma per la lingua Italiana (e se invece fai tutto questo con il back-end nella versione inglese, si farà lo stesso ma con le nazione contrarie, quindi Italiano default però assegnato alla lingua Inglese).

Sul sito ho cambiato questa opzione a "Passa gli argomenti tramite POST" e ho risalvato i permalink e il problema non succede più.

Puoi provare tu nel sito originale per vedere se il problema sparisce anche lì?

Saluti.

November 13, 2019 at 11:26 am #4938195
bossiR

Ciao Alejandro,

sembra funzionare. Da stamattina, il problema si è ripresentato solo una volta, dopo aver impostato un plugin per le cache e l'ottimizzazione del sito (quindi penso sia "normale" qualche stravolgimento). Dopo aver risettato la stringa e salvato i permalink non si è più ripresentato.
Tengo monitorato e ti faccio sapere.
Invece per quanto riguarda " Autenticazione e disconnessione automatica da tutti i domini " ancora non funziona. Ogni volta che cerco di modificare la sezione WPML > Lingue, se c'è il check "valida al salvataggio", il sistema di restituisce il messaggio "non valido" e sono costretto a togliere il check per poter salvare i cambiamenti. Questo problema può essere correlato?

Grazie mille.

I nuovi thread creati da Alejandro e collegati a questo sono elencati di seguito:

https://wpml.org/it/forums/topic/le-credenziali-non-si-passano-tra-i-diversi-domini/

November 13, 2019 at 5:00 pm #4941593

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Perfetto.

Allora possiamo considerare questo ticket chiuso? l'altro tema l'ho separato in un altro ticket e te l'ho risposto prima.

Se pensi che il ticket si possa chiudere ti prego di farlo o di darmi il permesso di farlo.

Saluti.

November 14, 2019 at 8:00 am #4944507

bossiR

My issue is resolved now. Thank you!