This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 58 risposte, has 2 voci.

Last updated by franzB-5 1 settimana, 3 giorni fa.

Assigned support staff: Alejandro.

Autore Post
September 23, 2019 at 8:26 pm #4626513

franzB-5

Salve, spero di poter parlare con Alejandro dal momento che abbiamo già parlato di questo problema in due diverse occasioni e questa è la terza volta che si presenta lo stesso problema.

Dipende da un bug di incompatibilità tra WPML ed il tema che sto utilizzando (Evora di Flothemes)

In questa occasione stavo scrivendo un articolo del blog ma ho lasciato volutamente la finestra senza salvare l'articolo, nemmeno come bozza. Può essere che si sia salvato come tale in maniera automatica. Il problema è che risulta dall'indicatore numerico, come presente in Bozza [Bozza(1)], ma se clicco su questa tab (Bozza) l'articolo non compare.

Mi è capitata la stessa cosa con i contenuti demo importati del tema. Disattivando tutti i plugin di WPML, si possono vedere tutti questi contenuti "ghost" e quindi poterli rimuovere definitivamente. Poi successivamente si devono riattivare tutti i plugin di WPML.

Questo però per me rappresenta un grave problema, perché questa operazione mi fa perdere le stringhe tradotte personalmente. Queste risultano ancora tradotte da Traduttore Stringhe di WPML, ma in front-end non lo sono.

Alejandro mi aveva suggerito la seconda volta che si è presentato questo problema, di individuare le stringhe che risultano tradotte ma in front-end non lo sono, selezionarle e cancellarle, per poi successivamente tradurle nuovamente.

Ho seguito le indicazioni e le stringhe risultano tradotte da WPML ma in front-end non lo sono.

Ho provato anche in incognito e a cancellare la cache ma nulla è cambiato.

Aspetto una vostra risposta in merito.

Grazie

Non ho potuto inserire le informazioni di debug perché si bloccava il sito (il vostro dove sto aprendo questo ticket)

Il sito è attualmente online quindi non è più hidden link ma semplicemente hidden link

Non appena riceverò una vostra risposta, fornirò i dati d'accesso da amministratore del back-end di WordPress

September 24, 2019 at 9:22 am #4629627

franzB-5

Vi scrivo solo per aggiornarvi che sono online, nel caso in cui fosse disponibile anche Alejandro.
L'ultima volta siamo riusciti a parlare in chat ed abbiamo risolto molto più velocemente la problematica.

Grazie e buona giornata

September 24, 2019 at 3:21 pm #4632839

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Ciao, al momento non penso che serva la chat (più giù ti spiego perché)

Qui in questo ticket vedo 2 problemi che in realtà sono collegati soltanto con il fatto di dover disattivare e riattivare String Translation.

Per quanto riguarda la bozza, che sembra essere il problema principale, prova a fare questo:

❌ Prima di procedere, ti consiglio di fare un backup completo del tuo sito ❌

Vai sul menu WPML > Assistenza > Risoluzione dei problemi
Premi i seguenti pulsanti, e controlla ad ogni premuta di pulsate se il problema si è risolto:
• "Cancella la cache di WPML"
• "Rimuovi dalle tabelle delle traduzioni le voci non correttamente collegate"
• "Correggi il confronto di element_type"
• "Inserisci informazioni sulla lingua"
• "Correggi l'assegnazione del tipo di articolo per le traduzioni"

Fammi sapere come va e se il problema della bozza si risolve.

Invece per la parte delle stringhe. questa volta chiederò ad uno sviluppatore di potermi dare una mano per vedere se lui riesce a trovare l'errore vero e proprio di questo caso perché se la risoluzione del problema cambia ogni volta, vuol dire che è un problema di cache oppure è un bug abbastanza rognoso che dobbiamo cercare di eliminare (ma dobbiamo vedere se il bug è dalla loro parte o dalla nostra). mi ricordo bene tutta la situazione quindi mi mancherebbero soltanto le credenziali del sito per poter inviare il caso direttamente ad uno dei nostri sviluppatori (per questo non ti consiglio la chat questa volta)

Per sicurezza e perché so che il nostro sviluppatore me lo chiederà assicurati di:

1) pulire il cache del sito (se c'è)
2) Chiedere al tuo hosting se puo' pulire il cache del server
3) Quando ti risponderò la prossima volta (quando il nostro sviluppatore entrerà a dare una occhiata) ti chiedo permesso per disattivare tutti i sistemi di cache presenti sul sito (se ci sono)

4) Prima di poter intervenire, ti chiedo di aggiungere anche le credenziali di un account FTP del sito

Spero trovare cosa succede con il sito per evitare che ti continui a succedere in futuro!

September 25, 2019 at 2:57 pm #4640141

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sul log di debug ho trovato che ci sono un sacco di errori. alcuni hanno a che fare con un image resizer (ma non ho idea se viene da un plugin o tema):

Aq_Resize.process() error: Unable to resize image because image_resize_dimensions() failed

Poi, ci sono questi errori che mi pare sono quelli più importanti:

Undefined variable: data in /web/htdocs/www.serenafaraldo.com/home/wp-content/viewcache/298e6b22489b1304d1b8ebed1f0f78d9 on line 9

Questo errore ha a che fare con un tipo di cache che però non ho idea da dove venga (non viene da nessun plugin quindi suppongo viene dal tema stesso). so che si crea sempre e sospetto che il problema possa provenire da lì.

Per ora, potresti gentilmente rinominare la cartella plugins da "plugins-", per qualche ragione l'account FTP che mi hai dato mi ha bloccato dopo quel cambiamento e non sono riuscito a farlo.

Grazie in anticipo.

September 25, 2019 at 3:05 pm #4640173

franzB-5

Ciao Alejandro,
ho rinominato la cartella plugin.
Per quanto riguarda il primo errore che mi hai segnalato (resize immagini), può essere causato da un plugin che ho utilizzato per il ridimensionamento automatico delle immagini. Si chiama "SMUSH". Se sono errori gravi o che possono portare problemi in futuro, fammi sapere se occorre disinstallarlo.

Per quanto riguarda il secondo tipo di errori, non so cosa fare a riguardo. Ho provato a contattare quelli del tema riguardo il problema dei "post fantasma" in bozza, ma non mi hanno saputo dare una soluzione. Posso chiederti di contattarli da parte di WPML essendo il tema compatibile con il vostro plugin multilingua?

O altrimenti dimmi pure cosa posso chiedere nello specifico aprendo un altro ticket.
Tienimi aggiornato su questo problema delle stringhe da dover tradurre.
So che non è colpa vostra, ma vorrei capire cosa poter dire bene alla mia cliente, dal momento che il sito è online ma ancora ha qualche problema.

Ti ringrazio e aspetto tue.
Franz

September 25, 2019 at 3:09 pm #4640261

franzB-5

Per quanto riguarda il primo errore che mi hai incollato nel tuo messaggio di risposta, ho trovato in rete questo articolo:
hidden link
non ho mai installato personalmente questo plugin/script. Può essere che lo utilizza il plugin SMUSH che ti ho indicato? Come posso fare per eliminare anche questo tipo di errori?

September 25, 2019 at 3:20 pm #4640421

franzB-5

Alejandro la mia cliente ha appena riscontrato un problema con un suo cliente. Non è riuscito a contattarla sul form e questo è un problema. Ho notato che i plugin del contact form sono disattivati. Sei tu che stai operando nel back-end? Fammi sapere quanto prima perché fra una mezz'ora mi dovrei vedere con lei.

Grazie

September 25, 2019 at 3:21 pm #4640431

franzB-5

Scusa le tante mail, ma capirai l'urgenza della situazione. Ho notato che tutti i plugin sono disattivati. Mi fai sapere cosa devo rispondere alla mia cliente e fra quanto il sito tornerà funzionante?

September 25, 2019 at 3:26 pm #4640557

franzB-5

Ora che avete i dati di accesso, non si può trasformare questo ticket in chat? Così può essere che risolviamo prima il problema. Oppure ne apro uno nuovo?

September 25, 2019 at 3:42 pm #4640707

franzB-5

Per favore Alejandro, aggiornami un momento sulla situazione. Ho visto che i plugin sono riattivati ma non si vedono più i form di contatto (ne dal back-end ne dal front-end), il plugin di instagram non funziona e non vengono richiamate le foto e anche il plugin dei cookie non fa visualizzare come si deve il messaggio.

September 25, 2019 at 3:48 pm #4640725

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

ho visto tutto e ho anche cambiato quello che rendeva il sito lento. potresti controllare per favore l'accesso FTP. a questo punto so che non posso più cambiare niente. c'è qualcosa in questo account che mi blocca quando provo a cambiare/scaricare il wp-config oppure i file della cartella wp-content.

September 25, 2019 at 3:49 pm #4640751

franzB-5

Ok una cosa alla volta allora.
Cosa hai bisogno che controlli di preciso? Non capisco perché non riesci ad accedere.
Forse perché ho effettuato anche io l'accesso? Disconnetto filezilla e non entro più nel backend, però tu tienimi aggiornato. Io ti rispondo tempestivamente

September 25, 2019 at 3:51 pm #4640755

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hai detto:

""SMUSH". Se sono errori gravi o che possono portare problemi in futuro, fammi sapere se occorre disinstallarlo."

Se ti è possibile, disinstallalo per vedere che altro errore uscirà.

Per il resto. quello che dobbiamo fare è migrare il sito perché ho provato a ricreare il tutto in un ambiente di sandbox e non riesco a riprodurre il problema. neanche con il tema. quindi penso si tratti di qualcosa che si vede sul tempo e questa cartella di cache (viewcache) è quello che mi crea più dubbi su tutti.

Per quanto riguarda il problema del modulo di contatto, prova ora, che il codice che avevo inserito io per non far crashare il sito è già stato tolto.

September 25, 2019 at 3:56 pm #4640841

franzB-5

Per quanto riguarda i problemi di accesso all'account FTP ho visto che hai installato un plugin WP File Manager per avere l'accesso. Può essere che c'è bisogno di abilitare il tuo IP per poter accedere all' FTP. Sono limitazioni del server che imposta automaticamente. Fammi sapere il tuo indirizzo IP così lo abilito subito.

SMUSH ho paura che disabilitandolo si creino problemi ulteriori che porterebbero ad avere il sito non funzionante online. Quindi per ora preferirei lasciarlo così e vediamo in un secondo momento di disattivarlo ed eliminarlo. Non posso proprio dire ora alla cliente che il sito potrebbe ripresentare problemi in futuro.

Mi fai sapere cosa hai fatto quando dici che hai alleggerito il sito?
Provo il contact form per vedere se funziona tutto.

September 25, 2019 at 4:03 pm #4641037

franzB-5

Il form funziona. Aspetto tuoi aggiornamenti.