This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

This topic contains 2 risposte, has 2 voci.

Last updated by Laura 4 mesi, 3 settimane fa.

Assigned support staff: Laura.

Autore Post
June 17, 2019 at 9:15 am #4033713

sebastianoC-2

Sto tentando di installare l'aggiornamento WPML Multilingual CMS 4.2.7.1

Invece ho ottenuto:

Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /var/www/vhosts/heladeriadulcepaladar.es/httpdocs/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php on line 810

June 18, 2019 at 9:15 am #4041883

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Salve,

grazie per averci contattato.

Potrebbe essere un bug introdotto dalla nuova versione, ma ti chiederei di effettuare queste operazioni:

1. aggiorna WordPress all'ultima versione
2. aumenta il WP Memory Limit, aggiungendo questo snippet all'inizio del file wp-config.php, dopo il tag di apertura <?

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

Il file wp-config si trova nella root del sito, è lo stesso file che contiene la configurazione del database. Per modificarlo ti servirà un accesso FTP o SFTP. Per controllare il valore registrato del WP Memory Limit puoi andare in WPML -> Assistenza
Ulteriori informazioni:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/
3. verfica se è possibile aumentare le versioni di MySQL e PHP. La versione minima richiesta di MySQL è la 5.6, e tu hai la 5.5.5. La versione minima richiesta di PHP è la 5.6, ma è consigliabile averne una più alta.

June 26, 2019 at 8:31 am #4090471

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+01:00)

Ciao,

sembrerebbe essere un problema di versione di PHP. Abbiamo pubblicato un erratum al riguardo: https://wpml.org/errata/parse-error-syntax-error-unexpected-t_class-and-other-errors-when-using-php-versions-older-than-5-6/

Fammi sapere se così risolvi o se hai bisogno di ulteriore assistenza.