This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Etichettato: 

This topic contains 3 risposte, has 2 voci.

Last updated by Alejandro 4 mesi, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
June 9, 2019 at 6:36 pm

Gianmatteo

salve,
abbiamo un problema nelle lingue tradotte del sito: in italiano, lingua predefinita funziona tutto bene, mentre in inglese, spagnolo e francese non funzionano i link: ad esempio sono in una pagina in italiano e clicco su una bandiera per andare su un'altra lingua e restituisce l'errore 404 oppure mi rimanda ad una pagina con la foto della categoria con i commenti sotto. l'errore persiste se da una lingua straniera voglio andare ad un al'altra sempre tramite le bandiere. l'errore accade anche cliccando sulle categorie e nei prodotti quando si è in una lingua tradotta. il problema che non riesco a capire perchè si verifica random e non sempre, ad esempio quando restituisce l'errore faccio refresh una o più volte e funziona. a volte l'errore non capita proprio. faccio presente che i link, le traduzioni, i permalink, la sincronizzazione sono tutti a posto e le pagine esistono tutte in tutte le lingue. ho fornito i dati per l'accesso, e disattivato il plugin della cache ed il plugin 301-404 in modo tale che possiate vedere l'errore, nel plugin 301-404 per i redirect potete vedere i logs in oggetto. grazie

June 10, 2019 at 11:26 am #3987113

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Di solito questo succede quando c'è un plugin di caching attivo e si sono fatti dei cambiamenti ai file di WordPress/tema/plugin, cioè quando un file viene modificato.

Molte volte capita pure quando fai una migrazione o campi la struttura dei permalink, perché il cache non è stato pulito e quindi cerca di trovare l'informazione di una pagina con un dominio oppure una struttura URL che non è quella giusta.

Al momento ho pulito il cache e ho controllato diverse pagine in diverse lingue.

Ti consiglio di visitare il sito in modo incognito oppure di pulire il cache del tuo browser e di controllare di nuovo.

Se il problema succede di nuovo allora prova a fare questo:

Segui le istruzioni che trovi in questo link per creare un registro di debug: https://wpml.org/documentation/support/debugging-wpml/

Dopo di aver inserito nel tuo file wp-config.php il codice presente nel link di sopra, cerca di ricreare il problema e poi vai alla cartella "wp-content" della tua installazione WordPress. Se ci saranno stati problemi nel sito comparirà un file "debug.log"

Se lo trovi, per favore caricalo nella piattaforma di archiviazione di tua preferenza (Google Drive, Dropbox, ecc) e poi incolla il link nella tua risposta (assicurati che sia condivisa con i permessi giusti altrimenti non potrò accedere al suo contenuto).

Dopodiché darò una occhiata al file e determinerò quale strada prendere.

June 10, 2019 at 12:39 pm #3987439

Gianmatteo

ciao,
non sono stati fatti cambiamenti ed il plugin di cache è disattivato, naturalmente se il problema persiste farò come da istruzioni, in ogni caso segnalo che disattivando tutti plugin yoast sembra rientrato tutto, stiamo monitorando. eventualmente segnaleremo la cosa a yoast e se lo vorrete fare anche voi sarebbe importante, grazie

June 10, 2019 at 2:02 pm #3987871

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Assolutamente,

Facci sapere cosa succede, noi siamo anche in contatto diretto con gli sviluppatori di Yoast quindi sarebbe bello se ci informaste pure a noi su quello che succede.

Più dettagli ci darai e meglio (e possibilmente più velocemente) riusciremoa trovare il problema per procedere a risolverlo.

Saluti.

The topic ‘[Closed] problema errore 404 nelle traduzioni del sito’ is closed to new replies.