This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 6 risposte, has 2 voci.

Last updated by mattiaT-4 1 mese, 1 settimana fa.

Assigned support staff: Alejandro.

Autore Post
September 9, 2019 at 8:05 pm

mattiaT-4

Sto tentando di: fare sincronizzare le categorie del sito web create in 3 diverse lingue. Questo problema si è presentato negli ultimi 7-10 giorni perché prima il sito è sempre perfettamente funzionato. La sincronizzazione delle pagine e dei post avviene correttamente mentre ora le categorie, seppur correttamente tradotte, non si vedono più in italiano e francese. Ho aggiornato all'ultima versione di WordPress oltre che alle ultime versioni dei plugin Wpml ma nulla è cambiato. In questo periodo nessuna modifica al sito è stata effettuata e per tal ragione non capisco a cosa possa essere dovuto.

Il sito con tutti i componenti di Wpml erano stati installati sul .blog e successivamente trasferiti con successo sul .com - Il passaggio non aveva comportato alcun problema.

Link a una pagina dove è possibile vedere il problema: hidden link - cliccando su una qualsiasi categoria (moda e sotto elementi si vieni rimandati alla versione in inglese).

Mi aspettavo di vedere: la rispettiva categoria in italiano quindi: hidden link

Invece ho ottenuto:hidden link

September 10, 2019 at 6:42 am #4542263

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Ho dato una occhiata al sito e ho visto alcune cose.

1) se apro l'inspector di chrome, vedo diversi errori, alcuni abbastanza importanti (basta premere f12 e posizionarsi sulla scheda "console" per vederle

2) Quando provo ad aprire alcune pagine del sito, ottengo un errore 523 che di solito significa che il sito e cloudflare non riescono a comunicare tra di loro. questo anche mi dice che stai usando cloudflare, giusto?

3) se posiziono il mouse sul language switcher, vedo che i link sono corretti e nella lingua giusta ma per qualche ragione non posso accedere a nessun'altra lingua delle categorie.

Ti chiedo gentilmente di pulire il cache di cloudflare un attimo e poi di metterlo in pausa per poter controllare il sito senza (e di fare lo stesso con sg optimizer e se è possibile disabilitarlo temporaneamente)

Prova pure tu se disabilitando entrambi, il problema si risolve, perché sembra che qualcosa sta creando alcuni problemi e potrebbe essere una configurazione a livello di caching.

Fammi sapere come va.

September 10, 2019 at 8:03 am #4542785

mattiaT-4

Ciao Alejandro e grazie per la risposta.

Ho provato a pulire la cache di Cloudflare + quella di Sg Optimizer ma non è cambiato nulla. Ho successivamente disabilitato entrambi e purtroppo ancora nulla.

Non riesco a capire a cosa possa essere dovuto questo problema, dato che è sempre ben funzionato da quando siamo andati online ed anche durante la fase di sviluppo.

I plugin utilizzati sono stati installati sin dall'inizio dello sviluppo e non ne sono stati aggiunti altri. Ieri ho disabilitato il token di Wpml da vecchio .blog ed installato sul .com per elaborare gli aggiornamenti.

Potrebbe essere un problema del tema?

Spero tu mi possa aiutare 🙂

Grazie

September 10, 2019 at 10:10 am #4543839

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ho Trovato il problema.

In pratica Yoast stava gestendo la struttura dei permalink e questo va benissimo, però non hai il nostro plugin Yoast Multilingual, quindi penso che basterebbe installarlo e poi attivare anche Yoast (che al momento l'ho disattivato) e il problema dovrebbe sparire.

Provaci e fammi sapere come va.

September 10, 2019 at 10:34 am #4544237

mattiaT-4

Ciao, questa mattina ho fatto un pò di test ed effettivamente avevo trovato un problema con Yoast, poichè disinstallando i vari plugin uno x uno, questa era l'unico che portava delle modifiche al problema.

Infatti cercando la sincronizzazione delle categorie, non risolvevo il problema ma almeno venivo indirizzato alla home page della lingua selezionata.

Ho controllato anche gli aggiornamenti dei plugin e le modifiche apportate al sito, ed effettivamente il 3 Settembre ho aggiornato il plugin di Yoast, che nella versione free ha apportato l'ultima release in quella data.

Ora ho aggiornato nuovamente WordPress all'ultima versione + tutti gli aggiornamenti di Wpml + installazione del plugin Yoast x Wpml, ma purtroppo quel problema non si è risolto.

Ancora non mi sincronizza le categorie, mentre pagine e post sono ok. La struttura dei permalink è fondamentale che rimanga: category / namepost.

C'è qualche setting da implementare nella versione Yoast per Wpml?

September 10, 2019 at 5:13 pm #4547649

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

No, in realtà Yoast WPML non fa altro che assicurare la compatibillità. ma ho controllato le configurazioni di Yoast del tuo sito e ho visto che avevi scelto di rimuovere la categoria (lo vedi su Yoast > Search Appearance > taxonomies > Category URLs )

Ho disattivato questa funzionalità e voila! problema risolto (o al meno così sembra)

Controlla e fammi sapere se ora anche a te va (forse dovrai pulire il cache del browser per vedere i risultati)

Saluti.

September 11, 2019 at 1:54 pm #4553869

mattiaT-4

My issue is resolved now. Thank you!