This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Nessun supporter è disponibile a lavorare oggi sul forum Italian. Sentitevi liberi di creare ticket e li gestiremo il prima possibile quando saremo online. Grazie per la comprensione.

Etichettato: 

This topic contains 17 risposte, has 2 voci.

Last updated by dermotricosS 2 settimane, 2 giorni fa.

Assigned support staff: Alejandro.

Autore Post
July 29, 2019 at 10:04 am #4298541

dermotricosS

Sto tentando di: tradurre le pagine riservate del mio sito

Link a una pagina dove è possibile vedere il problema: hidden link

Mi aspettavo di vedere: sono riuscita a tradurre tutte le pagine del plugin Ultimate Member, tranne la pagina dell'utente

Invece ho ottenuto: anche cliccando la bandierina inglese, non vedo il testo tradotto

July 29, 2019 at 11:40 am #4299317

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao!
Benvenuto al supporto cliente WPML.
Farò del mio meglio per aiutarti a risolvere questo problema.

Non sono molto sicuro di come funzioni questa pagina ma i plugin simili di solito aggiungono un shortcode per quelle pagine, giusto?

Da questa documentazione sembra che questo sia il tuo caso: hidden link

Puoi dare una occhiata e dirmi se per caso questo risolve il tuo problema? vedo che c'è una opzione dove ti si domanda se la pagina in question è quella dell'account o del profilo. mi sa che una di quelle opzioni è quella che desideri tradurre tu.

Provaci e fammi sapere come va.

July 29, 2019 at 12:25 pm #4299581

dermotricosS

Ciao Alejandro grazie del tuo aiuto, ho provato a seguire le istruzioni del link che mi hai indicato, ma purtroppo nella mia configurazione, non vedo i campi del punto 3 nel quadrato rosso indicati nel tuo link. Quindi non posso procedere...

July 29, 2019 at 1:03 pm #4299993

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sarebbe davvero utile chiedere al supporto di ultimatemember se ti possono dire dove si trovano ora queste opzioni perché forse sono state spostate in un altro modo.

Io, però, ti posso dare una mano dando una occhiata da vicino al sito, in modo da poter capire se per caso le cose sono cambiate.

Ho appena attivato i campi appositi per l'inserimento delle credenziali di cui ho bisogno. Questi campi sono privati quindi soltanto noi due potremo vederle e accedervi.

Suggerisco di creare un utente temporaneo, segnarlo come amministratore e poi inserire le credenziali nei campi appositi appena attivati.

July 29, 2019 at 1:43 pm #4300377

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi sa che quella opzione non esiste più. ho provato ad accedere alla pagina che menzioni sopra ( hidden link ). e vedo quello che ho allegato nello screenshot qui sotto.

Forse però tu intendi un altra cosa? se è così, mi potresti dire come posso vederlo perché finora sembra che tutto sia apposto.

Se lo devo vedere come un utente iscritto e non come admin, mi potresti inviare le credenziali dell'utente con cui posso vedere questo problema?

Grazie.

July 29, 2019 at 1:47 pm #4300413

dermotricosS

Questo è il link che non viene tradotto in inglese. hidden link

Ovvero le singole aree private dei vari utenti

July 29, 2019 at 2:05 pm #4300629

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, mi sa che il problema è in effetti un problema di compatibilità, ho visto che l'unico problema è che nel link il plugin inserisce tanto il parametro della lingua come quello dell'ID del cliente.

Potresti per favore caricare qui questo plugin: hidden link

E poi potresti creare un membro come hai fatto nel tuo sito, e poi elencare i passi su come l'hai fatto?

Con questo test vorrei isolare il problema per cercare di trovare la riga di codice nel plugin di ultimate member che sta creando questo problema.

Grazie in anticipo per l'informazione.

July 29, 2019 at 2:47 pm #4301057

dermotricosS

Ho caricato il plugin, devo ricreare le stesse pagine che ho nel mio sito?

July 29, 2019 at 3:01 pm #4301305

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Al momento mi interessa soltanto quella dei profili degli utenti. quella simile a questa: hidden link

quindi ricrea quella pagina ma dimmi anche come hai fatto a ricrearla perché mi servirà per poter studiare il problema ed eventualmente trovare una soluzione.

July 29, 2019 at 3:12 pm #4301353

dermotricosS

Questa è la pagina ricreata: hidden link
in questo caso ho lasciato creare le pagine al plugin, in automatico ha creato tutte le pagine. Nel mio caso ho prima creato la pagina e poi inserito lo shortcode relativo all "user" nella pagina user, e tutti gli altri short code nella pagine corrispondenti. (come puoi vedere dal pannello amministrativo di ultimate mambers>settings>pages)
Poi nel pannello amministrativo di ultimate member in settings>general>users ho impostato "Profile Permalink Base" ->user-id e "User Display Name" -> First name only.
Successivamente ho tradotto tutte le pagine del plug-in si sono tradotte tutte tranne quella relativa agli user

July 29, 2019 at 3:23 pm #4301417

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, vedo che il problema, come pensavo, si riprodurre anche qui. proverò a trovare la causa del problema e se non ci riesco, gliela invierò ai nostri sviluppatori.

Appena avrò più notizie ti aggiornerò

Saluti.

July 29, 2019 at 3:31 pm #4301453

dermotricosS

Grazie mille, sei stato gentilissimo!
Attendo tue notizie

July 30, 2019 at 11:29 am #4307173

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Effettivamente si tratta di un piccolo bug nel codice di Ultimate Member. Ho già inviato il caso ai nostri sviluppatori che potranno aiutare gli autori del plugin a sistemare il problema.

Comunque, in caso possa esserti utile, questo problema esiste soltanto quando il formato url del sito è messo con parametri, il che è un'opzione di WPML.

Se invece per te non è un problema, puoi usare l'url per directory, così invece di avere il sito come:

domain.com?lang=en

lo potrai vedere come: domain.com/en

con questa configurazione, il shortcode (che è quello che sta creando problemi) funziona bene.

Se ti pare una soluzione fattibile per il tuo caso, basta andare su WPML > Lingue > Formato degli URL per le lingue > Seleziona Directory con lingue diverse.

Poi vai su Impostazioni > Permalink > Premi il pulsante "salva" e vedrai che il problema non ci sarà più.

Saluti.

September 27, 2019 at 9:07 am #4652629

Alejandro
Supporter

Languages: Inglese (English ) Spagnolo (Español ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello. it seems the new version of Ultimate Member has fixed this issue.

I tested it on a new sandbox which you can find below but i'd like you to take a look at it and see if there's any missing piece or anything that i'm missing.

hidden link

The new version is 2.0.56 (so 2 minor versions from the one you had).

Let me know how it goes.

September 30, 2019 at 8:31 am #4662947

dermotricosS

Hi Alejandro,
Thank you for your assistance.

I upgraded my plugin to the last version (2.0.56) but the problem is still there.

Bye bye