This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.36 hours from now. Thank you for your understanding.

Etichettato: 

This topic contains 8 risposte, has 2 voci.

Last updated by Laura 4 mesi, 3 settimane fa.

Assigned support staff: Laura.

Autore Post
May 8, 2019 at 1:03 pm #3766893

katiaC-3

Link a una pagina dove è possibile vedere il problema:
in home hidden link
e nel backend dalla sezione Personalizza

Ho dei problemi col Personalizza (Customizer) del sito.
Il tema installato è custom.
La lingua principale del sito è il tedesco.
Io lavoro in backend con la lingua italiana.

Il problema attuale è questo:
Cercando di inserire dei dati nei campi del Personalizza, questi non vengono salvati e vengono resettati ai valori precedenti (i vecchi dati si riconoscono facilmente perché sono in lingua italiana).

Se provo a modificare un solo campo di tutti quelli presenti (non uno di più), allora quel campo viene salvato correttamente col nuovo valore (per esempio in questo momento il testo introduttivo della homepage è in tedesco).

Una volta che quel dato (in tedesco) è stato salvato, quando esco e rientro nel Personalizza, vedo il vecchio dato (in italiano) e non quello nuovo (in tedesco), mentre sul sito quel dato compare correttamente in tedesco.

Se provo a modificare più di un dato, al momento del salvataggio resetta tutto e tornano i vecchi dati in italiano per tutti i campi del Personalizza e anche lato front-end.

Aggiungo anche che il sito era stato creato inizialmente in una versione di demo che aveva come lingua principale l’italiano.
Una volta spostato in produzione ho fatto un cambio della lingua principale, ma così facendo rischiavo di perdere tutte le traduzioni e così con delle query dirette su DB ho fatto in modo che le stringhe in tedesco risultassero come quelle da tradurre, e quelle in italiano risultassero le loro traduzioni (ho fatto, per così dire, uno “scambio di ruoli” delle stringhe).
Se si va nella sezione “Traduzione stringhe” infatti compaiono le stringhe in tedesco con le relative traduzioni in inglese e italiano.
Ma entrando in Personalizza, si vedono solo le stringhe in italiano e accade appunto quanto spiegato all’inizio.

Come ho provato a risolvere:
Ho provato ad applicare i consigli che voi date qui https://wpml.org/it/documentazione/guida-introduttiva/tradurre-le-opzioni-del-tema-e-di-customizer/ in particolare l’ultimo paragrafo sul valore di max_input_vars.
Purtroppo:
- non è possibile cambiare il php.ini del server (server condiviso)
- aggiungendo in .htaccess la riga php_value max_input_vars 10000 non funziona più il sito
- ho provato a modificare wp-config.php aggiungendo la riga @ini_set('max_input_vars', 10000); senza ottenere alcun cambiamento sul valore, che al momento è di 2575.

Quello che vorrei in conclusione è:
- mantenere come lingua principale lato front-end il tedesco
- inserire nel Personalizza i dati in tedesco e trovarmeli tradotti poi in italiano e inglese (sperando di non dover ritradurre tutto)

May 8, 2019 at 3:53 pm #3768795

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Salve,

grazie per averci contattato.

Da come descrivi il problema, potresti provare a tradurre le voci del Customizer direttamente in Traduzione Stringhe.

Considera che se il sito in precedenza aveva come lingua principale l'italiano ora probabilmente le stringhe italiane sono considerate essere in tedesco. Questo perché la lingua principale di WPML sul tuo sito è il tedesco quindi qualunque contenuto ci fosse al momento dell'installazione per WPML è in tedesco.
Perciò probabilmente dovresti cercare le stringhe in traduzione stringhe, cambiare la lingua da tedesco a italiano e a quel punto tradurle in tedesco.
Spero di essermi spiegata.

Ti premetto che purtroppo non possiamo supportare codice personalizzato, temi inclusi, perciò nel caso fosse necessario un esame approfondito del codice non potremmo aiutarti, ma credo che se il tema è correttamente configurato per l'internazionalizzazione sia possible risolvere il problema.

May 9, 2019 at 1:46 pm #3776633

katiaC-3

No, forse non sono riuscita a spiegarmi bene. Purtroppo in Traduzione Stringhe, le stringhe da tradurre sono già in tedesco e hanno la bandierina tedesca (v. immagine allegata).

Nella versione in tedesco del sito però, come vedi anche online, si vedono le stringhe in italiano.
È come se venissero letti due dati differenti o qualcosa del genere.

Qualche mese fa mi avete fatto assistenza sullo stesso sito, da quando la cosa non è più possibile?

May 10, 2019 at 7:42 am #3782037

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

il problema precedente per cui avevi aperto il ticket non riguardava il tema nello specifico. Inoltre non è che non diamo assistenza, ma se il problema richiedesse la modifica del tema o un ulteriore debug da parte degli sviluppatori, questo non sarebbe possibile in quanto il tema è custom.

Puoi fornirmi le credenziali del sito, preferibilmente di una versione di test, così posso individuare meglio il problema? Abilito una risposta privata.

May 17, 2019 at 3:33 pm #3835759

katiaC-3

Scusate ragazzi non riesco nemmeno oggi a crearvi una versione di test. Spero entro domenica di farcela!

May 18, 2019 at 7:47 am #3838469

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Nessun problema.

May 20, 2019 at 8:53 am #3845063

katiaC-3

Eccomi! Ora ho gli accessi alla versione di test, vedo però che non è più attiva la risposta privata.

May 21, 2019 at 1:04 pm #3855395

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

La risposta privata, se rispondi e non la utilizzi, non si può più usare.
Ne abilito un'altra.

May 22, 2019 at 7:10 am #3861729

Laura
Supporter

Languages: Inglese (English ) Italiano (Italiano ) Portoghese, Brasile (Português )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

ho trovato le stringhe presenti nel Customizer nella pagina delle stringhe di amministrazione (il link è in fondo a Gestione Stringhe). Sono sotto l'opzione [theme_mods_sprachschneiderei]

Dal momento che non è possibile salvarle da lì perché non si può aumentare il valore di MaxInputVars, devi aggiungerle al file xml-config come era suggerito già nella guida che hai consultato. Per utilizzare questa opzione però è necessario installare Translation Management, che tu non hai. Ho provato a farlo manualmente ma questo ha causato un errore 500, e non riesco ad accedere via FTP quindi non posso fare ulteriori test.

La procedura da seguire quindi sarebbe:
- aggiorna WPML e String Translation
- installare Translation Management
- andare nella pagina delle stringhe di amministrazione e individuare le stringhe del Customizer (il modo più veloce è aprire il codice sorgente della pagina e cercare il testo con il comando "Trova")
- aggiungere le stringhe in WPML -> Settings -> Custom XML configuration seguendo questa guida: https://wpml.org/documentation/support/language-configuration-files/#admin-texts
- dopo che sono state aggiunte, andare nell'homepage e aggiornare la pagina
- a questo punto le dovresti trovare in String Translation

Molto probabilmente le troverai con la bandiera tedesca, dal momento che il tedesco è la lingua di default. A quel punto devi cambiare la lingua in italiano (con l'opzione "cambia lingua delle stringhe selezionate") e poi le puoi tradurre in tedesco.

Fammi sapere se così risolvi o se hai bisogno di ulteriore assistenza.