This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problema: Quando provo ad aggiornare i plugin ricevo questo errore: WPML Multilingual CMS: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature Soluzione: 1. Verifica gli aggiornamenti. ❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Vai su Bacheca -> Aggiornamenti - Premi il pulsante "Verifica di nuovo" - Vai su Plugin -> Aggiungi nuovo -> Commerciale - Premi il pulsante "Controlla aggiornamenti" - Prova a scaricare la versione aggiornata dei plugin WPML

2. Prova ad aggiornare i plugin dalla pagina Plugin -> Plugin installati

3. Prova a disattivare temporaneamente i plugin WPML e ad aggiornarli mentre sono disattivati.

4. Se il problema non si risolve prova a rimuovere la registrazione di WPML dal sito e a registrare il sito nuovamente. - Puoi farlo da Plugin -> Aggiungi nuovo -> Commerciale - Se ricevi errori mentre registri il sito prova a disabilitare l'opzione "Keep wpml.org up-to-date about which theme and plugins I use" e riprova.

5. Se tutti i metodi precedenti non hanno funzionato, puoi effettuare un aggiornamento manuale. - Scarica le versioni più aggiornate dei nostri plugin da qui: https://wpml.org/account/downloads/ - Vai su Plugin -> Plugin installati - Disabilita e cancella le vecchie versioni dei plugin WPML - Premi il pulsante "Aggiungi nuovo" - Premi il pulsante "Carica plugin" - Seleziona la versione appena scaricata di WPML ed installala, a partire dal plugin WPML Multilingual CMS

Autore Post
May 3, 2019 at 8:23 am #3732101

cristinaB-9

Sto tentando di: di aggiornare alcuni dei vostri servizi come richiesto ma quando provo a farlo il sistema mi dice che ci son degli errori. Allego il messaggio di errore.

Advanced Custom Fields Multilingual: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML All Import: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML CMS Nav: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML Media: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML Multilingual CMS: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML Sticky Links: Il pacchetto non può essere installato. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
WPML String Translation: Il download non è andato a buon fine. Not Found
WPML Translation Management: Il download non è andato a buon fine. Not Found

Come posso risolvere ed avere i plugin aggiornati all'ultima versione?

Grazie
Francesco.

May 3, 2019 at 8:54 am #3732401

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Salve Francesco, grazie per aver contattato il supporto WPML!

Potrebbe trattarsi di un problema momentaneo.

Prova questi passaggi:

1. Verifica gli aggiornamenti.
❌ Assicurarsi d'avere un backup del sito prima di procedere! ❌

- Vai su Bacheca -> Aggiornamenti
- Premi il pulsante "Verifica di nuovo"
- Vai su Plugin -> Aggiungi nuovo -> Commerciale
- Premi il pulsante "Controlla aggiornamenti"
- Prova a scaricare la versione aggiornata dei plugin WPML

2. Prova ad aggiornare i plugin dalla pagina Plugin -> Plugin installati

3. Prova a disattivare temporaneamente i plugin WPML e ad aggiornarli mentre sono disattivati.

4. Se il problema non si risolve prova a rimuovere la registrazione di WPML dal sito e a registrare il sito nuovamente.
- Puoi farlo da Plugin -> Aggiungi nuovo -> Commerciale
- Se ricevi errori mentre registri il sito prova a disabilitare l'opzione "Keep wpml.org up-to-date about which theme and plugins I use" e riprova.

5. Se tutti i metodi precedenti non hanno funzionato, puoi effettuare un aggiornamento manuale.
- Scarica le versioni più aggiornate dei nostri plugin da qui: https://wpml.org/account/downloads/
- Vai su Plugin -> Plugin installati
- Disabilita e cancella le vecchie versioni dei plugin WPML
- Premi il pulsante "Aggiungi nuovo"
- Premi il pulsante "Carica plugin"
- Seleziona la versione appena scaricata di WPML ed installala, a partire dal plugin WPML Multilingual CMS

Fammi sapere se così risolvi o se hai bisogno di maggiori informazioni.

Grazie

May 6, 2019 at 1:51 pm #3749405

cristinaB-9

Ciao Vincenzo, grazie per il supporto, ho eseguito la procedura da te descritta arrivando al punto 5 ed ora i plugin wpml risultano aggiornati.

L'unica cosa che non capisco è perchè mi appare questo messaggio.
ti allego foto del bckend.

Grazie mille.
Francesco.

May 6, 2019 at 1:54 pm #3749485

Vincenzo
Supporter

Languages: Inglese (English ) Italiano (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao Francesco,

Sono contento che il problema sia risolto.

Quel messaggio appare solo perché nel sito è attivo il plugin WPML All Import, ma non disponi di WP All Import.

Per rimuovere il messaggio ti basta disattivare e disinstallare il plugin WPML All Import perché non è necessario.

Grazie

Documentazione relativa:
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

May 6, 2019 at 2:00 pm #3749553

cristinaB-9

My issue is resolved now. Thank you!